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1. What's New - version 2301
Changes and enhancements made to Femap for version 2301 are listed here and in the Femap version
2301 readme file.

Teamcenter Integration

Femap v2301 adds support for direct integration with Teamcenter so Femap files can be managed via
the Teamcenter Environment and is accessed by using commands on the Teamcenter sub-menu found
on the new PDM → Teamcenter menu or Teamcenter toolbar. This new functionality includes check-in
and check-out from the Teamcenter Rich Application Client (RAC), along with the ability to import
assemblies of individual JT geometry files stored within the Teamcenter environment as an assembly.

Teamcenter Rich Application Client (RAC)

Femap requires the Teamcenter Rich Application Client (RAC) for implementation. Teamcenter Items
must to be created in RAC before they can be used with Femap. Refer to Teamcenter documentation for
installation/setup instructions.
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Note:

The Teamcenter Rich Application Client (RAC) is required, and comes from Teamcenter, but
there are different ways to install Teamcenter. Teamcenter Client Communication System
(TCCS) is the Teamcenter product required to run the Femap integration with Teamcenter. The
FMS_HOME environment variable needs to be created if not already created, and pointed to a
valid Teamcenter Client Communication System (TCCS).

Teamcenter Sign On

Sign on to Teamcenter from inside Femap by selecting PDM → Teamcenter → Sign In. When you are
signed in, you are connect to your own Teamcenter Environment. This allows you to do item check-in
and check-out operations, and manage item revisions and revision history.

1. What's New - version 2301
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When you are signed in, you will get confirmation in the Messages pane.

Note:

You will need to connect and Sign-in to Teamcenter the first time Teamcenter commands are ran
in that session of Femap.

File Operations - Save from Femap to Teamcenter

When you save a Femap model (PDM → Teamcenter → Save), you are checking in that file/item.
When you save a Femap file to Teamcenter for the first time, you must enter a New Dataset Name.
The dataset that you create here hosts the Femap .modfem file, and is required to support the Item in
Teamcenter. You must also maintain a Source location (where you save to) for the Femap files locally.
This Source folder is where Teamcenter will transact with your Femap files.

Teamcenter Integration
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File Operations - Open in Femap from Teamcenter

When you open a Femap model (PDM → Teamcenter → Open), you are checking out that file/item.

Note:

The Item has Revision, Dataset Name, Filename, Release Status, Checked Out By, Last
Modified, and Last Modified By information. These are updated each time the Item is checked
in/out, providing a history of the Item.

1. What's New - version 2301
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File Operations - Import JT Assembly Item ID’s from Teamcenter into Femap

Femap uses a generated JT model on each Item revision to import geometry. This accomplished in
Femap via the PDM → Teamcenter → Import JT Assembly command. Upon import, Femap looks
at each assembly in Teamcenter using the BVR (BOM View Revision) to find associated part ID’s and
sub-assembly ID’s. JT files can be generated/saved from multiple CAD systems within Teamcenter.

The PDM → Teamcenter → Import JT Assembly command allows for the JT assembly models to be
directly imported into Femap from Teamcenter.

Teamcenter Integration
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Create a Teamcenter Item to Save Femap Files To

To save files to Teamcenter from Femap, an item must already exist within Teamcenter. To do this, it is
required you install the Rich Application Client (RAC).

1. What's New - version 2301
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You create the item in the Rich Application Client (RAC) New Item dialog. ID and Revision are applied
automatically. All you need to do is enter a Name for the new Item.

Teamcenter Integration
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Now the Femap Model Files can be saved to the newly created Item.

Save a Femap Model to Teamcenter

After the Teamcenter Item is created in the RAC, select PDM → Teamcenter→ Save from within Femap.

1. What's New - version 2301
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Note:

You must sign-in and connect to the Teamcenter server if you are starting a new session of
Femap.

Note:

If the Femap file hasn’t been saved to the disk, you must first save it to the computer. This is
known as the source file with which Teamcenter works.

Search for the Item ID you created in the RAC previously.

Tip:

Take note of the Item ID when you create the item in the RAC. You will need to remember the
Item ID in order to Search for it in the Femap Save to Teamcenter dialog.

Teamcenter Integration
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Select the correct object/Item ID from the list that you want to save to, and enter a name for the Femap
Model dataset that you will see in Teamcenter.

Activate the Check-in option, and click Save if you are finished with the Femap model. If you are not
finished, leave Check-in unchecked, press Save and continue working. Activating Check-in will create
the Femap model.

Leaving Check-in unchecked then saving, will leave the dataset checked out to you, as you can see in
the Teamcenter RAC.

1. What's New - version 2301
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Now activate Check-in to check in the file into Teamcenter, and save the file to Item ID you saved to
previously. Click Save. Select yes when prompted to overwrite the dataset.

When the file has saved successfully (shown in the Messages pane) the file becomes read only. The file
name shown changes to the Teamcenter Item ID and revision.

And in the Teamcenter RAC the Femap file/dataset is shown as checked-in.

Teamcenter Integration
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Open a File from Teamcenter Using Femap

After the Teamcenter Item has been populated with the Femap files, select PDM → Teamcenter→
Open from within Femap. Search for the Item ID like you did previously to Save.

Make sure Check-out is activated to check out the file from Teamcenter, otherwise, the file will open
as read only and will not be checked out to you. Click Open to check out and open the file from
Teamcenter. The Item has a new Revision (B) and a Filename which will be saved to the local Dataset
Name Destination.

Note:

If the file is already open on your computer, you need to overwrite the old destination file
information.

1. What's New - version 2301
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In the Teamcenter Rich Application Client (RAC), the new revision has been created in the Item
structure, and it is checked out.

After you complete your work in Femap, select PDM → Teamcenter→ Save to check in the file. Like
before, search for the Item ID. This time, it is very important to also change the Revision to the new
revision (in this example, B). You will see in the Save to Teamcenter dialog, the object is Checked Out
By you.

Answer Yes to the Teamcenter dataset overwrite prompt.

Teamcenter Integration
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In the Messages pane, you get confirmation the file was saved to Teamcenter.

The new Revision (B) is now saved in Teamcenter. If you want to open the old Revision (A), you simply
select PDM → Teamcenter→ Open from within Femap, search for the Item ID, but this time for Revision
A. Click Open. You are opening the previous Revision that is managed with Teamcenter.

1. What's New - version 2301
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Import JT Assembly from Teamcenter

From Femap, select PDM → Teamcenter → Import JT Assembly. Like with the Open and Save file
operations, you must search for the assembly Item ID and a Revision. You then select the Object from
the dialog list, and select the Revision Rule to use.

Note:

The Revision Rules reset, and need to be selected each time the command is run. For information
on revision rules, please see the Teamcenter revision rule help.

Teamcenter Integration
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Femap looks at each assembly in Teamcenter using the BVR (BOM View Revision) to find the associated
part ID’s and assembly ID’s. Each part revision ID needs to have a generated JT assembly (A), and each
assembly with a BVR points to the part ID’s (B).

1. What's New - version 2301
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Teamcenter Integration

Femap What's New, Femap 2301  1-17
© 2023 Siemens



File → Preferences → PDM tab

A new PDM settings tab is added to the File → Preferences command. It has two options; Download
Directory sets a location on your system where Teamcenter can download files to, and Save
Teamcenter Info saves the Download Directory information regardless of where you set it when
working with the Teamcenter interactive Open and Save commands in Femap..

1. What's New - version 2301
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Teamcenter Integration
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Review of Femap with Teamcenter Prerequisites

• The Solid Edge Embedded Client (SEEC) feature package must be installed on the Teamcenter
Server in order to use the Femap integration with Teamcenter. Refer to the SEEC documentation with
the correct Teamcenter version you are using.

• The Teamcenter Rich Application Client (RAC) must be installed in order to create new Items and
revise existing Items in Teamcenter. You must install Teamcenter Client Communication System
(TCCS)

• The FMS_HOME environment variable needs to be created if not already created, and pointed to a
valid Teamcenter Client Communication System (TCCS).

Geometry

The following topics describe what is new in Geometry:

Midsurfacing Enhancements

Two new options have been added to the Geometry → Midsurface → Automatic command, both are
designed to allow more flexibility during the Midsurfacing workflow.

Remove Holes

When on, internal holes in the resulting midsurface geometry are deleted.

Keep Untrimmed Midsurfaces

When on, any midsurface which is found but not trimmed properly is kept instead of being deleted.

1. What's New - version 2301
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Examples

1. Original Geometry

2. Remove Holes - Off

3. Remove Holes - On

4. Keep Untrimmed Midsurfaces -
On (both Original Geometry and
Midsurfaces shown for clarity)

Group From Node Enhancements

Enhancements made designed to improve the Group → Curve → From Node and Group → Surface
→ From Node commands. These commands now work with non-Parasolid Femap geometry, previously
they only worked with Parasolid geometry.

This enhancement was also made for:

• Associated selection methods

• API Point object Curves, CurvesAsSet and SurfacesAsSet methods

• API Curve object Surfaces and SurfacesAsSet methods

Preprocessing

The following topics describe what is new in Preprocessing:

Group From Node Enhancements
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Support for Element Addition/Removal in SOL 401

Femap now supports SOL 401’s element addition and removal capabilities. This is all accomplished
with the Element Add | Remove Manager command which is accessed from the new Femap menu
item (Model → Simulation Entities → Element Add | Remove Manager) or the Model Info tree
(Simulation Entities branch).

There are various options for element addition/removal, including the 3 different types of addition/
removal criteria:

Time – Element addition or removal based on time

Inelastic Strain – Element removal based on inelastic strain

Mechanical Strain – Element removal based on mechanical strain

Support is also added for strain free element addition (Strain-Free check box), as well as addition delta
times and removal delta times for intervals to slow the transition of adding/removing elements.

Aero Spline Enhancement

When choosing which Aero Boxes to include for an Aero Spline, there are now two options:

All Boxes

1. What's New - version 2301
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Chooses all Aero Boxes on the Aero Panel/Body selected by CAERO ID. All Boxes allows you to update
the definition of an Aero Panel/Body and not have to update the Aero Spline when using all Aero
Boxes on the Aero Panel/Body.

Custom

Allows selection of a subset of Aero Boxes on the selected Aero Panel/Body

Note:

See Model → Aeroelasticity → Spline... for more information.

New Connection Properties for MultiStep Structural (401) and MultiStep
Kinematic (402)

To accommodate new connection property options, both the MultiStep Structural (401) and MultiStep
Kinematic (402) tabs of the Define Connection Property dialog have been expanded. A new More
Options... button is available on both tp access the new connection properties.

MultiStep Structural (401) tab

Eight new options are now supported, with 7 being found by clicking the More Options button. The
Adjustment Tolerance (ADJUST) now accepts negative values and can also now be toggled on and off.

New Connection Properties for MultiStep Structural (401) and MultiStep Kinematic (402)
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MultiStep Structural (401) tab

Note:

These items have been removed as they are no longer used: *Closed Gap Tolerance (GAPTOL),
*No Separation (NOSEP), and Stiffness Stabilization (KSTAB).

MultiStep Kinematic (402) tab

To accommodate new options, a More Options button was added. Nine new options are now
supported, with 8 being found by clicking the More Options button.

1. What's New - version 2301
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MultiStep Kinematic (402) tab

Group Operations Reduce To Existing

A new command, Reduce to Existing, is added to Femap Groups (Group → Operations → Reduce
to Existing). This command is just like the Condense command (Group → Operations → Condense)
except that it updates each rule type to contain its existing entities. It does not condense the rules down
to ID rules so you retain the same functionality of the Group.

Miscellaneous

Data Tables

• Updated how Constraint Equations are shown in the Data Table. Previously, Nodes with multiple DOF
did not show the Node ID with each DOF, which caused columns to be misaligned and mislabeled if
you added multiple equations with differing numbers of DOF per node.

• The ID of the Constraint Equation within the Constraint Set is now shown as the ID instead of the
selected node, as was previously done.

Group Operations Reduce To Existing
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• Improved performance when adding large numbers of Nodal, Elemental and Geometric Loads and
Geometric Constraints to the Data Table.

• Significantly improved performance when adding and updating large numbers of columns in the API
Data Table object.

Toolbars

Updated toolbar commands that show multiple different icons so all instances of those commands are
correctly updated if you place such a command on existing or custom toolbars.

Entity Selection

Added 8..Fluid and 7..Other options for material types which can be selected in the standard Entity
Selection dialog when Method^ is set to Type, and are also now selected when using Select All when
Method^ is set to Type.

Meshing

The following topics describe what is new in Meshing:

Midside Node Projection in Mesh Bodies

Mesh Points (hard points) created with the Mesh Point Editor are now recognized by the Body Mesher
both when using the Mesh → Bodies command or the Mesh → Geometry → Surface command with
the Mesher set to Body/on Mesh.

A new Midside Nodes tab is added to the Automesh Bodies dialog. It contains controls used to allow
projection of midside nodes toward associated surfaces and curves, limited by user-defined distortion
angle. The Midside Nodes tab appears when the Midside Nodes option is checked in the Mesh Types
section of the dialog.

1. What's New - version 2301
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By default, midside nodes are created along the element edge between the corner nodes of an
element. To project the midside nodes onto the geometry, turn on the Project Midside Nodes Toward
Associated Surfaces/Curves option. In some cases, it may be beneficial to limit the distortion of
elements created by projecting the midside nodes. If this is the case, turn on Limit Midside Distortion
Angle and enter the maximum allowable distortion angle in Max Angle.

Mesh on Mesh Enhancement

Line elements connected to other element types can now be updated when using the Mesh → Mesh on
Mesh command. This enhancement allows meshes containing line element stiffeners to be completely
refined or un-refined. A new Line Elements tab is added to control whether adjacent line elements
should be treated together or individually during remeshing based on a user-defined Orientation/Offset
Deviation Limit Angle Along Edge value.

Mesh on Mesh Enhancement

Femap What's New, Femap 2301  1-27
© 2023 Siemens



Effect of the Remeshing Options on Line Elememnts — The images below illustrate the efeect the
Orientation/Offset Deviation Limit Angle Along Edge Remeshing Option has on a model:

1. Original Model

2. Refined Mesh

3. Un-refined Mesh

1. What's New - version 2301
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Meshing - Miscellaneous

Cohesive Meshing

Enhanced the Mesh → Editing → Cohesive Meshing command to properly support inserting Cohesive
elements at a location where some portions of the mesh could be missing adjacent elements over part
or all of the area.

The Cohesive Meshing command is similar to the Edge Split command. You select two nodes on a
Solid Element edge and it splits all adjacent elements and, in this case, inserts Cohesive elements.
Previously, the Cohesive Meshing command assumed there were fully matching elements on both
sides of the split. When you split along the interior of an edge, the assumption is always true. However,
if you choose the option to split at the Top or Bottom, there could be missing adjacent elements over
portions of the area.

With the updated command, Top and Bottom cohesive elements are only created in regions with
adjacent elements, or over the entire area if there are no adjacent elements (putting a layer of
cohesiveness on the outside).

Meshing - Miscellaneous
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Bad cohesive elements created (top) in previous versions of Femap now are corrected (bottom).

Geometry Preparation

Updated the Mesh → Geometry Preparation command to display a confirmation question and warning
message if the Suppress Internal Voids option is selected, and there are any voids much larger than the
specified mesh size. The inten is to prevent accidental suppression of large void regions like the inside of
hollow tubes with closed ends.
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HexMesh Bodies

Updated the Mesh → HexMesh Bodies command to better match specified mesh sizes in very specific
case where the Size Surface if All Curves Sized option is turned on, all curves on either a required
surface are sized, or the All Sized Curves option is turned on, and curve sizing is close to the Target
Element Size.

Performance Improvement

The following topics describe what is new in Performance Improvement:

Femap Unified Architecture

Continuing the conversion of Femap graphics to the new Femap Unified Architecture. In a previous
release the first part of the Unified Architecture was used to draw picking marker symbols quicker.
This release implements geometry in Unified Architecture: Points, Curves, Composite Curves, Surfaces,
Boundaries, volumes/solids and geometry-based loads and constraints. It also implements coordinate
systems and hard/mesh points.

Currently, Femap contains two different pipelines for graphics: Performance Graphics and original
OpenGL. When the Best Possible or Performance Graphics option is turned on in the File →
Preferences command, everything supported by Performance Graphics is drawn using a more modern
OpenGL technology and everything which is not supported is drawn using the original OpenGL.

Note:

A minor caviat with having two different pipelines is that some entity types only appear "as
expected" in the graphics window in the original OpenGL due to line style, line width, fill style, and
transparency not being supported by Performance Graphics.

Unified Architecture Option - File → Preferences

The new Unified Architecture option in the Graphics Options section of the File → Preferences
command's Graphics tab is part of the ongoing effort to improve graphics performance across all
aspects of Femap with the new Unified Graphics Architecture (UGA). This will use a single “pipeline”, and
will be implemented over the next few releases.

Performance Improvement
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When fully implemented, UGA will provide a better experience for the user in quality, performance, and
with hardware support. Both the Performance Graphics and original OpenGL pipelines will be removed.
In addition, UGA will support line style, line width, fill style, and transparency along with being able to
better support users using Intel graphics accelerators.

The following entity types are currently supported:

• Coordinate Systems

• Hard/Mesh Points

• Points

• Curves

• Composite Curves

• Surfaces

• Boundary Surfaces

• Solids

• Volumes (may be removed in future version)

• Geometry-based Constraints

• Geometry-based Loads

Miscellaneous Performance Improvements

Improved the performance of adding large numbers of Nodal, Elemental and Geometric Loads and
Geometric Constraints to the Data Table.

API Data Table

Improved performance when adding and updating columns in API Data Table object. For instance,
adding a Freebody with over 800,000 lines of data went from approximately 19 minutes to 34 seconds
(330% improvement).

Faceted Geometry

Improved the performance of loading certain facetted geometry. For instance, a model with complex
surfaces showed an almost 50% speed improvement, in another about 27%.

Miscellaneous Performance Improvements
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Meshing Toolbox

Improved the performance of updating a mesh in the Meshing Toolbox when the model contained
rigid elements and Sizing Propagation was turned off. Previously, unnecessary work was done to find
adjacent edges even though they would not be used.

Analysis and Solvers

The following topics describe what is new in Analysis and Solvers:

Analysis Monitoring - Running Multiple Analysis Sets Continuously

Femap has increased functionality to allow Running Multiple Analysis Sets Continuously without
manually loading results each time analysis set completes.

Note:

Applicable only when the Automatically Load Results check box in Preferences → Interfaces is
unchecked. The behavior is unchanged when the check box is checked.

Included with this new ability, is an increase in the speed of operations like loading results and deleting
analysis sets, as well as numerous improvements to the Analysis Monitor pane and the Model Info tree
Analysis branch.

The ability to run multiple analysys sets is helpful when you have a large number of analysis sets to run.
You can start the queue and let it run until it completes or until (optionally) a failure occurs, at which
point you can decide to continue running the queue or cancel it. In the Model Info tree, there are new
icons on the analysis sets that indicate status. These are updated as the queue is processed. These icons
lets you quickly identify analysis sets that needs attention. In addition, new right click menu options on
the analysis sets provide access to the Analysis Monitor pane and analysis results. Easy access to the
Analysis Monitor pane and analysis results overall, enhances your ability to run the queue, review the
results, and manage the results information.

Analysis Monitor pane

The Analysis Monitor pane now updates to show the active Model analysis set information. The
Analysis Monitor pane can now be opened and closed from the Femap menu (Tools → Other
Windows → Analysis Monitor Pane option. It can also be opened by selecting Show Analysis Monitor
Pane on the Model info pane Analysis branch right click menu.

Model Info tree

To accommodate the new functionality, several additions/changes were made in the Model Info tree
Analysis branch:

Analysis Status Icons
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In the Analysis branch, each analysis set now has a status indicating icon that is updated every time
it is analyzed:

 Not Analyzed

 Successfully Completed

 Failed

Note:

The icons are updated only for Nastran and Ansys solvers as of the Femap 2301 release.
Future releases will update the icons for other solvers as well.

Analysis right click menu

Three new options are now available on the Model Info Analysis branch right click menu:

• Continue Running Analysis Queue - Restarts the paused analysis queue after an analysis set
fails (activated if Pause Analysis Queue after Failure is checked in File → Preferences →
Interfaces).

• Load Results - Loads the results for the selected analysis set into the Analysis Monitor pane.

Note:

You must right click on the analysis set you want to load results for.

• Show Analysis Montor Pane - Reopens the Simcenter Nastran Analys Monitor pane if closed.

API - ClearJobMonitorData

A new method, ClearJobMonitorData is added to the AnalysisMgr object. It is used to delete any

job monitor related data of the already analyzed sets, and reset the analysis set icons to  (Not

Analyzed).

Pause Analysis Queue after Failure

A new Pause Analysis Queue after Failure setting is added to the Analysis Monitor Options of the
Preferences dialog (File → Preferences → Interfaces). When checked, the analysis queue is paused
when an analysis fails. You have an opportunity to review the results. You can restart the analysis queue
by selecting Continue Running Analysis Queue in the right click menu of the Analysis branch of the
Model Info tree.

Analysis Monitoring - Running Multiple Analysis Sets Continuously

Femap What's New, Femap 2301  1-35
© 2023 Siemens



Analysis Set Manager Enhancement

In the Analysis Set Manager, a brief description of the analysis which is to be run by a specific Analysis
Set is now displayed in the main Analysis Set dialog. The description is based on a combination of the
selected Analysis Program and Analysis Type, and includes information which is likely to be familiar to
users familiar with solver nomenclature.
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For example, the description for:

“Analysis Program” = “36..Simcenter Nastran” and “Analysis Type” = “7..Buckling” shows a description of
“SEBUCKL – SOL 105”

Analysis Set Manager Enhancement
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Nastran Response Spectrum Application Enhancement

Added support for Simcenter Nastran’s
simplified user interface for response
spectrum application runs

• RSAPPLY case control command

• RSAPPLY bulk data entry

• RSPECTR bulk data entry

• RSPOPT bulk data entry

Includes support for the new modal
combination methods:

• CQC

• DSUM (FACTOR = Earthquake
Duration)

• GRP

• ROSE (FACTOR = Earthquake Duration)

MSC Nastran – HDF5 Output Request

Output from MSC Nastran can now be requested in HDF5 format (NH5RDB) from the NASTRAN Output
Requests dialog.
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Depending on selected options, the MDLPRM bulk data entry is written with an appropriate value for the
HDF5 parameter:

• Generate HDF5 turned on (no other options on) – writes 2

• With Compression turned on only – writes 3

• With Input Data turned on only – writes 0

• Both With Compression and With Input Data turned on – writes 1

MSC Nastran – HDF5 Output Request
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Analysis Set Manager - Multi-Step Nonlinear (SOL 401) Updates

Additions and Updates for Multi-Step Nonlinear (SOL 401) in Analysis Set Manager:

Boundary Conditions

Added an Element Add | Remove drop-down to select an Element Add | Remove entity or an
Element Add | Remove set. See Support for Element Addition/Removal in SOL 401 for more
information.

Multi-Step Control Options

• Changed default for Equilibrium Min Factor (EQMFMIN) from to 0.2 to 0.476

• Changed default for Equilibrium Max Factor (EQMFMAX) from to 5.0 to 1.9
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Multi-Step Control Options → Solution and Convergence

Added the Always Output Results at Last Converged Step (LSTCONV) check box.

Updated the Diagnostic Level (MSGLVL) option from Boolean to drop-down to accommodate
addition option

Analysis Set Manager - Multi-Step Nonlinear (SOL 401) Updates

Femap What's New, Femap 2301  1-41
© 2023 Siemens



Multi-Step Control Options → Contact/Bolt Prelaod

• Added the Tangential Cont Stiff Options (KMODTN) drop-down.

• Added the Modal Subcase Scale (KMODSCL) value field.
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Multi-Step Control Options → Creep/Plasticity

• Added the Adjust Integration Factor (CRLIMR) value field.

• Added the Max Equivalent Plastic Strain (PLLIM) value field.

• Added the Max Plastic Strain Multiplying Factor (PLLIMF) value field.

Analysis Set Manager - Multi-Step Nonlinear (SOL 401) Updates
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Analysis Set Manager - Multi-Step Kinematics (SOL 402)

Additions and Updates for Multi-Step Kinematics (SOL 402) in Analysis Set Manager:

Multi-Step Control Options

• Added the Storage Cycle for Grid Point Results (IA16) value field.

• Added the Storage Cycle for XY Plotting Results (IA19) value field.

• Added the Ramping Load Factor Interpolation (RFVAR) drop-down

• Added the Free Thermal Expansion (ITHE) check box.

• Added the Laws of Excitation Storage (LL2) value field.

• Added the Max Equivalent Plastic Strain (PLLIM) value field.
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• Added the Creep Strain Increment (CRICOFF) value field.

• Added the Adjust Integration Error (CRLIMR) value field.

• Updated the Enable Inertial in Dynamics (INERTIA) drop-down to accommodate addition
options.

• Changed the default for Minimum Decrease Ratio (EQMFMIN) from 2.1 to 0.476.

Multi-Step Control Options → Solution and Convergence Options

• Added the Stiffness Update (KUPDATE) drop-down.

• Added the Max Time Step Reductions (MAXBIS) value field.

• Added the Modified Generalized Alpha Param (RHOINF) value field.

• Added the Tangential Contact Stiffness (KMODTN) drop-down.

Analysis Set Manager - Multi-Step Kinematics (SOL 402)
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• Added the Diagnostic Output (MSGLVLC) drop-down.

• Changed the default for Max Iter (ITMA) from 10 to 20.

• Changed the default for Relative Disp Force (PRCQ) from 1.0 to 0.1.

• Changed the default for Generalized Scheme Param (TETA) from 0.80 to 0.55.

ABAQUS Additions and Updates

• Added support for SHELL TO SOLID CONNECTION for glued contact.

• Added support for 13-node pyramid elements, which are degenerate hexahedral elements.

• Added support for NASTRAN RBE3-like interpolation elements.
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• Updated Standard Beam Section to write out for Implicit Analysis, not just Explicit Analysis. Also
corrected issues when reading standard sections from ABAQUS input file.

• Updated reading of output files to read in Forces for Spring and DOF Spring elements, which are
created using a STRESS request.

ANSYS Additions and Updates

• Added the ability to read “meshed” cross-section for Beams from ANSYS input files and store them
with the appropriate Beam Property so they can later be exported.

• Added ability to read certain ANSYS APDL-style inputs which are often used in input files created by
ANSYS Mechanical (formally ANSYS Workbench).

ANSYS Meshed Beam Sections

This edition of Femap includes support for ANSYS meshed beam sections. Meshed beam sections are
in addition to many standard beam section shapes (rect, circle, I, T, L, etc) and arbitrary sections
(with integrated properties ( area. moment of inertia, etc). ANSYS beam sections can also be a 2D
planar mesh data, with mesh connectivity and nodes coordinates. ANSYS beam sections in terms of the
command “SECTYPE,BEAM,MESH”/”SECDATA” are now supported in Femap. The beam section properties
such as area, moment of inertia will be automatically calculated within Femap. These beam section
properties will be used in Nastran or other solvers which do not support meshed beam sections. The
same mesh data will be written to an Ansys input file, and Ansys solver calculates the beam section
properties directly during an analysis. You can also use the Femap calculated beam section properties
directly in Ansys and same results will be obtained.

ANSYS meshed beam section data:

SECTYPE,2433,BEAM,MESH
SECBLOCK,329,82
       76       77       78       76      246      247      231       
76      329     2433       !!mesh connectivity, 9 nodes
       76       74       75       76      243      244      245       
76      328     2433
       73       74       76       73      242      243      241       
73      327     2433
…, …
       82        2       59       82       85       87       88       
82      249     2433
        1        2       82        1       84       85       86        
1      248     2433
0,     5.080000000E+01,     
2.091500000E+01                                                      !!
 node coordinates y,z
0,     4.402666667E+01,     2.091500000E+01
0,     3.725333333E+01,     2.091500000E+01

ANSYS Additions and Updates
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…, …
0,     4.848267041E+01,    -2.082633828E+01
0,     5.020666667E+01,    -1.859111111E+01

These beam sections can be graphically displayed in the same way as other beam sections.

Note:

Because Nastran doesn’t support meshed beam sections, beam properties (A, Ixx, Iyy, J, etc) are
calculated from the meshes and stored in the Femap beam section property. Nastran and other
solvers can have access to the data and use it in their structural analyses. For ANSYS, the same
meshed sections are written to an ANSYS input file, and the ANSYS solver calculates the beam
section property directly.
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Note:

You can also use the Femap calculated beam section property for input to ANSYS, by checking
"Omit Beam Section Shape” button in Ansys Analysis Manager Dialog.

Flutter VG/VF Plots

An enhancement was made to Aerodynamic Flutter Analysis (Analysis Type set to 26..Aerodynamic
Flutter) when using the PKNL flutter analysis methods to provide improved support for reading of
VG/VF. This was done because the PKNL method writes a different format to the flutter summary than
the PK method which stems from the looping. While the PK method does every combination of density,
mach and velocity, in the PKNL method, only ordered pairs are analyzed; i.e., (M1, V1), (M2, V2)...(Mn,
Vn). Also, for the PKNL method, equal number of densities, Mach numbers and velocities must be
specified.

This makes the PKNL loop faster when solving with both constant density and mach, saving
computation time compared to the PK method (when Mach No. is held constant). There is no
recalculation of the aerodynamic influence coefficient matrixes.

See also:

Aerodynamic Flutter Analysis in the Femap User Guide.

Flutter Analysis in the Simcenter Nastran Aeroelastic Analysis User's Guide.

FLUTTER in the Simcenter Nastran Quick Reference Guide.

Flutter Summaries in the Simcenter Nastran Aeroelastic Analysis User's Guide.

Flutter VG/VF Plots
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Support for Simcenter Data File

Support is added for the Simcenter Data File. A Simcenter Data File (SCD5) file is a FEM result file based
on the Pithos library, which itself is based on HDF5 API and hierarchical organization.

Note:

For attaching to SCD5 files, shear strain components are stored as epsilon (per the convention)
and are presented as such when post-processing.

The Pithos library is based on general concepts, such as:

• Group (Similar to a folder on a disk)

• DataSet (Similar to a file on a disk)

• Attribute

• Legend

• Field

The SCD5 convention is not a new set of API but rather is a convention for:

Organization of the file

The group in which to store the mesh, solution, FEM Results, and so on.

Wording

The ContentType name of groups that contains:

• Solution

• Mesh

• Legend

• FEProperty

• Result

• ...

The ContentType name of DataSet that describes:

• Mesh
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• Result

• Composite

• ...

Postprocessing

The following topics describe what is new in Postprocessing:

Computed Vectors

New in Femap v2301, is the Computed Vectors command (see the Femap Commands Guide) whichis
used to capture additional key results data that may not be calculated by the solver. The command is
accessed from the Femap menu - Model → Output → Computed Vectors....

Postprocessing

Femap What's New, Femap 2301  1-51
© 2023 Siemens



Computed Vectors speeds up capturing the results data by computing the additional results vectors
automatically, every time you run an analysis or whenever you choose to do it.

Use the When To Compute options to set when the additional results vectors are to be computed.
When Automatically when Results are Read or Created is on, the results vectors are automatically
computed for the types checked in the Auto Run check boxes after an analysis is done. In addition, upon
an import of results, the additional calculations are also completed. Automatically when Results are
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Read or Created is typically used for the results vectors types you regularly want to compute vectors for
immediately after each analysis run.

Now in Existing Output Sets is intended to be used any time to compute additional results vectors, as
long as there are results in the model. For example, you change material limits to recalculate the failure
theory. Also, when using Now in Existing Output Sets, the Auto Run checked boxes are different from
what gets saved when using Automatically when Results are Read or Created.

Standard Computed Vectors

Select from list of pre-defined output types; Elemental Results, Plate/Solid Failure Theory, Laminate
Failure Theory, Enveloped Results. Check Auto Run for the ones you want to compute. The Elemental
Results and Plate/Solid Principals and Invariants are Identical to the Compute Principal and Averaged
Stress/Strain options on the Results tab of File → Preferences. Plate/Solid Failure Theory computes the
vectors for Max Von Mises, Max Shear Stress / Tresca, Mohr-Coulomb Stress, and Max Normal Stress
theories. Plate/Solid Failure Theory also calculates Factor of Safety and Margin of Safety results, and
provides an aditional set of Plate/Sold Failure Theory Options to select between Centroidal or Centroidal
and Corner results (press "…" button). Laminate Failure Theory uses the same Failure Theory calculations
as Nastran solvers to compute Hill, Hoffman, Tsai-Wu, and Max Strain computed vectors. This allows you
to calculate a different Failure Theory or recalculate using different material limits without re-running
the analysis. The Enveloped Results are the same as those calculated using the Model → Output →
Process command. The Enveloped Results streamlines the creation of the Beam All Locations, Plate
Top/Bottom, Laminate All Ply, Plate/Laminate All Locations, and Solid All Locations output vectors.

Computed Vectors
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User Defined Computed Vectors

The User Defined Computed Vectors are created based on Combination, Envelope or API Script derived
Output Vectors. Use the Define and Edit options in one of th ethree the Computed Vectors creation
dialogs. The Combine type is based on a Linear Combination or RSS Combination using any number of
specified Output Vector IDs. The Envelope type creates a Max Value, Min Value, or Max Absolute Value
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Envelope using the specified Output Vector IDs, and the API type creates Computed Vectors based on an
API script.

Library

You can use a library of vectors to compute that can be saved and loaded using the Upload and Save
icon tools. Both Standard and User Defined computed vectors can be saved to libraries. The library is
specified on the Results tab of the File → Preferences command. This will select a library of vectors to
always compute for all new models.

Computed Vectors
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Additional Output Data Conversion Options

When converting Output from Elemental to Nodal, options to use or skip elemental corner results and
options to either use Averaged, Max Abs or Min Abs results at the same locations. This Femap version
expands the number of options to include Average, Max Absolute Value, Min Absolute Value, Max
Value, and Min Value.

Output Data Conversion options in Femap commands

The expanded options are added to the following commands/locations:

• Select Contour Options dialog under Data Conversion.
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• PostProcessing Toolbox under Options → Data Conversion.

Additional Output Data Conversion Options
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• Process Output Data dialog, on Convert tab, under Conversion Approach.
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• Chart Data Series dialog under Output Processing.

Additional Output Data Conversion Options
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• Entity Editor under Contour Data Conversion.
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Data Conversion Options

Updated options for Data Conversion throughout Femap. Previously, there were just three options:
Average, Max Value (actually Max Absolute Value) Min Value (actually Min Absolute Value) Now, the
available options are: Average Max Absolute Value (really the old Max Value) Min Absolute Value (really
the old Min Value), Max Value (new), and Min Value (new).

Data Conversion Options
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These Data Conversion options are now all labeled consistently and available in all places they are used:

• Select Contour Options dialog

• Postprocessing Toolbox for Data Conversion

• View → Options – Post Titles (displayed in Graphics Window)

• Charting pane dialog boxes and Legend in Chart Area

• Model → Output → Process – Convert tab

• Output Map Data Surface in Data Surface Editor pane

• Model → Load → Map Output from Model command

• Entity Editor and Data Table which contain info about a View

• API Enum zResultsConvert API Interpolate Class

Attach to Results - HDF5 Format

Support has been added to attach to HDF5 format files.
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Note:

For attaching to SCD5 files, shear strain components are stored as epsilon (per the convention)
and are presented as such when post-processing.

Attach to Simcenter HDF5 File (*.scd5)

Support has been added to attach to HDF5 format results files (SCD5) generated by Simcenter Nastran
using the File → Attach to Results command.

Attach to Results - HDF5 Format
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Note:

There is no other way to currently request the SDC5 file via the Femap user interface.

Attach to MSC Nastran HDF5 File (*.H5)

Support has been added to attach to HDF5 format results files (NH5RDB) generated by MSC Nastran
using the File → Attach to Results command.

Note:

Results in this format can be requested within the Femap user interface using the NASTRAN
Output Requests dialog box.

HDF5 Output Types currently supported:

NODAL

• NODAL\DISPLACEMENT

• NODAL\APPLIED\LOAD

• NODAL\SPC\FORCE

• NODAL\MPC\FORCE

• NODAL\ACCELERATION

• NODAL\VELOCITY

ELEMENTAL STRESS

• ELEMENTAL\STRESS\ROD

• ELEMENTAL\STRESS\ROD\NL

• ELEMENTAL\STRESS\TRIA3

• ELEMENTAL\STRESS\TRIA6

• ELEMENTAL\STRESS\TRIAR

• ELEMENTAL\STRESS\QUADR

• ELEMENTAL\STRESS\QUAD4

• ELEMENTAL\STRESS\QUAD8
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• ELEMENTAL\STRESS\QUAD\CN

• ELEMENTAL\STRESS\QUADR\NL

• ELEMENTAL\STRESS\QUAD4\NL

• ELEMENTAL\STRESS\TRIA3\NL

• ELEMENTAL\STRESS\TRIAR\NL

• ELEMENTAL\STRESS\TETRA

• ELEMENTAL\STRESS\HEXA

• ELEMENTAL\STRESS\PENTA

• ELEMENTAL\STRESS\PYRA

• ELEMENTAL\STRESS\TETRA\NL

• ELEMENTAL\STRESS\HEXA\NL

• ELEMENTAL\STRESS\PENTA\NL

• ELEMENTAL\STRESS\PYRA\NL

ELEMENTAL FORCE

• ELEMENTAL\ELEMENT\FORCE\ROD

• ELEMENTAL\ELEMENT\FORCE\QUAD4

• ELEMENTAL\ELEMENT\FORCE\QUADR

• ELEMENTAL\ELEMENT\FORCE\TRIA3

• ELEMENTAL\ELEMENT\FORCE\QUADR\CT

• ELEMENTAL\ELEMENT\FORCE\TRIAR

• ELEMENTAL\ELEMENT\FORCE\TRIA6

• ELEMENTAL\ELEMENT\FORCE\QUAD8

• ELEMENTAL\ELEMENT\FORCE\QUAD4\CN

ELEMENTAL STRAIN

Attach to Results - HDF5 Format
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• ELEMENTAL\STRAIN\ROD

• ELEMENTAL\STRAIN\QUAD\CN

• ELEMENTAL\STRAIN\QUAD4

• ELEMENTAL\STRAIN\QUAD8

• ELEMENTAL\STRAIN\QUADR

• ELEMENTAL\STRAIN\TRIA3

• ELEMENTAL\STRAIN\TRIA6

• ELEMENTAL\STRAIN\TRIAR

• ELEMENTAL\STRAIN\TETRA

• ELEMENTAL\STRAIN\HEXA

• ELEMENTAL\STRAIN\PENTA

• ELEMENTAL\STRAIN\PYRA

Xcelerator Share

The Xcelerator Share commands are moved from the File menu to the new PDM menu.

Command Finder

This edition of Femap adds a new command search function. The new search text entry field is found
on the Femap main menu. Enter the search text, and click the magnifying glass icon to do the search.
Results are listed in a drop down below the search field. Clicking on a result starts that command. Also,
included in each result, is the name of the command and its menu location.

1. What's New - version 2301

1-66  Femap What's New, Femap 2301
© 2023 Siemens



Command Finder
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API

New and updated API Objects and Attributes

• Added Solid Cleanup Tool (feSolidCleanupTool) Object to the API.

• Added CheckGeometry, MatchModelScaleFactor, RemoveRedundantGeometry,
ShowProgressMessages, EnableAdvancedCleanup, AdvCleanInvalidGeometry,
AdvRemoveSmallFeatures, AdvOptimize, and AdvStitch to select options in Solid Validation
and Cleanup dialog box of the Geometry → Solid → Cleanup command via the Solid Cleanup Tool
Object.

• Added AdvCleanValidGeometry, AdvRepairEdges, AdvSmoothDiscontinuity,
AdvRemoveSelfIntersection, AdvAllowSurfaceMods, AdvRemoveSpikes,
AdvRemoveSpikesTolerance, AdvRemoveSmallEdges, AdvRemoveSmallEdgesTolerance,
AdvRemoveSmallFaces, AdvRemoveSmallFacesTolerance, AdvRemoveSlivers,
AdvRemoveSliversTolerance, AdvRemoveGashes, AdvRemoveGashesTolerance,
AdvSimplifyGeometry, AdvSimplifyGeometryTolerance,
AdvImproveEdges, AdvImproveEdgesTolerance, AdvMergeSharedGeometry,
AdvReapplyBlends, AdvStitchTolerance, AdvStitchSmoothDiscontinuity,
AdvStitchSmoothDiscontinuityTolerance, and AdvStitchReplaceMissingGeometry to
specify options in the Advanced Cleanup Options dialog box of the Geometry → Solid → Cleanup
command via the Solid Cleanup Tool Object.

• Added Computed Vectros (feComputedResultsVectors) Object to the API.

• Added PlateSolidPrincipals, PlateAveragedMid, BeamVonMises,
PlateSolidMaxVonMises, PlateSolidTresca, PlateSolidMohrCoulomb,
PlateSolidMaxNormal, LaminateHill, LaminateHoffmann, LaminateTsaiWu,
LaminateMaxStrain, EnvelopeBeamAll, EnvelopePlateLamPly, EnvelopePlateLamAll,
and EnvelopeSolidAll to specify the Auto Run option for various results quantities when When
To Compute is set to Automatically when Results are Read or Created using the Computed Vectors
Object.

• Added PlateSolidUseCorners and DesignFactorOfSafety to specify option and value for the
Plate/Solid Failure Theory Options dialog box when When To Compute is set to Automatically when
Results are Read or Created using the Computed Vectors Object.

• Added NowPlateSolidPrincipals, NowPlateAveragedMid, NowBeamVonMises,
NowPlateSolidMaxVonMises, NowPlateSolidTresca, NowPlateSolidMohrCoulomb,
NowPlateSolidMaxNormal, NowLaminateHill, NowLaminateHoffmann,
NowLaminateTsaiWu, NowLaminateMaxStrain, NowEnvelopeBeamAll,
NowEnvelopePlateLamPly, NowEnvelopePlateLamAll, and NowEnvelopeSolidAllto
specify the Run Now option for various results quantities when When To Compute is set to Now
in Existing Output Sets using the Computed Vectors Object.
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• Added NowPlateSolidUseCorners and NowDesignFactorOfSafety to specify option and
value for the Plate/Solid Failure Theory Options dialog box when When To Compute is set to Now
in Existing Output Sets using the Computed Vectors Object.

• Added Element Add and Remove (feElemAddRemove) Object to the API.

• Added title, AltType, NasTYPE, NasGRPID, NasHasAC, NasAC, NasADOpt, NasAD, NasHasRC,
NasRC, NasRDOpt, NasRD, NasSTNFREE, HasElemList, and ElemSetID to the Element Add and
Remove Object.

• Added AllowMeshIntersections, MidsideOntoGeometry, MidsideAngleLimitOn, and
MidsideAngleLimit to BodyMesher Object.

• Added NasMsnlCntKMODTN, NasMsnlCntCRLIMR, NasMsnlCntPLLIM, NasMsnlCntPLLIMF,
NasMsnlCntKMODSCL, and NasMsnlCntLSTCONV to Analysis Case Object to support options for
SOL 401. Also, updated NasMsnlCntMsglvl to support change from a Boolean to a drop-down in
the User Interface.

• Added NasMsnlkCnt2ITHE, NasMsnlkCnt2LL2, NasMsnlkCnt2CRICOFF,
NasMsnlkCnt2CRLIMR, NasMsnlkCnt2PLLIM, NasMsnlkCnt2RHOINF, NasMsnlkCnt2MAXBIS,
NasMsnlkCnt2KMODTN, NasMsnlkCnt2MSGLVLC, NasMsnlkCnt2IA16, NasMsnlkCnt2IA19,
NasMsnlkCnt2KUPDATE, and NasMsnlkCnt2RFVAR to Analysis Case Object to support options for
SOL 402. Also, updated NasMsnlkCnt2INERTIA to support change from a Boolean to a drop-down
in the User Interface.

• Added NasGenerateHDF5, NasHDF5WithCompression, and NasHDF5WithInputData to
Analysis Manager to support options to request HDF5 output from MSC Nastran.

• Added NasMsnlCntKMODTN, NasMsnlCntCRLIMR, NasMsnlCntPLLIM, NasMsnlCntPLLIMF,
NasMsnlCntKMODSCL, and NasMsnlCntLSTCONV to Analysis Manager Object to support options
for SOL 401. Also, updated NasMsnlCntMsglvl to support change from a Boolean to a drop-down
in the User Interface.

• Added NasMsnlkCnt2ITHE, NasMsnlkCnt2LL2, NasMsnlkCnt2CRICOFF,
NasMsnlkCnt2CRLIMR, NasMsnlkCnt2PLLIM, NasMsnlkCnt2RHOINF, NasMsnlkCnt2MAXBIS,
NasMsnlkCnt2KMODTN, NasMsnlkCnt2MSGLVLC, NasMsnlkCnt2IA16, NasMsnlkCnt2IA19,
NasMsnlkCnt2KUPDATE, and NasMsnlkCnt2RFVAR to Analysis Manager Object to support options
for SOL 402. Also, updated NasMsnlkCnt2INERTIA to support change from a Boolean to a drop-
down in the User Interface.

• Added items to pval attributes to support new options on Mutlistep Strucural (401) and Multistep
Kinematic (402) tabs to the Connection Property Object

• Added ReduceToExisting to Group Object.

• Added AutoAssign to Mesh Point Object.

API
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• Updated ibox1 on Aero Spline Object to allow a value of -1, which sets the All Boxes option in the
user interface.

New and Updated API Methods

• Added SetTolerances, Dialog, and Cleanup to the Solid Cleanup Tool Object.

• Added Clear, Dialog, GetCountUserDefined, GetUserDefinedInfo, EnableUserDefined,
EnableNowAll, FindUserDefined, NewUserDefinedAPI, NewUserDefinedCombine,
NewUserDefinedEnvelope, SetUserDefinedVectorIDRange, DeleteUserDefined, and
RunNow to the Computed Vectors Object.

• Added GetComponentSet, ClearComponentSet, PutComponentSet, GetELAR2Entry,
PutELAR2Entry, PutCombination, GetELAR2List, PutELAR2List, GetCombinationSet,
GetCombinations, and PutCombinations to the Element Add and Remove Object.

• Added ClearJobMonitorData to Analysis Manager Object.

• Added OnPoint2, AtCoordinates, Clear, and OnSurface to Mesh Point Object.

• Added HasShape to Property Object.

• Added SetColumnComponents2 and Save2 to Results Browsing Object.

• Added HasConsistentSurfaceMesh to Surface Object.

• Added SetClippingPlane to View Object.

• Updated CurvesAsSet and SurfacesAsSet on Point Object to work with curves and surfaces
created using Femap's Standard Geometry Engine (i.e. non-Parasolid geometry).

• Updated SurfacesAsSet on Curve Object to work with surfaces created using Femap's Standard
Geometry Engine (i.e. non-Parasolid geometry).

New and Updated Global Variables

• Added Pref_UnifiedArchitecture to specify the Unified Architecture option in the Graphics
Options section on the Graphics tab in the Preferences dialog box.

• Added Pref_RenderDebugOGLErrors2 to specify option for Debug Messages drop-down in the
Advanced/Debug Options section on the Graphics tab in the Preferences dialog box.

• Added Pref_LibComputedVectorNumber to specify options in the Computed Vectors (from
Computed Output Library) section on the Results tab in the Preferences dialog box.
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• Updated Pref_ComputePrincipal and Pref_ComputeAverageMidResults to specify the Auto
Run option for Plate/Solid Principals and Invariants and Plate Averaged Mid Stress/Strain, respectively,
in the Computed Results Vectors dialog box.

• Added Pref_LibComputedResultsVectors to specify the full directory path for a library file to
use for Computed Output in the Statup Personal Libraries section on the Library/Startup tab in the
Preferences dialog box.

• Added Pref_TCDownloadDir and Pref_SaveTeamcenterInfo to, respectively, specify the full
directory path of a Download Directory and specify the Save Teamcenter Info option in the
Teamcenter section on the PDM tab of the Preferences dialog box.

The following functions have been added or updated:

• feFileReadCatia3

• feFileReadNeutral4

• feFileWriteNeutral3

• feCurveSplitPointToPoint2

• feCurveSplitPointToEdge2

• feCurveSplitEdgeToEdge2

• feCurveBreak2

• feSurfaceMidAuto5

• feMeshEditingSplit

• feMeshExtrudeElem3

• feMeshExtrudeCurve2

• feMeshRevolveElem2

• feMeshRevolveCurve2

• feGroupReduceToExisting

• feAddUserCommand2

• feLoginToTeamcenter

API

Femap What's New, Femap 2301  1-71
© 2023 Siemens



• feIsUserLoggedInToTeamcenter

• feOpenModelFromTeamcenter

• feSaveModelToTeamcenter

• feGetCurrentModelPDMInfo

• feGetTeamcenterDatasetInfo
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2. What's New - version 2022.2 MP3
Changes and enhancements made to Femap for version 2022.2 MP3 are listed as fixes in the Femap
version 2022.2 MP3 readme file.

Siemens Digital Exchange (SDEX)

Siemens Digital Exchange (SDEX) is an E-Commerce Marketplace that provides Siemens and Third-Party
Sellers the ability to market, sell, and deploy their products as Software as a Service (SaaS). See for
details.
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3. What's New - version 2022.2 MP2
Changes and enhancements made to Femap for version 2022.2 MP2 are listed as fixes in the Femap
version 2022.2 MP2 readme file.
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4. What's New - version 2022.2 MP1
The following chapters describe new features, changes and enhancements to Femap for version 2022.2
MP1.

Analysis Program Interfaces

Several of the analysis program interfaces have been improved. These changes include:

Simcenter Nastran

Added support for reading CROD results from SOL 401/SOL 402 analyses.

General

Femap v2022.2 MP1 addresses a number of issues. For a full list of corrections, see the Femap
readme.pdf file in the Femap installation pdf folder.
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5. What's New - version 2022.2
The following chapters describe new features, changes and enhancements to Femap for version 2022.2.

Xcelerator Share Integration

Siemen's cloud file sharing solution Xcelerator Share is now integrated with Femap, allowing Femap
users to collaborate and share Femap model files, anslyses files, analyses results files, and Femap
neutral files.

For more information about Xcelerator Share, visit https://www.sw.siemens.com/en-US/digital-
transformation/.

Accessing Xcelerator Share from Femap

The File menu has been updated with the Share submenu. There are five Xcelerator Share commands
on the Share submenu. Each command launches Xcelerator Share where you can browse your projects
for files to open or import: Open checks out files from Xcelerator Share. Import → Geometry imports
geometry from files saved in Xcelerator Share into your existing model file. The other import commands,
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Import → Analysis Model, Analysis Results, and Femap Neutral import these analysis models files
from Xcelerator Share into Femap.

The same commands can be found on the Xcelerator Share toolbox which by default is docked on the
main menu bar.

5. What's New - version 2022.2
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Note:

If the Xcelerator Share toolbox is not available, right click on anywhere the menu bar, and select
Xcelerator Share from the right click menu. If Xcelerator Share is not available, it means Xcelerator
Share is not activated in your Femap license.

Siemens Connector Application

The Connector Application is another part of the Xcelerator Share intergration, and must be downloaded
and installed in order to access Xcelerator Share from Femap. The Connector download can be found
on the Xcelerator Share web client. Login with a web browser, and in the Xcelerator Share Home
screen, click Install the desktop connector. For more information on the Connector application, see
"The Connector application" in the Commands guide for more information.

Xcelerator Share Integration
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Using the Connector Folder

The Connector installation creates a special Connector folder on your local drive. Connector projects and
files are stored in this folder, and the Connector folder is synchronized with Xcelerator Share and Femap.
There are a few ways to add or access files to and from the Connector folder: File → New, and Save As
in Femap create new Xcelerator Share files if they are saved to the Connector folder, the commands on
the Xcelerator Share toolbox, the .Connector application options. and the Xcelerator Share web client.

In Femap, click on the Xcelerator Share commands to begin sharing:

Click... To...

Open a project file (see "File→Share→Open" in the Femap Commands guide)

Import geometry into an existing Femap model (see "File→Share→Import→Geometry" in the
Femap Commands guide)

Import an analysis model into Femap (see "File→Share→Import→Analysis Model" in the
Commands guide)

Import an analysis results into Femap (see "File→Share→Import→Analysis Results" in the
Commands guide
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Click... To...

Import an analysis results into Femap (see "File→Share→Import→Femap Neutral in the
Commands guide)

Check out/check in project files to Xcelerator Share (see "Simcenter Femap with Xcelerator
Share – Open a Project File" in the Commands Guide)

New Layup Manager

Femap Layups have been reworked, expanded and reintroduced in Femap version 2022.2 in the new
Layup Manager command. Layup Manager creates plies and layups, references existing layups within
other layups, manipulates ply order in layups, and generally manages layups for the entire model,
allowing you to create unlimited combinations of plies and layups. Earlier Femap versions Layup Editor
is replaced with Layup Manager.

Features

• Reference Layups – Reference existing layups into new layups, adds all plies of referenced layups

• Ply Materials – New Femap entity has associated Material and Thickness attributes, created and
edited with new Ply Material Manager

• Linked Plies – plies with links to a plies within the layup so Material, Thickness, and Angle
automatically update when changed

New Layup Manager
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Ply Material Manager, Global Ply Manager, and Multi Layup Editor

Several new commands that work with Layup Manager have been added too. The Ply Material
Manager creates "Ply Materials", a new Femap entity, which are ply definitions with associative material
and thickness attributes.

The Global Ply Manager creates "Global Plies" which are used in Layup Manager to create layups.

Finally, the Multi Layup Editor can edit multiple layups simultaneously in an intuitive manner using
a table format. The layups are stacked side by side in columns making it easy to carry out the editing
options.
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MONPNT2 Element Monitor Points

Added support for Simcenter and MSC Nastran’s MONPNT2 capability with the new Element Monitor
Point type. You can now create MONPNT2 entries with associated entities. The NASTRAN Monitor Point
Manager dialog has a new New Elem Monitor option added. It is used to define new Element Monitor
Points.

MONPNT2 Element Monitor Points
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Pressing New Elem Monitor opens the new NASTRAN Element Monitor Point dialog which is used to
create MONPNT2 entries (see "4.7.1 Model → Simulation Entities → Monitor Points" in the Commands
guide) for Simcenter Nastran and MSC Nastran.

Analysis Interfaces

Femap Neutral

• Updated Femap Neutral Read and Write for version 2022.2 changes.

Analysis Manager New Analysis Types

• Added 31..Aeroelastic Frequency Response, 32..Aeroelastic Transient Response, and
33..Aeroelastic Random Response to the Analysis Type drop-down for either Simcenter Nastran or
MSC Nastran.

5. What's New - version 2022.2
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Nastran (All Nastrans)

Aeroelastic Response (SOL 146)

Added support for Aeroelastic Response (SOL 146), which includes the ability to:

• Specify values for the Mach Number (MACH), Dynamic Pressure (Q), and Gust Load (GUSTAERO)
options in the NASTRAN Aerodynamic Data (AEROx, MKAEROx) dialog

• Specify options for Transient, Frequency, or Random Response via the NASTRAN Dynamic Analysis
dialog

• Specify Gust PSD Input for Random Response in the NASTRAN Power Spectral Density Factors
(SOL 146) dialog

• Choose a unique load set for the analysis using the Loads (Aerodynamic) drop-down in the
Boundary Conditions dialog. In addition, a Vertical Gust Load can now be defined using the Model
→ Load → Body command for use with SOL 146.

Nastran (All Nastrans)
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Distributed Memory Parallel (DMP)

Added support for specifying the number of tasks for a Distributed Memory Parallel (DMP) analysis
using MPI402/DMPARALLEL by turning on the Number of DMP CPUs option in the NASTRAN Executive
and Solution Options dialog, then entering a value.

Loads and Constraints

Added the ability to create an Aerodynamic Vertical Gust Load for use with Aeroelastic Frequency
Response, Aeroelastic Transient Response, and Aeroelastic Random Response (SOL 146 in Simcenter
Nastran and MSC Nastran).

Simcenter Nastran

• Updated Plastic Matl. Measures (STRMEAS) and Output Measure (STROUT) in the Multi-Step
Golbal Control Options dialog to be marked OBSOLETE, and changed the default to be a value of
-1..Nastran Default.

ANSYS

• Added read and write support for ANSYS MPC184 Joint Elements, including options for SECDATA,
SECJ, TB, SECLOCK, and SECSTOP.

Simulation Entities

• Added the ANSYS tab to the Joint Properties dialog box for Kinematic Joints which is used to specify
options for SECDATA, SECJ, TB, SECLOCK, and SECSTOP.

• Added 11..General as a Joint Type to both the Define Kinematic Joint and Define Joint Connection
dialogs. This type of joint is only used for ANSYS.

• Added the New Elem Monitor button to access the NASTRAN Element Monitor Point dialog, which
is used to support the MONPNT2 entry for Simcenter Nastran and MSC Nastran.

Improved Update Line Element Offsets Dialog

Improvements have been made to the dialog displayed by the Modify → Update Elements → Line
Element Offset command.

The previous dialog had different interactions (check boxes and/or push buttons ) depending on the
type of modification to be done. In addition the overall layout was somewhat random.

The new dialog has a more uniform layout with radio buttons for each method.
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In addition most of the necessary values to be entered are now in this dialog instead of requiring
additional dialog boxes.

Finally, a new capability has been added to add offsets along the vector when using the Around Vector
method. Previously only radial offsets were supported.

Two new API methods, feModifyRadialOffsets2( ) and feModifyOffsetssToRefPt2( )
have also been added.

Selecting Geometry from the Attached Mesh

Added new Group commands to be able to select geometry (Points, Curves, Surfaces and Solids) using
the attached mesh (Nodes and Elements).

• Group → Point → From Node

• Group → Point → From Element

• Group → Curve → From Node

• Group → Curve → From Element

• Group → Surface → From Node

Selecting Geometry from the Attached Mesh
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• Group → Surface → From Element

• Group → Solid → From Node

• Group → Solid → From Element

These methods allow you to choose one or more nodes or elements and they return the IDs of the
geometry the mesh entity is attached to.

When selecting nodes, multiple entities may be returned. For example, if a node is attached to a point
but you are selecting curves or surfaces then all curves or surfaces that use that point will be returned.
Similarly, if the node is on a curve, multiple surfaces may be returned.

When selecting elements, only element types that correspond to the geometry being selected are used.
You can select any elements, but some may have no effect. For example, if you are selecting surfaces,
only planar elements are used. If selecting Solids, only solid elements, etc.

When selecting elements, only the element attachment is required. It is not required or even tested to
see if the nodes of that element are attached to the selected or any geometry.

The same methods were added to the Method menu for the Standard Selection dialog when selecting
Points, Curves, Surfaces or Solids. And the List → Group command has also been updated to properly
handle the new methods.

Custom Contour Legend Labels

API code was added to allow an API user to create text labels at certain predefined locations on the
contour legend. The contour legend can be anywhere on the screen, can be Horizontal or Vertical, can
have the text on either side of the contour legend (Label Top/Left), and can be Reversed.

Export Femap Neutral Output (FNO) Added to Menu

You can now select File → Export → Femap Neutral Output... to export Femap’s own results output
format file. The FNO file is useful because it reads and attaches faster than other output file types like
the op2 and f06.
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Kinematic Joints MPC184

Kinematic joints defined in Femap are translated to ANSYS as MPC184 elements, and MPC184 elements
defined in ANSYS are translated to Femap as kinematic joints. Kinematic connections defined in Femap
are translated to ANSYS as contact/target pairs in addition to MPC184 elements. Joints that are defined
on geometries in ANSYS Workbench are translated to Femap as connections in addition to being
translated as kinematic joints. Drivers/loads applied on joints in Femap are translated to ANSYS as
DJ/FJ commands. DJ/FJ commands that are defined in ANSYS are translated to Femap joint drivers/loads.
ANSYS Joints stiffness/damping/coefficient of friction and other joint properties are stored in Femap and
are not shared with Nastran joint properties.

NASTRAN and ANSYS Joint Types and their Free DOFs

NASTRAN joints ANSYS joints Free DOFs

Slider Translational Ux

Revolute Revolute Rx

Cyldr Cylindrical Ux, Rx

Screw Screw Ux, Rx

Universal Universal Rx, Rz

Sphere Sphere Rx, Ry, Rz

Fixed Weld

Sliunv General Ux, Rx, Rz

General any

Convel ?

Point-on-plane,
[Orient]

Ux, Uy, Rx, Ry, Rz [U]

ANSYS does not support the Nastran Constant Velocity Joint.

ANSYS offers a General Joint that Nastran does not support.

In the Define Kinematic Joint dialog, you select a Joint Type, the two nodes linking the two bodies,
and two coordinate systems defined for the two nodes that represent the joint orientation. With the
11..General Joint Type for ANSYS, you check the Relative DOF check boxes to activate the joint degrees
of freedoms constrained by the joint. With other types of joints, the Relative DOF check boxes are set
automatically according to the joint mechanics and cannot be changed. The other joint properties can
be set in the Joint Properties dialog.

Kinematic Joints MPC184
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User Interface
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API Selection Tools in Entity Selection Pick Menu

Added a capability similar to the Custom and User Tools menus into the Standard Selection dialog so that
it is possible to update or make selections with custom API tools.

A submenu API Selection Tools is added to the Pick menu that allows you to populate the menu with
custom API tools.

Note:

The default Tools Directory is APISelect under the Femap install if not set manually. It can be set
in the Tools Directory popup or in Library/Sartup tab of the File → Preferences command.

API Selection Guidelines

There are some restrictions on APIs used for Selection and care must be taken to follow these guidelines:

• Every selection tool API must call feStartSelectionTool( ) and should always check the entity
type being selected. It should always abort if it does not support the entity type being selected. This
call should be one of the first API calls that you make. It must come before any calls that would display
another selection dialog.

• A Selection API may display dialog boxes, including other selection dialogs. If it does display another
selection dialog, the Selection API menu will not be available as only one API can be run at a time.

• You should not add APIs to the Selection API directory that are not intended simply to update the
selection process.

• Care should be taken not to update the model database during a Selection API. While all API
functionality is available, results will be unpredictable and potentially damaging if you attempt to
update the model while already in the selection process.

API Selection Tools in Entity Selection Pick Menu
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• Either feEndSelectionTool( ) or feAbortSelectionTool( ) should be called at the end of
the API … and they may only be called once after calling feStartSelectionTool( ).

Paramaters Dialog

Updated the Tools → Parameters command's Model Parameters dialog to include the Design
Equation option with NextID and Increment fields.

New From Node/From Element Entity Selection Pick Methods

• Added From Node to the Method^ menu of the standard Entity Selection dialog when selecting
points, curves, surfaces, or solids. When used, any point, curve, surface, or solid, respectively, which
has a node associated with the geometric entity will be selected.

• Added From Element to the Method^ menu of the standard Entity Selection dialog when selecting
points, curves, surfaces, or solids. When used, any point, curve, surface, or solid, respectively, which
has all nodes of the selected element associated with the geometric entity will be selected.

Bitmaps for Custom Tools, User Tools, and Selection Tools Menu

• Enhanced the ability to specify bitmap files for the Custom Tools, User Tools, and the new Selection
Tools menu, and to be able to add icons to the commands. Previously, those bitmaps were limited to
16x16 pixels. Now they can be any size, however 16x16, 24x24 and 32x32 pixels provide the clearest
images depending on the resolutions and Windows Display settings used when running Femap.

Preferences

• Library/Startup tab - Added the Selection Tools Path field to specify the directory where API scripts
can be stored for use with the API Selection Tools submenu of the Pick^ menu in the standard Entity
Selection dialog.

API Programming

New and updated API Objects and Attributes

• Added Ply Material (fePlyMaterial) Object to the API.

• Added title, matID, thickness, and failuretheory to the Ply Material Object

• Added NasExecNumDmpCPU, NasAeronPARAMgustaero, NasAerodPARAMmach,
NasAerodPARAMq, and NasMonitorElemEnabled to Analysis Manager Object

• Added NasCaseMonitorElemEnabled to Analysis Case Object

• Added validate to Global Ply Object
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5-16  Femap What's New, Femap 2301
© 2023 Siemens



• Added JointProp, vJointProp, flag, and vflag to the Joint Object.

• Added OnOff, vOnOff, and IncludeOffPlys to the Layup Object. Also, updated thickness,
vthickness, angle, vangle, matID, vmatID, globalply, vglobalply, failuretheory, and
vfailuretheory to work with updated Layup Manager dialog box.

• Added BodyGustOn, BodyGustWG, BodyGustX0, BodyGustVelocityOpt, BodyGustVelocity,
BodyGustAppliedNode, and BodyGustFunction to the Load Set Object.

• Added NumberOfContributions to Monitor Point Object.

New and Updated API Methods

• Added IsGust, GetCorrelateGust, and PutCorrelateGust to the Analysis Manager Object

• Added GetAllArray, GetAllAttrArray, PutAllArray, and PutAllAttrArray to the Curve
Object

• Added SetReferencedGroups to the Group Object

• Added AddPlyMaterialPly, AddLayupPly, AddMatchedPlys, GetPlyInfo,
GetAllPlyDefinition, MaterialsUsed, GlobalPlysUsed, and PlyMaterialsUsed to the
Layup Object.

• Added GetAllArray and PutAllArray to the Material Object.

• Added AddManualContribution, GetElemContributions, SetManualContributions,
ClearElemContributions, GetAtIndex, and SetAtIndex to Monitor Point Object.

• Added GetAllArray, GetFlagArray, PutAllArray, and Put FlagArray to the Property Object

• Added GetAllArray, GetAllAttrArray, PutAllArray, and PutAllAttrArray to the Surface
Object

• Added SetOpenGLTransformationSpace, GetOpenGLTransformationSpace,
CollectorContourLegendText, and CollectorAddTextContourLegendLocations to User
Defined Graphics Object.

New and Updated Global Variables

• Added Pref_SelectionToolsPath to specify the directory to store API scripts to be used with the
API Selection Tools submenu on the Pick^ menu in the standard entity selection dialog box.

The following functions have been added or updated:

• feStartSelectionTool

API Programming
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• feEndSelectionTool

• feAbortSelectionTool

• feModifyRadialOffsets2

• feModifyOffsetsToRefPt2

• feElementTypeCount

• feElementShapeCount
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6. What's New - version 2022.1 MP1
The following chapters describe new features, changes and enhancements to Femap for version 2022.1
MP1.

• Severeal Geometry Editing tool enhancements.

• New API calls GetSuperElementIDArray and PutSuperElementIDArray added to Node
Object.

Note:

A number of issues have been addressed, please see readme.pdf found in the pdf directory for a
full list of corrections.

Tools

Geometry Editing tool

Updated the Point to Point, Point to Edge, and Edge to Edge options in the Operation section to
use more robust methods to determine and process how a surface is spilt by these operations.

OLE/COM API

Added two new API calls to bulk access and/or update the Superelement ID stored on nodes.
GetSuperElementIDArray and PutSuperElementIDArray work similarly to the bulk node data
access routines.
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7. What's New - version 2022.1
The following chapters describe new features, changes and enhancements to Femap for version 2022.1:

User Interface

General

• Added a Add to Copied Entity Groups option to the Parameters section in the Copy Option dialog
box for Geometry → Copy/Rotate/Reflect commands for all geometry types.

• Added the Nonstructural Mass Property Values section to the Define Property - BEAM Element Type
dialog box (Model → Property – Beam command). Renamed the Nonstruct Mass/Length option to
Nonstructural Mass/Length, and moved it from Property Values to the new Nonstructural Mass
Property Values section.

• Changed the name of the Autodesk Nastran tab to Simcenter/Autodesk Nastran in the Model →
Property command for Plate element Property Extensions dialog box.

Menu

• Added the HexMesh Bodies... command to the Mesh menu. See Hex-Dominant Mesher for more
information.

• Added the Mapped Hex Refine... command to the Mesh → Editiing submenu. See Hex-Dominant
Mesher for more information.

• Added the Kinematic Driver... command to the Model → Load submenu. See Kinematic Joints for
more information.

• Added the Kinematic Joints... command to the Model → Simulation Entities submenu. See
Kinematic Joints for more information.

• Added Kinematic Joint... to the Delete → Model submenu.

• Added Kinematic Joint to the Group menu. The Kinematic Joint... item contains submenu items ID,
Color and Layer.

• Added the new Node\Element Entity Eelection methods to the Group → Node and Group → Element
submenus. See UI/Usability Features for more information.

• Added Flexible Sliders to the Model → Simulation Entities submenu. See Flexible Sliders for more
information.
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• Added Flexible Slider... to the Delete → Model submenu.

Model Info Tree

• Added the ability to Evaluate Groups from within the Model Info tree. See UI/Usability Features for
more information.

• Added Kinematic Joints to the Simulation Entities branch of the Model Info tree. See Kinematic
Joints for more information.

• Added Flexible Sliders to the Simulation Entities branch of the Model Info tree. See Flexible
Sliders for more information.

Entity Selection

• Added Methods to select nodes and elements on points, curves, and surfaces of solids. See UI/
Usability Features for more information.

• Added Methods to select nodes and elements on points, curves, and surfaces of solids. See UI/
Usability Features for more information.

Preferences

• Interfaces tab - Added new settings in the Nastran Options section; Activate OGEOM Parameter,
Results Dest. (Femap or Simcenter) to assist requesting Nastran analysis output to the .op2 file. See
Request Output To .op2 File for more information.

• Color tab - Added a Kinematic Joint item to Entity Colors. See Kinematic Joints for more
information.

• User Interface tab - Added the Help... button. Opens the Help Options dialog which is used to select
the Femap help source (Online HTML or Local HTML - requires Siemens PLM Documentation Server).
See New Help System for more information.

Hex-Dominant Mesher

Hex-dominant meshing of solid geometry with little to no simplification or subdivision into smaller and
simpler regions has long been desired by the finite element analysis community. Simcenter Femap has
collaborated with other development organizations in the Siemens Simcenter Portfolio in order to offer
this exciting technology to Femap users for the first time for v2022.1.

To accomplish this goal, the hex-dominant mesher first fills a solid volume with as many hexahedral
elements as possible, then fills the remainder of the volume with wedge, pyramid, and tetrahedral
elements, as needed. This process creates high quality elements which can be sent directly to the
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Simcenter Nastran solver with no additional interaction from the user or manual refinement of the
mesh.

In addition to being able to mesh single parts, the hex-dominant mesher can work on multiple parts to
create a single continuous mesh of the assembly. There are also additional options to control various
aspects of mesh sizing, mesh associativity, and if all elements should be given midside nodes during the
meshing process.

The following two commands are added for Hex-Dominant Hexahedral Meshing.

Automatic Hex-Dominant Meshing of CAD Geometry

Previous versions of Femap provide semi-automatic , but it requires you to split the geometry into
sections so Femap could setup connected mesh sizing and sweepable areas. This can be time
consuming, and is essentially an intuitive process.

Added a HexMesh Bodies... command to the Mesh menu.

The new HexMesh Bodies... command eliminates the need to split the geometry. Selecting the Mesh
→ HexMesh Bodies... command will open the Hex-Dominant Automesh Bodies dialog box after the
geometric entities are selected.

Hex-Dominant Mesher
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Constrained nodal locations make it difficult to get an acceptable hex-dominant mesh, so options are
therefore very similar to the Mesh → Bodies... command. You are given a Target Element Size, not an
exact one.

The Mesh Associativity section is where required geometry is associated, or geometry with Loads,
Boundary Conditions, Contact Regions, etc. You can also request associativity on additional entities if
required.

Node Options control how the Midside Nodes are handled, or the element order and projection to
geometry.

The mesher can take some time to process. When the meshing is finished and the Midside Nodes are
processed, you end up with a Hex-Dominant Mesh.
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will then display statistics in the Messages window. Counts of Hex, Wedge, Pyramid and Tet elements
are listed. Also, listed is the percentage of Hex elements by volume. In the example here, 96% of the
volume is encompassed by hexihedral elements.

Use the Model Tree to view the mesh elements (Model → Elements → By Shape):

Hex-Dominant Mesher
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Using the Check Element Quality command (Tools → Check → Element Quality...) will indicate the
elements pass the Nastran checks.
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Automatically Refine Hexihedral Meshes

Added a Mapped Hex Refine... command to the Mesh → Editiing submenu.

Hex-Dominant Mesher
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Selecting Mesh → Editiing → Mapped Hex Refine... opens the Mapped Hex Refinement dialog box for
the selected mesh.
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Pick the hexahedral elements you want to refine, and click OK. The command splits all the hex elements,
and produces a more refined hex mesh in the local area. Checking Repeat Refinement automatically
refines down another layer.

Note:

The Mapped Hex Refine... command is used for traditional Mapped Hexahedral Meshes, not
mixed Hex-Dominant Meshes.

Kinematic Joints

Simcenter Femap will begin to provide support for advanced simulation methods, such as flexible body
dynamics, using Simcenter Nastran’s Multi-Step Nonlinear Kinematic solution, SOL 402. As a first step,
Kinematic Joints have been added as Simulation Entities for version 2022.1.

Kinematic Joints allow for structural analyses of assembies containing moving parts. Kinematic Joints
connect two nodes and allow a certain relationship of relative motion or rotation between the two
depending on what type of joint is established. The types of Kinematic joints include revolute, inline,
slider, spherical, cylindrical, and other highly specialized types which can be used for the analysis of

Kinematic Joints
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models containing moving parts, such as aerostructures, helicopters, deployable structures in space, gas
turbines, and machine tools. The addition of drive loads as a new load type can be used to enforce
displacements or rotations on kinematic joints.

To accelerate the process of creating kinematic joints, Kinematic Connections have also been added,
which are a type of entity unique to Femap. Kinematic Connections allow the user to establish how a
kinematic joint will be connected to geometry or existing mesh of the model and are then expanded to
the necessary nodes when Simcenter Nastran input file is exported.

Kinematic joints are found under the Simulation Entities branch in the Model Info tree.

Defining Kinematic Joints

Select the Kinematic Joints element from the Model Info tree, right click, and choose  Kinematic

Joint from the menu - Or select from the main menu: Model → Simulation Entities →  Kinematic
Joints.... This opens the Define Kinematic Joint dialog box.

You can create various joint types by selecting from the Joint Type drop-down. The options are
1..Revolute, 2..Inline, 3..Slider, 4..Spherical, 5..Cylindrical, 6..Slider-Universal, 7..Fixed, 8..Screw,
9..Universal and 10..Constant Velocity.

The example below, the model has four revolute joints connecting the suspension linkage on the rear of
a mountain bike. This allows you to connect the different pieces of the assembly, and also allows them
to rotate.
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With this model solved, it can be animated to show the deformation of the rear suspension travel.

As the frame articulates, the revolute joints connect the parts of the geometry in the assembly, and
allow the pieces to rotate about the point of the revolute joint.

Defining Kinematic Joint Connections

There has also been the addition of kinematic connections. These kinematic connections speed up the
process of creating kinematic joints.

Select the Kinematic Joints branch from the Model Info tree, right click, and choose  Kinematic
Connection from the menu. This opens the Define Joint Connection dialog box.

Kinematic Joints
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For instance, to create a revolute joint on one side of some universal joint geometry, set it To Ground
because it is attached to nothing on the open end. Then connect the motion attachment as a surface.

Femap automatically generates a coordinate system in the axis that is needed, along with the point of
the joint location.
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Click Joint Properties... (opens the Joint Properties dialog box) to specify some of the more technical
things like translation stiffness - Translation (KT), rotational stiffness - Rotational (KR) and others
depending on the type of joint.

Kinematic Joints
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On the General tab of the Joint Properties dialog box, you can set some of the Connection Expansion
methods. For instance, select a surface to connect to so you can choose whether it expands out to
0..Nodes on boundary only, 1..Nodes in interior only, or 2.. Nodes on boundary and interior.

For the Nastran expansion - Connection (Nastran) - you select what type of element will connect the
joint to the mesh.

With more kinematic connections added creating a universal joint, the motion can be simulated. First,
the surface of the holes (1) that make up the clevis and a coordinate system with the x-axis (2) oriented
to align with the holes. Secondly and similarly, on the other side of the assembly, the holes (3) are
aligned to the other coordinate system (4). This completes the universal joint.

Create Loads on Kinematic Joints

To drive the motion of the simulation, a driver load is needed on the revolute joint. The new 

Kinematic Driver... command is used to accomplish this. Select Model → Load → Kinematic Driver...
to start the command. The menu selection opens the Create Loads on Kinematic Joints dialog box.

Kinematic Joints
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Select the Enforced Rotation load, and enter a Magnitude of 360 degrees (in radians) and apply it to
the joint (click OK).

Managing Kinematic Joints

The right click menu in the Kinematic Joints branch of the Model Info tree has several additional
options.

Note:

The menu is available if you click on the branch and the individual kenematic joints.

The Kinematic Joint Manager menu option opens Kinematic Joint Manager dialog box.
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Here, the Kinematic Joints in the model are listed. You can do some of the same actions mentioned
previously such as creating a New Joint, or a New Connection. Edit kinematic joints by clicking Edit
Selected... (opens the Define Joint Connection dialog box). You can delete the selected kinematic joint
(click Delete...) or delete all the kinematic joints in the model (click Delete All...). There are also options
to Expand, Copy..., Renumber and Preview the kinematic joints in the model. Finally, if you have a
long list of kinematic joints, you have the option to filter by title (enter text into the Title Filter field).

The List menu option lists information on all the kinematic joints in the Messages pane. For example:

          ID         
Title                                                            
Type              Node 1     Node 2     CSys 1     CSys2
_________________________________________________________________________
_________________________________________________________________________
_________________________
          2001       
Spherical                                                                
        Spherical         2301       2302       0          0         
 
 
          ID         
Title                                                            
Type              Attach     Attach 2   CSys 1     CSys2
_________________________________________________________________________
_________________________________________________________________________

Kinematic Joints
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_________________________
          2000       
Revolute                                                                 
        Revolute          Surfaces   Nodes      0          0         
          2002       
Slider                                                                   
        Slider            Surfaces   Surfaces   0          0         
 

The Color and Layer options are used to manipulate the kinematic joints display and layer assignment.
They open the Color Pallete and Select Layer dialog boxes.

The Copy, Edit, Delete and Renumber menu options act in the same way as their counterparts in the
Kinematic Joint Manager.

Flexible Sliders

Simcenter Femap’s support for kinematic analysis of mechanical systems is enhanced with the addition
of Flexible Sliders simulation entities in version 2022.1. Flexible Sliders allow analyses to accurately
simulate the deformation of curvilinear tracks as assembly components are displaced along them.

This capability includes several parameters for customization such as different slider types, driver loads,
and additional friction options. The available slider types allow different constraints for relative rotation
of the nodes sliding along the track. This includes spherical, prismatic, cylindrical, and universal types.
For driver loads, Flexible Sliders can be driven with both external load sets, and forces/displacements
applied directly to a specified driver node. Furthermore, for friction, available types include options for
validating motion (no friction), infinite friction, and displacement or velocity dependent frictional forces.

When defining Flexible Sliders in Femap, multiple options are also available for specifying their
required references. Existing group entities can be assigned to the Flexible Sliders to define the nodes
to be displaced along the track, or the beam elements making up the track. In the absence of group
entities, dynamic selection lists can be also be used to assign these entities on-the-fly. After creating the
Flexible Sliders, they can be selectively exported to a SOL 402 analysis with support for specification of
single Flexible Sliders or a union of Flexible Sliders.

In Femap, Flexible Sliders are found in the Simulation Entities branch of the Model Info tree. Or you

can access them from the main menu: Model → Simulation Entities →  Flexible Sliders...

From the Model Info tree, right click on Flexible Sliders, and select New from the menu. This selection
opens the NASTRAN Flexible Slider dialog box which is where you define the parameters for the Flexible
Slider Joint.
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There are four Flexible Slider Types: 0..Spherical, 1..Cylindrical, 2..Prismatic, and 3..Universal. The
Driver Load sections contains Driver Types which include 1..Force and 2..Displacement. The The
Friction section has an Option drop-down with several friction parameters.

The Displacement Entities section allows you select the nodes you want to displace along the flexible
slider joint. Select either the from the Node Group driop-down or create a dynamic selection list of the
nodes (Node List → Select...).

Flexible Sliders
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The Slider Trajectory section is where you define the beam elements that comprise the flexible and
curvilinear track. Select either the from the Beam Group driop-down or create a dynamic selection list of
the beams (Beams List → Select...).

When the Flexible Slider is defined, you can export it to an Analysis Set. Select Model → Analysis.….
Then in the Analysis Set Manager, expand the tree structure, expand the Flexible Sliders branch, and
click on the Flexible Slider.

After the analysis is successful, and post processing is completed, the analysis study can be animated
showing deformation and stresses in both the flexible path and the car body.

In the animation, the track deforms as the car travels along it.
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Analysis Program Interfaces

In Simcenter Femap’s ongoing mission to provide support for functionality available in Simcenter
Nastran, as well as other Nastran solvers, a number of enhancements have been made for version
2022.1. These include:

• Simcenter Nastran - Added the ability to request Simcenter Nastran to produce an output file, in
particular an .op2 file, in a format which can then be used by, Femap, and other applications in the
Siemens Simcenter Portfolio, including Simcenter 3D, and other commercially available pre and post
processors. See Request Output To .op2 File for more information.

• Simcenter Nastran - Added support for Tension-Only Quadrilateral Shell Elements, which have
been added to the Multi-Step Nonlinear solution sequence, SOL 401, for Simcenter Nastran. See
Support for Tension-Only Quadrilateral Shell Elements for more information.

Analysis Program Interfaces
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• Simcenter Nastran - Added support for a new way to specify control options for the Dynamic Design
Analysis Method, often called DDAM. See New Methodology for Control Option Specification in
the Dynamic Design Analysis Method (DDAM) for more information.

• Simcenter Nastran - Added new Solution Monitor options for monitoring analyses. See Nastran
Solution Monitor for more information.

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

Request Output To .op2 File

First, it is now possible to instruct Nastran to create an output file, in particular an .op2 file, which
can be used by other applications in the Siemens DI Software Simcenter Portfolio, including Simcenter
3D, from within the Femap User Interface via the Analysis Set Manager. In addition, there is also a
preference which can be set to have this be the default behavior.

To have Femap request output be placed into the .op2 file in this format, use the Analysis Set Manager
command (Model → Analysis...) and select Output Requests from the tree structure.
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Click Edit... to open the Nastran Output Requests dialog box. Select Simcenter in the Results
Destination section. That is all that is needed.

Request Output To .op2 File
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Nastran now knows to produce this type of output by having PARAM,POST set to a value of -2 in the
input file.
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You can also set Femap to always create .op2 files using PARAM,POST,-2 with the File → Preferences
command. In the Preferences dialog box, choose the Interfaces tab, and set the Results Destination
option to Simcenter.

Some pre and post processors that can read .op2 files created using PARAM,POST,-1, which is the
Femap default, require that the model information also be in the .op2 file, which is done by setting
PARAM,OGEOM to a value of YES. By turning on the Activate OGEOM Parameter option on this same
tab, all newly created Analysis Sets will have the OGEOM option turned on automatically.

Support for Tension-Only Quadrilateral Shell Elements

Support for Tension-Only Quadrilateral Shell Elements is added in Simcenter Nastran’s Multi-Step
Nonlinear solution sequence, SOL 401. The Tension-Only Quad will behave like a typical shell element
instead of behaving like a shear panel element based on component direction and a compression
allowable, both specified by the user, which creates a PSHLPNL entry in the Nastran Input File.

Once the conversion has occurred, the element will continue to act as a shear panel for each
Sequentially Dependent subcase following an initial Sequentially Independent subcase. Also, it is now
possible to specify a parameter which controls if the tension-only capabilities should be considered for a
particular analysis.

In Femap, the behavior of Tension-Only Quad elements is controlled by specifying Property Extensions
which are available when defining a Plate Property. Select the Model → Property... command making
sure the Elem/Property Type... is set to Plate. Choose the Simcenter/Autodesk Nastran tab, and then
specify which component direction of use for every quad element referencing that property, such as Use

Support for Tension-Only Quadrilateral Shell Elements
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X Membrane Stress, Use Minimum Principal Stress, etc, along with a Compression Allowable value
to determine when a shell element will start to behave like a shear panel.

Once converted, the element retains shear panel behavior for the remainder of any sequentially
independent subcase and any sequentially dependent subcases which follow.

After the Property Extensions are specified, the TENSOQD parameter can be specified in the Analysis
Set Manager to control the behavior of Tension-Only Quads. Select the Analysis Set Manager
command (Model → Analysis...), select Bulk Data from the tree structure, and click Edit... to open
the Nastran Bulk Data Options dialog box.
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By default, the ability to have shell elements convert to shear panel elements is active but can be
deactivated by turning on TENSOQD and setting it to Tension-only Quad behaves as shell. In addition,
any time Tension-Only Quad Property Extensions are defined, the ESHLPNL entry is automatically added
to Case Control of the Simcenter Nastran Input File.

Support for Tension-Only Quadrilateral Shell Elements
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In addition, any time Tension-Only Quad Property Extensions have been defined, the ESHLPNL entry will
automatically be added to Case Control of the Simcenter Nastran Input File.

Once the analysis is completed, it is easy to visualize which elements wre converted to Shear Panel
Elements by displaying Shear Panel Results. After looking at the shear panel results, it is also possible to
look at the shell element results to see which elements were not converted to Shear Panel Elements.

New Methodology for Control Option Specification in the Dynamic Design
Analysis Method (DDAM)

support was added for entries in Simcenter Nastran which offer a streamlined approach to specify
control options for the Dynamic Design Analysis Method (DDAM). DDAM is a three step process which
runs a modal analysis, sends needed results and other inputs specified by the user to the NAVSHOCK
Fortran application, then creates Summed Modal Results during the final step.

The Dynamic Design Analysis Method, often called DDAM, is added to Simcenter Femap. DDAM is
performed in 3 steps.

1. Simcenter Nastran performs a modal analysis on the structure to calculate the modal participation
factors and modal effective mass for each mode.

2. The Naval Shock Analysis FORTRAN program, NAVSHOCK, uses the modal effective masses and
natural frequencies calculated by Nastran along with user inputs to compute shock design
accelerations.

New Methodology for Control Option Specification in the Dynamic Design Analysis Method (DDAM)
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3. Simcenter Nastran uses the shock design accelerations along with the modal participation factors
and natural frequencies to compute the shock response of the structure.

The first thing needed within in Femap to run a DDAM Analysis is an Analysis Set specified to run a
Normal Modes/Eigenvalue solution. Select the Model → Analysis... command, and click New... in the
Analysis Set Manager dialog box. In the Analysis Set dialog box, select 2..Normal Modes/Eigenvalue
from the Analysis Type drop-down.

Once that is specified, almost everything else is controlled via the NASTRAN DDAM Solution Options
dialog box. Click OK to create the new Analysis Set. Then in the Analysis Set Manager, choose DDAM
Options from the tree structure, and click Edit...

The first thing you want to do is to check the Enable DDAM Analysis option. Currently, if you choose
the DDAM option in the Spectrum/Coefficient Options section, Femap runs DDAM using the legacy
method. This method entails creation of multiple external files. All the options in the NASTRAN DDAM
Solution Options dialog box are written to a control file which is then sent to the NAVSHOCK program.
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To use the new methodology, choose the DDAMCTR/SPDIR option, and instead of all the options being
written to an external file, they are written to two Nastran entries which are included in the Nastran
Input File. Back in the Analysis Set Manager dialog box, click Preview Input to see the values are there
for those Nastran entries.

New Methodology for Control Option Specification in the Dynamic Design Analysis Method (DDAM)
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Once the DDAM Analysis is complete, three output sets in the Model Info can be explored. They are the
Summed Modal Response in the X, Y, and Z directions, respectively.
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Nastran Solution Monitor

The Simcenter Nastran Solution Monitor can now be accessed by Simcenter Femap 2022.1, and allows
you to view the results of an analysis and/or review curated output from Simcenter Nastran including
information, warning, and error messages recovered directly from Nastran while the analysis is running
or after it has been completed.

Nastran Solution Monitor
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The Solution Monitor is most helpful when used to monitor Simcenter Nastran’s Multistep Structural or
Multistep Nonlinear Kinematic Solutions Sequences, SOL 401 and SOL 402, thus is the default for those
types of analysis. It can also be invoked for other types of analysis by selecting the appropriate option for
Solution Monitor when specifying Executive and Solution Options in the Analysis Set Manager.

The reason the solution monitor is so valuable when using SOL 401 or SOL 402 is it provides information
such as the time increment and iterations for each step, convergence criteria, cumulative number of
iterations, energy evolution, contact/material status, number of nodes in contact, damaged elements,
creep elements, and elements which have experienced plastic deformation. Knowing this type of
information during a multistep solve can be used to determine if the solution is properly converging
and should be allowed to continue or is diverging and various options and/or model setup choices
should be reevaluated.

You can access the new Solution Monitor. First open the Analysis Manager dialog box (Model →
Anslysis...), choose Executive/Solution from the tree structure, and click Edit....

Then in the NASTRAN Executive and Solution Options dialog box, choose 2..Launch
SimcenterNastran's Solution Monitor from the new Solution Monitor drop-down list.
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Click OK, and then click Analyze in the Analysis Set Manager dialog box. The Simcenter Nastran
Analysis Monitor panel appears docked next to the Model Info panel.

Nastran Solution Monitor
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When the analysis starts, the Solution Monitor appears indicating the solver has started.

In this example, the analysis is a 402 solution, so there is a SOL402 tab included. This shows the
different time steps requested, and the analysis and iterations it takes for each step. As the monitor
goes through and dgets ready to prepare the time steps, you will see a message ––-- Sending mesh
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to the Solution Control Monitor ––--. Click the SC Monitor icon on the toolbar to open the
Solution Control Monitor to preview the model mesh.

When the analysis is complete, you can review Results on the Post View tab of the Solution Control
Monitor. The Result Type drop-down includes result types such as Displacement and Displacement
Magnitude. The View Options section contains view orientation options and an Export Image
command to capture the preview in an image file.

The time steps are displayed showing information about each iteration. The next time step begins after
the message –– Time step accepted –--.

Nastran Solution Monitor
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The time steps continue until the analysis is completed. The total number of time steps is displayed at
the bottom of the Solution Monitor.
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Click the SC Monitor icon on the toolbar to open the Solution Control Monitor to preview the
Displacement Magnitude.

Nastran Solution Monitor
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The Solutions Manager also offers several Graphs to view Contact / Material status, Convergance and
Energy.
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UI/Usability Features

View Entity/Labels Toggle

The standard Entity Display Toolbar has been enhanced to include an icon which can be toggled to
select if the toolbar is currently controlling the overall display of the various entity types available on the
toolbar or the labels for those entity types.

The first Icon now controls Entity or ID.

UI/Usability Features
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Evaluate Groups from Model Info

Added the ability to Evaluate the rules for any number of selected Groups via the context-sensitive
menu for Groups in the Model Info pane, which eliminates the need to use the multiple step process
when using the Evaluate command from the Group menu.

If the surfaces are meshed or the mesh is updated, right click the Group in the Model Info tree and
select Evaluate from the menu. Once the view is refreshed, the evaluated group is displayed.
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UI/Usability Features
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Methods to Select Nodes and Elements on Points, Curves, and Surfaces of Solids

Additional entity selection methods for nodes and elements are now available during standard entity
selection. New methods for selection of nodes on the Entity Selection dialog box Method^ drop-down
include on Points of Solid..., on Curves of Solid... and on Surfaces of Solid....

As for elements, new methods on the Entity Selection dialog box Method^ drop-down include All
Nodes on Solid, on Points of Solid..., on Curves of Solid... and on Surfaces of Solid....
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Add Rules to Groups Using the New Node\Element Entity Selection

For Groups, these same selection methods have been made available to use as rules on the Group menu
for Nodes and Elements, respectively.

UI/Usability Features
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New Help System

The location and format of the Help System for Femap can now be specified via a Preferences with
the ability to choose the compiled help from previous versions or presented as HTML pages, either
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accessed online or locally using the Siemens Help Server application. See New Help System for more
information.

New Help System

A big change to Femap’s user experience is a new Help System providing the ability to select Online Help
or Local Help.

A new Help... button is added to the File → Preferences command on the User Interface tab of the
Preferences dialog box.

New Help System
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Clicking it opens the Help Options dialog box. This dialog controls which source is used to display help
content. You do not have to exit Femap for the change to take effect.

The options in the Help Location section are used to select the help system used by Femap.

Help Type

Here, you select which help system to use.

0..Online HTML

Activates online web help. Help is hosted on the Siemens Support Center website - This is the
default source when you access Femap Help from the product. This is the web-served HTML
help that you view in an internet web browser.

Note:

Online help for all Siemens software is available on Support Center: https://
www.plm.automation.siemens.com/locale/docs/

1..Local HTML

Activates locally installed web help. This help system requires you install the Siemens PLM
Documentation Server web server application - By installing the Siemens PLM Documentation
Server, you can host online help for Femap and other Siemens Digital Industries Software
products on your local host or intranet. This installs the HTML help collection on an internal
server or a standalone computer. It provides the same content and is also displayed in a
web browser. When deployed on your local intranet, the Siemens PLM Documentation Server
can host online help for multiple languages and multiple Siemens Digital Industries Software
products. It provides a fast, powerful, server-based search engine.

Note:

To use this option, you must install the Siemens PLM Documentation Server and the
Femap help, which are installations separate from the installation of Femap.

New Help System
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If you do not have user privileges to access the public internet, and if your company
provides access to locally installed help, select this option and enter the URL of the local
server in the Help Location field.

Help Location

Activated when 1..Local HTML is selected as the Help Type. Enter the URL of the local server in this
field to use locally istalled help.

API

Overall Functionality

• Updated API methods to be able to pass Variants or single valued variables dimensioned as BOOLEAN,
INT2/INT4/INT8, or REAL4/REAL8 to input array arguments if all values of the array are supposed
to contain the same value. Previously numeric constants and dimensioned array variables were
supported, but not the new combinations.

New and updated API Objects and Attributes

• Added Kinematic Joint and Joint Connection (feJoint) Object to the API.

• Added color, layer, title, type, JointBehavior, G1, G2, PID, HasCID1, CID1, HasCID2, CID2, HasG3,
G3, KT, KR, CF, FR0, LR, LX, LY, LZ, RegularizationOpt, TOL, KCF, LIBL, PITCH, OPT, HasSPR1TRA,
K1T, K1TTID, SK1TTID, HasSPR1ROT, K1R, K1RTID, SK1RTID, HasDAM1TRA, B1T, B1TTID, SB1TTID,
HasDAM1ROT, B1R, B1RTID, SB1RTID, JointLoc1, vJointLoc1, JointLoc2, vJointLoc2, JointLoc1_x,
JointLoc1_y, JointLoc1_z, JointLoc2_x, JointLoc2_y, JointLoc2_z, HasTarget1List, HasTarget2List,
Target1SetID, Target2SetID, Target1Type, Target2Type, CurveExpansionOpt, SurfExpansionOpt, and
ElemExpansionOpt to the Kinematic Joint and Joint Connection Object

• Added Flexible Slider (feFlexibleSlider) Object to the API.

• Added color, layer, title, NasTYPE, NasNGRPID, NasBGRPID, NasSGID, NasPROJ, NasHasNLIM, NasNLIM,
NasDTYPE, NasDGID, NasDVAL, NasDTID, NasFOP, NasCF, NasTOL, NasKCF, HasNodeList, HasElemList,
NodeSetID, and ElemSetID to Flexible Slider Object

• Added AddToCopiedEntityGroups and CopyMeshSize to the CopyTool Object

• Added NasBulkTENSOQD, NasBulkTENSOQDval, NasSolutionMonitorOpt, NasMsNLKGlobalRESXTRP,
NasMsNLKGlobalBOLTMETH, NasMsNLKGlobalPLSHSOL, NasDdamSpdirCSID, NasDdamSpdirCOMP,
NasDdamFileUnit, NasMsnlkJCON, NasMsnlCntPLSHUT, and NasMsnlkCnt2PLSHUT to Analysis
Manager Object

• Added VectorPressure, vPressureDirection, and PressureDirection to the LoadMesh Object

• Added IsSequence to the LoadSet Object.
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New and Updated API Methods

• Added GetReferenceSet, ClearReferenceSet, PutReferenceSet, GetMotionSet, ClearMotionSet, and
PutMotionSet methods to the Kinematic Joint and Joint Connection Object

• Added GetComponentSet, ClearComponentSet, and PutComponentSet Methods to Flexible Slider
Object

• Added PutFLXSLISetID, GetFLXSLISet, ClearFLXSLISet, and PutFLXSLISet to the Analysis Manager
Object

• Added Solid to MeshPoint Object

New and Updated Global Variables

• Added Pref_OnlineHelp_Mode to set Help Type preference in the Help Options dialog box accessed via
User Interface tab of File, Preferences.

• Added Pref_OnlineHelp_Path to set directory path for Help Location preference in the Help Options
dialog box accessed via User Interface tab of File, Preferences.

• Added Pref_SC3DResultsDest to specify Results Dest preference on the Interfaces tab of File,
Preferences.

• Added Pref_nastran_param_ogeom to specify Activate OGEOM Parameter preference on the
Interfaces tab of File, Preferences.

The following functions have been added or updated:

• feCheckCoincidentNode5

API
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8. What’s New - version 2021.2

User Interface

General

• Added an All Nodes on Solid option to the Method menu of the standard entity selection dialog box
when selecting elements. When used, any element which has all its nodes associated to the selected
solids will be selected.

• Updated selection of Aero Panel/Body, Aero Property, Aero Splines, and Aero Control Surface entities
to use the picking technology activated by the New Picking option on the Graphics tab of the File →
Preferences command, which takes advantage of OpenMP to improve performance.

Menu

• Added the Model → Simulation Entities → Design Equation command. See Simulation Entities for
more information.

• Added the Mesh → Bodies and the Mesh → Mesh on Mesh commands. See Meshing for more
information.

• Added the Delete → Model → Design Equation command. See Simulation Entities for more
information.

• Added the Group → Element → All Nodes on Solid command. See Groups and Layers for more
information.

Model Info tree

• Added Design Equation to the Simulation Entities branch which allows for management, editing,
listing, deleting, and renumbering of monitor points and matrix inputs, respectively. For monitor
points, the color and layer may also be changed.

Meshing Toolbox

• Geometry Editing tool - Added a Projection Mode drop-down when Operation is set to Point to
Edge. Choose from Normal, which performs a normal projection of the selected point to the selected
edge; Vector, which allows specification of a vector to project the selected point along to the selected
edge; or Interactive, which is has the user select a point, select an edge, then specify a vector to
project along.
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• Geometry Editing tool - Added a Projection Mode drop-down when Operation is set to Project
Curve. Choose from Normal, which performs a normal projection of the selected curve(s) onto the
selected surface(s) or Vector, which allows specification of a vector to project the selected curve(s)
along to the selected surface(s).

• Mesh Sizing tool - Added Set Size to the Operation section which allows the user to specify a Mesh
Size to define the number of elements on a curve. In addition, changed Set To in the Operation
section to Set Number which allows the user to specify Number of Elements on a curve.

Mesh Control Explorer

• Added Show Edges that are Adjacent to Surface with No Imprinted Edges and Show Surfaces
that Pierce Other Surfaces with No Imprinted Intersections tools to the Mesh Control Explorer.
Also, changed the position of the icons in the pane to group tools used to do similar operations
together.

Show Edges that are Adjacent to Surfaces with No Imprinted Edges

This tool is used to determine if edges of any number of surfaces are adjacent to the face of a surface,
but there is no imprinted edge where an edge(s) of the surface(s) meet the face of another surface
(T-Junctions) then lists them to the list area. When highlighting is enabled, which is the default, all
Surface Face-to-Surface Edge combinations which are found by the tool will also be highlighted in the
graphics window. For a single combination, this is listed as “Surface ID > [Surface Edge (Curve) ID]”. For
combinations where edges from multiple surface intersect a single surface, this is listed as “Surface ID >
[Surface Edge (Curve) ID A, Surface Edge (Curve) ID B, etc]”.

To potentially create imprinted edges on the surface using the surface edges, select a line in the list
area, then right-mouse click and choose the Imprint Edges from the context-sensitive menu. To attempt
to create imprinted edges on all of the Surface Face-to-Surface Edge combinations currently in the
list area, select any line from the list area, then right-mouse click and choose the Imprint Edges - All
command from the context-sensitive menu. In addition, if you would like to have the imprinted edges
always be extended to the extents of the surface in both directions, activate the Extend Imprints toggle
on the context-sensitive menu.

List simply lists the surface ID and all curve IDs on the selected line to the Messages window, while
Show All highlights found by the tool using the current options specified on the Show When Selected
icon menu.
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Show Surfaces that Pierce Other Surfaces with No Imprinted Intersection

This tool is used to determine if any number of surfaces pierce through another surface but there
are no imprinted curves at the location where the surfaces intersect., then lists them to the list area.
When highlighting is enabled, which is the default, all Surface(s) piercing another Surface without
Imprinted Intersection(s) combinations which are found by the tool will also be highlighted in the
graphics window. For a single combination, this is listed as “Surface being pierced ID > [Piercing Surface
ID]”. For combinations where multiple surfaces are piercing a single surface, this is listed as “Surface
being pierced ID > [Piercing Surface ID A, Piercing Surface ID B, etc}”.

To potentially create imprinted edges at the intersections of surface(s) which pierce each other, select
a line in the list area, then right-mouse click and choose the Imprint Intersections from the context-
sensitive menu. To attempt to create imprinted edges on all of the surfaces which pierce each other
currently in the list area, select any line from the list area, then right-mouse click and choose the Imprint
Intersections - All command from the context-sensitive menu. In addition, if you would like to have
the imprinted edges always be extended to the extents of the surface(s) in both directions, enable the
Extend Imprints toggle on the context-sensitive menu.

List simply lists the curve on the selected line to the Messages window, while Show All highlights all
of the curves found by the tool using the current options specified on the Show When Selected icon
menu.

Meshing

• Added the Body/on Mesh option to the Mesh → Geometry → Surface command. When selected,
surfaces are meshed with the same mesher used by the new Mesh → Bodies and Mesh → Mesh on
Mesh commands.

• Added the Mesh → Bodies command.

This command uses meshing methodologies which differ from those used by the Mesh → Geometry →
Surface and Mesh → Geometry → Solid commands in an attempt to create a higher quality mesh by
imposing fewer restrictions when meshing geometric surfaces (sheet solids), solids, and general bodies.
Can be used to create a 2-D surface mesh on a connected sheet solid (stitched body) or general body or
a 3-D solid tetrahedral mesh in a solid part.

Meshing
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Note:

This meshing technology has the ability to ignore internal curves and other mesh sizing specified
on geometry. In order to maintain mesh sizing specified on geometry, see the options in the
Geometry tab section below.

The geometric entities can be imported or built directly inside of Femap. When using this command
and only one sheet solid, general body, or solid exists in the model, Femap automatically selects that
geometric entity. If multiple sheet solids, general bodies, or solids exist, select any number of geometric
entities to mesh using the standard entity selection dialog box.

Note:

This command can also be used to mesh geometric entities which have any number of surfaces
defined using a faceted representation (convergent model) instead of a boundary representation
(B-rep) or contain a mixture of both. Geometric entities containing faceted surfaces cannot be
created within Femap, they can only be imported.

Once the geometric entities have been selected, the Automesh Bodies dialog box will be displayed:
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Femap will compute a Target Element Size to use for the selected geometric entities based upon the
average curve length of all curves on the selected geometric entities. This Target Element Size is used
in conjunction with the other parameters in the Mesh Sizing section, along with the settings on the
Geometry, Curvature/Proximity, and Mesh Quality tabs to create either a triangular or quadrilateral
surface mesh. When creating a tetrahedral mesh on solids, these parameters and settings are used in
the same manner to create a triangular surface mesh, which is then sent to the tetrahedral mesher
using options specified on the Tet Options tab to create the tetrahedral mesh.

If the tetrahedral mesher fails, Femap will ask “OK to Update Selector and Data Table with # nodes
causing errors?” If selected answer is Yes, the problem nodes will be sent to the selection list and Data
Table for easy identification using the Show When Selected tool in the Model Info tree and/or Data
Table.

Node and Element Options

Most of the node and element options are explained in Section 5.1.3.2, "Mesh, Geometry, Curve..."
in the Femap Commands guide, while other common features of this dialog box are explained in
Section 5.1.3, "Mesh, Geometry", also in the Femap Commands guide. When Mesh Type is set to Tri
or Quad, an existing property from the Plane Elements section of the Element/Property Type dialog

Meshing
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box, other than Axisymmetric Shell, must be selected from the Property drop-down or created
using the New Prop... icon button. When Mesh Type is set to Tet, an existing solid property must
be selected from the Property drop-down or new solid property created using the New Prop... icon
button. In addition, icon buttons to specify Node Parameters, Element Parameters, and Element
Formulation are also available (see Section 4.2.2, "Model, Element..." in the Femap Commands
guide for more information on element formulations).

Mesh Type

These options control what type of elements will be created. Each of these options are described
below.

Tri or Quad

The Tri option creates a surface mesh containing only triangular elements on surfaces of
selected geometric entities, while the Quad option creates a quadrilateral-dominant mesh on
surfaces of selected geometric entities.

Note:

The Quad option will attempt to create a quadrilateral-only surface mesh, but in complex
geometry it is quite possible that a limited number of triangular elements will also appear
in the mesh.

Tet

The Tet option creates a solid mesh containing only tetrahedral elements in the selected solids
with each solid being meshed individually.

Midside Nodes

When activated, midside nodes are added to the elements created by this command, thus
creating parabolic elements. For Tri and Quad, this option is deactivated by default, while for
Tet this option is activated by default.

Mesh Sizing

These options control the size of the elements being created. Each of these options are described
below.

Target Element Size

This value specifies the edge length that the mesher aims for in the absence of any mesh
refinement. The average length of all edges in the selected geometric entities is divided by 6 to
determine the default Target Element Size. Decreasing the target surface size generates more
refined and detailed surface mesh.

Points Around Circle

Specifies the number of triangles (edges/faces) used to define a 360 degree cylindrical surface.
Any other types of cylindrical surfaces use an equivalent number of triangles. For example, a
half circle uses half of this value and an ellipse would use more faces on tighter curvature.

Min Element Size Factor
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When any setting causes mesh refinement to occur, the element face edges do not go below
the specified value.

Growth Factor

This control determines the maximum rate at which face edge sizes vary from one face to its
neighbor. The effect is only seen when there is transition from an area of refinement to the rest
of the surface mesh. As an example, the default value of 50% means that a face edge can be 1.5
times its neighbor length when growing from a short to a long edge length. The recommended
range for Growth Factor is from 10% to 60%.

Geometry tab

These options control what type of elements will be created. Each of these options are described below.

Mesh Associativity

Three options are available for Mesh Associativity, each of which offers some benefits and
drawbacks.

All Geometry

Associates the mesh to geometry using all of the curves and surfaces of the selected
geometric body. Essentially, this option provides the same level of geometric associativity as
the commands on the Mesh → Geometry... menu, but in doing so will likely cause the mesher
to create a lower quality mesh compared to what it might have been able to do if the mesh
only needs to be associated to the Required Geometry, as the mesher does not have as much
freedom to improve mesh quality by ignoring internal curves and surface.

Required Geometry Only

Associates the mesh to only the geometry which is required to be associated, such as curves
and surfaces used to define geometry-based Loads, Constraints, and/or Regions. This is the
default option and offers the mesher the most freedom to ignore internal curves and surfaces,
which typically allows the mesher to create the highest quality mesh based on the Target
Element Size and other specified option.

Additional Selected Geometry

Uses the same approach as Required Geometry Only, but allows selection of any number of
curves and/or surfaces where mesh should also be associated to geometry. Additional curves
are selected by clicking the Curves icon button and additional surfaces by clicking the Surfaces
icon button.

Note:

How much the mesh quality is potentially diminished by using the Additional Selected
Geometry option depends on the location and number of additional curves and/or
surfaces selected.

When using either Required Geometry Only or Additional Selected Geometry, the
Additional Geometry by Angle option becomes available. When enabled, automatically adds

Meshing
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additional geometry to consider for mesh associativity based on a specified break angle. Default
value is 30 degrees.

Note:

To display which additional geometry will be considered using the specified angle, click
the Show When Selected icon button, which highlights the additional geometry in the
graphics window using the current settings for the Window → Show Entities command.
For more information, See Section 6.3.2.3, "Window, Show Entities..." in the Femap
Commands guide.

On Associated Geometry

When Use Curve Sizing is activated, any mesh size currently specified for a curve on a selected
geometric entity will be used during meshing. When Use Surface Sizing is specified, any mesh
size specified for a surface on a selected geometric entity will be used during meshing. When
deactivated, the mesh size on either type of entity is not considered by the mesher.

Curvature/Proximity tab

These options control settings to automatically refine mesh based on curvature and proximity. Each of
these options are described below.

Surface Curvature

When on, the Curvature Alignment option will attempt to create a mesh where face edges follow
the curvature of rounded features, such as fillets, essentially creating an aligned or mapped mesh.

The following conditions apply to the Curvature Alignment option:

• Aligned sections must have 4 sides and have geometric features as closed boundaries, for
example:

• There must be less than a 30% difference between the number of nodes created on opposing
sides of an aligned section.
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• The surface must have a relatively uniform surface mesh size. As a general guideline, the
minimum surface size (without aligned meshing) must be greater than half of the maximum
surface size.

• Aligned meshes cannot lie on a periodic interface boundary, or be connected to one along an
edge (in-place interfaces are supported).

• Aligned sections cannot contain inner loops, such as an inlet duct on a filleted edge.

When Curvature Refinement is activated, the Refinement Deviation Limit is used to calculate an
appropriate number of edges that are used around a complete circle. This means that the diameter
of a curve is accounted for in the mesh distribution. In addition, the Max Points Around Circle
option can be used to limit the maximum number of points around a complete circle, regardless of
the value specified for Refinement Deviation Limit.

Once the part has been properly subdivided, the Size on Solid command handles all sizing
automatically. Simply specify a nominal size. If further mesh grading is needed or to modify the
sizes that Size on Solid has created - great care must be used. If the mesh size along a curve is
changed manually, the mesh sizes must also be changed on all other curves in the solids needed
to maintain mapped meshable surfaces. If this is not done, Femap will not be able to hex mesh
the solids. While using this process, be sure to pick ALL of the required curves. In particular, at the
common boundaries between sliced solids, there will be duplicate curves - one on each solid. All of
these curves must get the same mesh size to maintain mesh connectivity from one solid to another.

Surface Curvature

When Proximity Refinement is activated, the Elements Across option determines the local face
size by dividing the distance from one face to another across a gap by this value. It is used in
conjunction with the Max Search Distance value, which specifies a Search Ceiling, and the setting
for Search Direction, which is the direction to search with respect to face normal direction.

Max Search Distance specifies the maximum distance that the mesher includes in surface
proximity, which prevents unwanted refinement. This property is useful if a component has a
variable thickness and you need an option to locally refine only those areas where the thickness is
less than a specified value. However, if the gap distance is more than the this value, there is no
refinement.

Search Direction can be set to Inside, which searches in the opposite direction of the face normal,
Outside, which search in the same direction of the face normal, or Both, which searches in both
directions.

Mesh/Quality tab

These options use element quality parameters to and more precise faceting to attempt to improve the
overal quality of the mesh. Each of these options are described below.

Mesh Quality

The Minimum Tri/Quad Quality option represents a value that ranges from 0.0 to 1.0, with 0.0
being the worst and 1.0 being perfect. The quality of a triangle is calculated as the ratio of the

Meshing
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triangle face area to the area of an equilateral triangle that would exactly fit inside the circumcircle
of the triangle, where the circumcircle is the circle which touches all three corner points of the
original face. In the diagram below, the Minimum Face Quality is defined as:

Minimum Face Quality = A/Aequil

This quality check ensures all the triangles in the resultant surface mesh have a quality equal to
or greater than the specified value. This minimum quality is achieved by allowing the mesher to
disregard feature edges, move feature vertices, or avoid projecting vertices if necessary. As a result,
the faces whose quality is below the specified value are removed or improved. Recommended
values are in the range 0.01 to 0.1 and values cannot exceed 1.0.

The Enhanced Quality Mesh option generates triangle surfaces of higher quality. When activated, it
provides the following advantages:

• Alignment with curvature and boundaries (feature edges, part boundaries). Enhanced quality
triangles are better at capturing the geometry and are closer overall to the input geometry.

Note:

Alignment is only feasible when sizes do not change on a surface. In cases where sizes do
change, the alignment must be sacrificed to allow for the change in mesh size.

• Allows you to better capture target sizes coming from inputs such as curvature size, surface
proximity and base sizes. However, the improved quality of the triangles increases mesh
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generation time. You are advised to only use this option as a local control for surfaces where
quality and alignment are most needed.

When activated, the Compatibility Refinement option imposes a surface growth rate of 2 to limit
the difference in face sizes across a gap. Therefore, if the gap between faces is small, the relative
size of faces on either side of the gap is close to one another. This option improves volume mesh
quality, as face sizes on opposing sides are similar without explicitly stating a size.

Note:

This option is similar to Proximity Refinement, but Proximity Refinement specifies a mesh
size that is based on the gap size and number of points inside the gap. Compatibility
Refinement ensures that the mesh size on either side of the gap is similar. In some cases,
this results in fewer elements.

Faceting Tolerances

The values in this section are used to create a faceted representation of the selected geometric
entities. The facets are passed to the mesher one geometric entity at a time and used to create
either a triangular or quadrilateral-dominant surface mesh.

Max Facet Size facets the geometry using the specified value as a percentage of Target Element
Size (i.e., value of 50 uses 0.5*Target Element Size for faceting). Distance Error specifies the max
distance from an element to a facet as a percentage of Target Element Size.

Angle Error is a measure of the angle between the tangent of each facet at the point it touches the
edge of the solid and the chord of each facet. Chord Error is a measure of the length of the chord
of each facet to the distance it is away from the edge of the solid at the middle of the chord. Curve
Factor is used to improve the curve accuracy of attached curves to the surfaces. Essentially, Femap
takes the values specified for solid faceting and changes the curve accuracy to be the Curve Factor
value times more accurate.

When Use Faceter is activated, the current facets used to display the model in the graphics window
are used by the mesher. When deactivated, the body is converted to a faceted body by a Parasolid
command and those facets are used by the mesher.

Note:

If the mesher does not work as expected with Use Faceter activated, deactivate option and try
again. A different batch of triangles are created which may allow the mesher to work

Tet Options tab

These options are used to specify options which control the creation of tetrahedral elements.

Meshing
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Tet Sliver Removal

When enabled, which is the default, attempts to remove tetrahedral elements considered ‘slivers’
near the boundary. A sliver is defined as a tetrahedral with at least one angle less than 5 degrees. In
most cases this will improve mesh quality and should only be disabled if there is a problem.

Allow Void Regions

Allows meshing solids which have internal voids.

Multiple Tet thru Thickness

When activated, the tetrahedral mesher will attempt to place the specified number of elements
through the thickness, from 2 to 10, throughout the model.

Tet Optimization

Sets an optimization level (mesh quality vs. speed) for the tetrahedral mesher. Using a higher value
does not guarantee improved mesh quality. 3..Default is the best compromise between speed and
quality, while choosing 0..None will simply not use any optimization. Setting to 1..Minimal will
potentially create a lower quality mesh in less time, while 5..Maximum will potentially create a
higher quality mesh, but take longer.

Tet Growth Ratio

The Tet Growth Ratio can modify the size of the tetrahedral elements based upon the size of
elements in the surface mesh. If the Tet Growth Ratio value is set to 1, the size of tetrahedral
elements formed will be approximately the same as the surface mesh elements. If this value is
set below 1 (minimum of 0.5), the length of the tetrahedral elements formed by the solid mesher
will be smaller than the surface mesh elements. If this value is above 1 (maximum of 100), the
tetrahedral elements will be larger than the surface elements. If the desired tetrahedral elements
need to be larger or smaller than this ratio will allow, remesh the surfaces of the solid with a finer or
coarser mesh.

Mesh on Mesh

• Added the Mesh → Mesh on Mesh command.

...uses meshing methodologies as the Mesh → Bodies command (see Section 5.1.4, "Mesh, Bodies" in
the Femap Commands guide), only it uses existing triangular or quadrilateral elements as the starting
point instead of geometric entities. This is made possible by sending the facets used to display the
elements in the graphics window into the mesher, which then creates a triangular or quadrilateral-
dominant mesh based on those facets.

One other difference is this command cannot be used to create Tetrahedral elements, therefore the Tet
option in the Mesh Type section is not available and either is the Tet Options tab.

The elements can be imported or built directly inside of Femap. Once the elements exist in Femap, they
are selected using the standard entity selection dialog box
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Note:

It may be helpful to use the By Faces option on the Pick^ menu of the standard entity selection
dialog box to select sections of shell elements.

Once the geometric entities have been selected, the Automesh Bodies dialog box will be displayed:

Femap will compute a Target Element Size to use for the selected elements based upon the average
edge length of the selected elements. This Target Element Size is used in conjunction with the other
parameters in the Mesh Sizing section, along with the settings on the Mesh Features, Curvature/
Proximity, and Mesh Quality tabs to create either a triangular or quadrilateral-dominant mesh which
will replace an existing mesh.

Node and Element Options

Meshing
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Most of the node and element options are explained in Section 5.1.3.2, "Mesh, Geometry, Curve..."
in the Femap Commands guide, while other common features of this dialog box are explained in
Section 5.1.3, "Mesh, Geometry", also in the Femap Commands guide.

When Mesh Type is set to Tri or Quad, the original property of each element will be retained by
default. To select a different property from the Property drop-down to use for the newly created
elements, the Property option in the Element Attributes to Retain section of the Mesh Features
tab must be deactivated. Once deactivated, an existing property from the Plane Elements section
of Element/Property Type dialog box, other than Axisymmetric Shell, may be selected from the
Property drop-down or created using the New Prop... icon button.

Mesh Features tab

These options control which element attributes will be retained along with some additional options.

Mesh Attributes to Retain

This section contains a number of options which control which element attributes will be
retained once the current elements have been replaced with the new elements created by the
command.

Property

When activated, the property of the original element is retained.

Element Type

When activated, the element type of the original element is retained and only elements
which were originally an element type which matches the property type of the selected
property will be remeshed.

Corner Thickness

When activated, the corner thickness values specified for each original element will be
retained.

Offset

When activated, the element offset value for each original element will be retained.

Normal Direction

When activated, the normal direction of each original element will be retained.

Color

When activated, the element color of each original element will be retained.

Layer

When activated, the layer of each original element will be retained.

Associativity

When activated, the geometry associativity for each original element will be retained.

Feature Control

When selecting elements for this command, it may be easier to select elements which span
multiple mesh regions that are adjacent to one another. Mesh regions can be automatically
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determined using an angle, specified in degrees, for Edge Break. Femap calculates the normal
to the planar face for each element. If the normals of two adjacent elements are within the
angle that you specify of being parallel, they will be considered to be in the same segment. If
they are not within that angle, multiple segments will be formed.

When the Keep Mesh on Free Edges option is activated, the nodes which lie on free edges
of the selected elements will be retained. Otherwise, the mesh along the free edges can be
modified by the mesher.

Connectivity

When the Merge Nodes option is activated, any new nodes created by the command will be
merged with other new nodes and existing nodes when the nodes fall within the default Merge
Tolerance. For more information about the default Merge Tolerance, see Section 7.4.1, "Tools,
Parameters..." in the Femap Commands guide.

Elements

• Added ability to create a CBUSH1D element for Nastran solvers by using a Spring/Damper element
which references a Spring/Damper property with the CBUSH1D option selected or by using a Spring/
Damper to Ground element which references a Spring/Damper to Ground property with the CBUSH1D
option selected.

Properties

• Added a CBUSH1D option to both the Spring/Damper property and the Spring Damper to Ground
property types. When a Spring/Damper element or Spring/Damper to Ground element references a
property which is set to CBUSH1D, a CBUSH1D and corresponding PBUSH1D will be written to the
Nastran input file. In addition, the Nonlinear/Freq Resp... button can be used to access the Define
Nonlinear 1D Spring/Damper dialog box to choose Functions or Design Equations to control Spring,
Damper, Shock Absorber, and/or Generalized Spring/Damper behavior on the PBUSH1D entry.

Simulation Entities

• Added the Model → Simulation Entities → Design Equation command, which opens the NASTRAN
Design Equation Manager to manage design equation entities in a model.

Elements
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This manager is used to create Design Equation entities (DEQATNs) for Nastran solvers.

This manager can be used to create a New Equation; Edit Selected (equations), Delete, Copy, or
Renumber Design Equation(s) currently highlighted in the Available Design Equation(s) list; or Delete
All the Design Equations currently in the model.

Clicking the New Equation button opens the NASTRAN Design Equation dialog box:
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Specify an ID and Title, then enter the text of the Design Equation (i.e., the text formatted exactly as it
should appear in the EQUATION field of the DEQATN entry) into the Source Data section. To delete all of
the text currently in the Source Data section, us the Delete All button.

Note:

When Design Equations are imported into Femap from DEQATN entries in a Nastran input file, the
exact format of the text from the EQUATION field of the DEQATN entry is maintained in the Source
Data section.

In Femap, there is currently only one use for Design Equations, which is to allow selection of a Design
Equation using drop-downs in various sections of the Define Nonlinear 1D Spring/Damper when that
section is set to Equation. For more information, see "Spring/Damper Element Properties" in Section
4.2.2.1, "Line Elements" in the Femap Commands guide.

Groups and Layers

• Added the Group → Element → All Nodes on Solid command which places any element which has
all its nodes associated to the selected solids in a group.

Output and Post-Processing

• Updated the View → Advanced Post → Stress Linearization command to copy the underlying
transformed stresses to the clipboard instead of the regular output report by holding down the Shift
key when pressing the Copy to Clipboard button.

Geometry Interfaces

The following Femap interfaces have been updated to support newer geometry formats:

Femap Interface Latest Supported Version

Parasolid 33.1

NX version 1953

ACIS 2020.1.0 1.0.1

Creo (Pro/Engineer) Creo 7

SolidWorks 2021

• Added ability to import Parasolid files with solids, sheet solids, and/or general bodies which have
any number of surfaces using a faceted representation (convergent modeling) instead of a boundary
representation (b-rep).

For details, see Section 9, “Geometry Interfaces” in the Femap User Guide.

Groups and Layers
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Analysis Program Interfaces

Several of the analysis program interfaces have been improved. These changes include:

• Femap Neutral File Interface

• Simcenter Nastran Interface

• Nastran Interfaces (Simcenter and MSC/MD)

• LS-Dyna Interface

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

Femap Neutral File Interface

• Updated Neutral Read and Write for v2021.1 changes.

Simcenter Nastran Interface

• Added support to specify a Connection Property when the Gaps as Contact option is enabled for SOL
101.

SOL 401/402

• Added support for reading and writing the MPLAS entry used by SOL 401 and SOL 402.

A number of bugs were corrected.

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

Nastran Interfaces (Simcenter and MSC/MD)

• Added support for defining dynamic subcases for 3..Transient Dynamic/Time History, 4..Frequency/
Har-monic Response, and 12..Nonlinear Transient Response analysis types. In addition, a static
subcase can now be created for 3..Transient Dynamic/Time History and 4..Frequency/Harmonic
Response for the purpose of accounting for differential stiffness using a STATSUB entry.

• Added support to read and write the CBUSH1D element type and corresponding PBUSH1D property
type entries. In addition, general nonlinear behavior can be defined with Functions or Design
Equations.

• Added support to read and write the DEQATN entry by using a Design Equation Simulation Entity. In
addition, general nonlinear behavior can be defined with Functions or Design Equations.
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• Updated the default value of the PRGPST option in the NASTRAN Bulk Data Options dialog box to off.

A number of bugs were corrected.

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

LS-Dyna Interface

• Added support for element formulation EQ18 and EQ-18 for solid elements as well as element
formulation EQ16 for shell elements.

A number of bugs were corrected.

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

Tools

• Updated the Tools → Check → Mesh Interference command to have selected Plot Only plates
elements be treated as having zero thickness, removing numerical roundoff and false positive mesh
interferences.

JT Files

• Added the ability to output the active, visible, selected, or all load sets and/or constraint sets to a
JT file when Type is set to Standard Output in the JT File Options dialog box. In addition, element
symbols can now be output to a JT file.

• Added a Multi Result Output option to the JT File Options dialog box which allows for the selection
of any number of output vectors in any number of output sets to be output to a JT file either as
Raw Output Data or as Collated Vectors and Tensors with options to use averaging, transformation,
and/or include corner data.

OLE/COM API

New and modified API Objects and Attributes

• Added a BodyMesher (feBodyMesher) object to the API.

Added MeshType, MidsideNodes, TargetSize, MinSizeFactorOn, MinSizeFactor, PointsAroundCircleOn,
PointsA-roundCircle, GrowthFactorOn, and GrowthFactor attributes to control Mesh Sizing options for
the Mesh → Bodies and Mesh → Mesh on Mesh commands when using the BodyMesher Object.

Added AssociateTo, AssociateAngleOn, AssociateAngle, UseCurveSizing, and UseSurfaceSizing attributes
to control options on the Geometry tab of the Mesh → Bodies command when using the BodyMesher
Object.

LS-Dyna Interface
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Added RetainProperty, RetainElemType, RetainCornerThickness, RetainOffset, RetainNormalDirection,
Retain-Color, RetainLayer, RetainAssociativity, FeatureEdgeBreakAngle, KeepMeshOnFreeEdges, and
MergeNodes attributes to control options on the Mesh Features tab of the Mesh → Mesh on Mesh
command when using the Body-Mesher Object.

Added CurvatureAlignment, CurvatureRefinement, CurvatureRefinementMaxPoints,
CurvatureRefinementLimit, ProximityRefinement, ProximityElemAcrossOn, ProximityElemAcross,
ProximityDistanceOn, ProximityDis-tance, ProximityDirection attributes to control options on the
Curvature/Proximity tab of the Mesh → Bodies and Mesh → Mesh on Mesh commands when using
the BodyMesher Object.

Added MinQualityOn, MinQuality, EnhancedQualityMesh, CompatibilityRefinement, FacetMaxSize,
FacetDistanceError, FacetAngleError, FacetChordError, FacetCurveFactor, and UseFaceter attributes to
control options on the Mesh Quality tab of the Mesh → Bodies and Mesh → Mesh on Mesh
commands when using the BodyMesher Object.

Added TetSliverRemoval, TetAllowVoids, TetMultipleThruThicknessOn, TetMultipleThruThickness,
TetOptimizationLevel, and TetGrowthRatio attributes to control options on the Tet Options tab of the
Mesh → Bodies command when using the BodyMesher Object.

New and Updated API Methods

• Added Clear, Dialog, Size, UseSizing, Associate, MeshBodies, MeshOnMesh,
CalculateDefaultMeshSize, Set-SizeOnCurves, and SetSizeOnSurfaces methods to the BodyMesher
Object.

• Added NodesAsSet method to the BCSet Object.

• Added NodesAsSet and ElementsAsSet methods to the ConnectionRegion Object.

• Added IsFacet method to the Curve Object.

• Added NodesAsSet and ElementsAsSet methods to the LoadSet Object.

• Added IsFacet and IsAllFacet methods to the Solid Object.

• Added IsFacet method to the Surface Object.

The following functions have been added or updated:

• feFilePictureSaveJT

• feFilePictureSaveJTMultiResults

• feAppAllowUVSurfaceForMeshFaces
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9. What’s New - version 2021.1 MP 1
Analysis Program Interfaces

Several of the analysis program interfaces have been improved. These changes include:

• Simcenter Nastran Interface

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

Simcenter Nastran Interface

SOL 401/402

Added support to write the CRSTRN case control entry to the input file if either the Total Strain or
Elastic Strain output request is activated in the NASTRAN Output Requests dialog box.
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10. What’s New - Version 2021.1

User Interface

General

• Added functionality to hide the list of entity ranges in the standard selection dialog box to improve
performance when more than 1000 unique ID ranges have been selected.

Once more then 1000 “unique ID ranges” are selected, the list of selected entities is replaced by text
stating (number of unique ranges) Ranges Selected and Show List>>>:

To display the entire list of ranges, click anywhere in the list area. To hide the list again, click the Hide
List button which appears to the left of the list area.

• Added the Match Color button menu to the Color Palette, which selects a color by matching the color
of an existing entity.

• Improved handling of repeated error messages to catch cases where multiple errors were repeated in
a pattern. This can dramatically improve import times of invalid or incomplete Nastran models.

• Enhanced performance of picking, especially front picking (up to 15 times faster) and area picking (up
to 10 times faster), when using the New Picking option on the Graphics tab in the Preferences dialog
box. New Picking also takes advantage of OpenMP technology.

Menu

• Added the Tools → Other Windows → Mesh Control Explorer command. See Mesh Control
Explorer - New for 2021.1 for more information.

Meshing Toolbox

• Added an icon to open the Mesh Control Explorer dockable pane from within the Meshing Toolbox.
For more information, see Mesh Control Explorer - New for 2021.1.
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Function/Table Editor

• Added the Connect To Excel command which is only available after the Send To Excel command on
the Copy to Clipboard menu has been used to send data to Excel. Connect to Excel opens the Excel
Connection dialog box. When the Live option is activated, any additions and modifications done in
Excel are automatically reflected in the Function/Table Editor. If the Live option is deactivated, then
additions and modifications can be committed to the Function/Table Editor by using the Update
button.

Mesh Control Explorer - New for 2021.1

Added the Mesh Control Explorer to perform a number of different tasks, including specification
of options for mesh propagation, visualization of slaved surfaces for solid meshing and/or mesh
approaches on surfaces, and determining if curves are paired by a mesh approach and/or can be
automatically paired based on proximity when mesh sizing.

The Mesh Control Explorer pane contains a number of icons and a section used to list the results of the
various exploration tools:

Mesh Control Explorer Icons

The icons are split into five sections. The first section is used to specify options for automatic mesh
propagation.

The second section contains tools which are used to visualize how surfaces of different solids are linked
to one another for solid meshing or determine which surfaces have a mesh approach currently assigned.

The third section contains tools to visualize curves on geometric entities which are already automatically
paired and/or can be when using the mesh propagation options; adjacent to one another, but require
additional modification, such as being split at various locations, to allow automatic pairing; or not
adjacent to any other curves, therefore not eligible for automatic pairing unless existing geometry is
moved or new geometry is created.
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The fourth section contains a single icon to clear the list area, while the fifth section contains one
command which locates the line in the list area containing the curve or surface selected from the
graphics window and another which controls how curves or surfaces currently highlighted in the list
area are highlighted in the graphics window.

Mesh Sizing Propagation Toggle

When activated, uses options in the Mesh Sizing Propagation Options dialog box to set up mesh
sizing on curves to facilitate mesh propagation from geometric entity-to-geometric entity. To access
the Mesh Sizing Propagation Options dialog box via the Mesh Control Explorer, click the Mesh
Control Explorer Options icon. When deactivated, the options in the Mesh Sizing Propagation
Options dialog box are ignored.

Mesh Control Explorer Options

Opens the Mesh Sizing Propagation Options dialog box. For more information, see Meshing.

Show Slaved Surfaces

This tool is used to visualize how surfaces of solids are linked to one another using the “Matched -
Link to Surface” Mesh Approach. When a surface is “linked” to another surface, the Slave surface
is given an identical mesh to the master surface, which allows either the hex mesher or tetrahedral
mesher to create a single connected mesh across multiple solids.

When this tool is used, a list of all surfaces which are linked using “Matched - Link to Surface” Mesh
Approach will always be sent to the list area. In addition, when highlighting is enabled, which
is the default, all surfaces which have the mesh approach defined or are referenced will also be
highlighted in the graphics window. Each master will appear “filled”, while each Slave will appear
“outlined”. Once the list area is populated, any single line can be selected, which highlights only the
surfaces on that line in the graphics area.

Each line in the list area can contain any combination of Surface IDs and symbols, with the location
of the Surface ID and type of symbol holding particular significance. In all cases, the surface ID to
the left of the symbol is the master, while the surface ID to the right of the symbol is the Slave.

If a “<“ symbol is between two Surface IDs, this indicates the surfaces reside on the same solid. In
general, this indicates the solid has been sized for hex meshing and the hex mesh will start at the
master and continue to the Slave surface, following all the curves found on the solid between the
two surfaces.

If a “<<“ symbol is between two Surface IDs, this indicates the surfaces reside on different solids. In
general, these surfaces have been linked specifically so the Slave surface will be meshed identically
to the master, which allows for the mesh on both solids to be connected at that interface (i.e.,
share nodes at that surface). In Femap, this type of linking is often referred to as adjacent surface
matching.

It is quite common for a surface to be the master or Slave for hex meshing purposes on a particular
solid, but then be the opposite when setting up adjacent surface matching. For instance, surfaces A,
B, C, and D all appear on a single line in the list area as “A<<B<C<<D”. This means:

Mesh Control Explorer - New for 2021.1
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• A is any surface on “Solid 1” (could potentially be matched to another surface for hex meshing
purposes)

• B and C are both on “Solid 2”, where B is the “master” and C is the “slave” for hex meshing
purposes.

• D is any surface on “Solid 3” (could potentially be matched to another surface for hex meshing
purposes).

• In the connection between “Solid 1” and “Solid 2”, A is the “master” and B is the “slave”.

• In the connection between “Solid 2 and “Solid 3”, C is the “master” and D is the “slave”.

Right mouse-clicking on any selected line in the list area will display a context-sensitive menu
containing four commands.

Reverse reverses the master-Slave relationships for all surfaces on the selected line. If all
relationships cannot be reversed, an error stating “Unable to Reverse. Multiple Surfaces are Slaved
to Surface (ID).” will be displayed.

Approach on Master will display the Surface Mesh Approach dialog box, allowing the definition of
a meshing approach on the master. For more information on the available mesh approaches, see
Section 5.1.2.15, "Mesh, Mesh Control, Approach On Surface" in the Femap Commands guide.

List simply lists all the surfaces on the selected line to the Messages window, while Show All
highlights all of the surfaces found by the tool using the current options specified on the Show
When Selected icon menu. These commands are also found on the context-sensitive menu for
every tool in the Mesh Control Explorer which has a con-text-sensitive menu, only they list or
highlight all of the found curves instead surfaces.

For example, the geometry below is sized for hex meshing. The surface IDs on each line in the
list area of the Mesh Control Explorer each represent any number of pairs of surfaces which are
“linked” using the “Matched - Link to Surface” Mesh Approach. In addition, those surfaces are all
simultaneously highlighted in the graphics window.
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Show Mesh Approaches

This tool determines which surfaces have a mesh approach assigned (other than Matched - Linked to
Surface).

When this tool is used, a list of all surfaces which have a mesh approach assigned will always be sent to
the list area. In addition, when highlighting is enabled, which is the default, all surfaces which have a
mesh approach assigned will also be highlighted in the graphics window. Once the list area is populated,
any single line can be selected, which highlights only the surface on that line in the graphics area.

Right mouse-clicking on any selected line in the list area will display a context-sensitive menu containing
three commands.

Approach displays the Surface Mesh Approach dialog box, which can be used to review or edit the mesh
approach currently assigned to the surface. For more information on the available mesh approaches, see
Section 5.1.2.15, "Mesh, Mesh Control, Approach On Surface" in the Femap Commands guide.

List simply lists all the surfaces on the selected line to the Messages window, while Show All highlights
all of the surfaces found by the tool using the current options specified on the Show When Selected
icon menu.

Show Paired Edges

This tool is used to determine which curves have been “paired” in some way due to mesh approach
and/or can be automatically “paired” when Mesh Sizing Propagation is activated because the curves
are coincident and share end points, then lists them to the list area. When Highlighting is activated,
which is the default, all curves which are paired will also be highlighted in the graphics window. When
a solid is sized for hex meshing, the curves which extend from the master surface to the Slave surface
are “paired” because all of them need to have the same mesh size in order for mesh properly extrude,
revolve, and/or sweep through the solid to create “layers” of solid hex (brick) or wedge elements.

When “paired”, curve IDs will be listed between brackets, separated by commas. For example:

• Two paired curves, “A” and “B”, are on two different solids, sheet solids, and/or general bodies, this
listing is “[Curve A ID] , [Curve B ID]”

• Four paired curves, “A”,“B”, “C”, and “D”, are on the same solid the listing is “[Curve A ID, Curve B ID,
Curve C ID, Curve D ID]”.

• Two paired curves, “A” and “B”, are on “Solid 1”, while two paired curves, “C” and “D”, are on “Solid 2”.
If properly set up for solid meshing (i.e., curves “B” and “C” are on surfaces which have a “Matched -
Linked to Surface” mesh approach defined), the listing is “[Curve A ID, Curve B ID] , [Curve C ID, Curve
D ID]”.

Mesh Control Explorer - New for 2021.1
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Right-mouse clicking on any selected line in the list area displays a context-sensitive menu. Use List to
simply lists all the curves on the selected line to the Messages window, while Show All highlights all
of the curves found by the tool using the current options specified on the Show When Selected icon
menu.

Show Unpaired Free Edges that are Not Adjacent to Other Edges

This tool is used to visualize curves which are not coincident to other curves and also do not share
any end points. Many times this tool will simply highlight geometric free edges in the model. When
highlighting is activated, which is the default, all curves which are found by the tool will also be
highlighted in the graphics window. Curves found by this tool are always listed individually.

List simply lists the curve on the selected line to the Messages window, while Show All highlights all
of the curves found by the tool using the current options specified on the Show When Selected icon
menu.

Show Unpaired Free Edges that are Adjacent to Other Edges

This tool is used to determine curves which are partially coincident to other curves, but do not share
any end points, then lists them to the list area. When highlighting is activated, which is the default, all
curves which are found by the tool will also be highlighted in the graphics window. These curves are
listed as “[Curve A ID] , [Curve B ID]”.

To potentially create shared end points on a particular set of unpaired curves, select a line in the list
area, then right-mouse click and choose the Imprint Points command from the context-sensitive menu.
To attempt to create shared end points on all of the unpaired curves currently in the list area, select any
line from the list area, then right-mouse click and choose the Imprint Points - All command from the
context-sensitive menu.

List simply lists the curve on the selected line to the Messages window, while Show All highlights all
of the curves found by the tool using the current options specified on the Show When Selected icon
menu.

Show Edges that are Adjacent to Surfaces with No Imprinted Edges

This tool is used to determine if edges of any number of surfaces are adjacent to the face of a surface,
but there is no imprinted edge where an edge(s) of the surface(s) meet the face of another surface
(T-Junctions) then lists them to the list area. When highlighting is enabled, which is the default, all
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Surface Face-to-Surface Edge combinations which are found by the tool will also be highlighted in the
graphics window. For a single combination, this is listed as “Surface ID > [Surface Edge (Curve) ID]”. For
combinations where edges from multiple surface intersect a single surface, this is listed as “Surface ID >
[Surface Edge (Curve) ID A, Surface Edge (Curve) ID B, etc]”.

To potentially create imprinted edges on the surface using the surface edges, select a line in the list
area, then right-mouse click and choose the Imprint Edges from the context-sensitive menu. To attempt
to create imprinted edges on all of the Surface Face-to-Surface Edge combinations currently in the
list area, select any line from the list area, then right-mouse click and choose the Imprint Edges - All
command from the context-sensitive menu. In addition, if you would like to have the imprinted edges
always be extended to the extents of the surface in both directions, activate the Extend Imprints toggle
on the context-sensitive menu.

List simply lists the surface ID and all curve IDs on the selected line to the Messages window, while
Show All highlights found by the tool using the current options specified on the Show When Selected
icon menu.

Show Surfaces that Pierce Other Surfaces with No Imprinted Intersection

This tool is used to determine if any number of surfaces pierce through another surface but there
are no imprinted curves at the location where the surfaces intersect., then lists them to the list area.
When highlighting is enabled, which is the default, all Surface(s) piercing another Surface without
Imprinted Intersection(s) combinations which are found by the tool will also be highlighted in the
graphics window. For a single combination, this is listed as “Surface being pierced ID > [Piercing Surface
ID]”. For combinations where multiple surfaces are piercing a single surface, this is listed as “Surface
being pierced ID > [Piercing Surface ID A, Piercing Surface ID B, etc}”.

To potentially create imprinted edges at the intersections of surface(s) which pierce each other, select
a line in the list area, then right-mouse click and choose the Imprint Intersections from the context-
sensitive menu. To attempt to create imprinted edges on all of the surfaces which pierce each other
currently in the list area, select any line from the list area, then right-mouse click and choose the Imprint
Intersections - All command from the context-sensitive menu. In addition, if you would like to have
the imprinted edges always be extended to the extents of the surface(s) in both directions, enable the
Extend Imprints toggle on the context-sensitive menu.

Mesh Control Explorer - New for 2021.1
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List simply lists the curve on the selected line to the Messages window, while Show All highlights all
of the curves found by the tool using the current options specified on the Show When Selected icon
menu.

Clear List

This icon is used to clear all lines of curve IDs or surface IDs from the list area.

Locate in List

This icon is only available when the list area is populated with curve or surface IDs by one of the tools.
When curve IDs are listed, this icon allows selection of a curve from the graphics window, then locates
and highlights the curve in the list area. When surface IDs are listed, this icon locates and highlights the
selected surface in this list area.

Show When Selected menu

Contains a number of options to show the entities currently highlighted in the Mesh Control Explorer
in the main graphics window. Only Curves and Surfaces can be “shown” and which type of entity being
shown depends on which tool was used to populate the list in the Mesh Control Explorer. By default,
this command is enabled. The commands on this menu use the various options of the Window → Show
Entities command (see Section 6.3.2.3, "Window, Show Entities..." in the Femap Commands guide).
Once the options have been selected, simply clicking the Show When Selected icon will enable/disable
the highlighting.

When highlighting is enabled, all entities which are listed to the Mesh Control Explorer by tool will be
highlighted in the graphics window. If a single line is then highlighted, only the entities on that line will
be highlighted.

Setting the menu to Highlight highlights the entities in the graphics window. Transparent Highlight
does the same thing as Highlight, but will make all non-selected entities temporarily transparent as
well.

Note:

The level of transparency used in the Transparent Highlight option can be adjusted using a global
value for all entities using View → Options; Category: Tools and View Style; Transparency
option.

Setting the menu to Show Selected Only will cause all entities NOT associated with the selected entities
in the Mesh Control Explorer to temporarily disappear until Show When Selected is toggled off or
the model is regenerated. The Autoscale to Show Entities, Show Labels, and Show Normals (shows
element normals) options can be toggled and the highlight color can also be chosen from the Femap
color palette using the Highlight Color... command.
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Geometry

• Added an Overlap Repair option to the Automatic Midsurface Generation dialog boxwhich is
accessed by the Geometry → Midsurface → Automatic command.

When activated, Overlap Repair attempts to automatically remove overlapping midsurfaces caused
by offsets in the original solid geometry, thereby resulting in fewer newly created midsurfaces and/or
midsurfaces which do not overlap. This option may be useful when creating midsurfaces in cases
where multiple internal ribs approach an “intersection” or “near intersection” from various directions
and/or the ribs on “opposite sides” of the “intersection” are otherwise not aligned with one another.

• Added Enhanced Geometry → Curve - Centerline to better handle more complex beam-like solids,
including helical and swept shapes created from complex splines.

Meshing

• Added a Size Propagation section to the dialog box for the Mesh → Mesh Control → Size on Curve;
Mesh → Mesh Control → Size on Surface; and Mesh → Mesh Control → Size on Solid commands.
In each command, there is a Propagate Sizing option and an icon button which accesses the Mesh
Sizing Propagation Options dialog box. The Propagate Sizing option can also be activated and the
other options specified via the Mesh Control Explorer dockable pane, which was added for 2021.1.

Opens the Mesh Sizing Propagation Options dialog box:

Geometry
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This dialog box is broken into four sections, each controlling a different aspect of mesh sizing
propagation.

Limit Selection

Controls which solids/surfaces are considered when mesh sizes are updated. Choose All Solids/
Surfaces, Meshed Solids/Surfaces Only, or Selected Solids Only. When using Selected Solid
Only, click the Select Solids button to select solids, sheet solids, and general bodies using the
standard entity selection dialog box.

On Solids

If Slaved and Mapped Surfaces is activated, then slaved surfaces with mapped mesh approaches
are con-sidered when determining which edges to update, otherwise they are not considered.

Edges to Pair

These options will automatically find neighboring edges of unstitched geometric entities (i.e.,
individual surfaces, sheet solids, and/or non-enclosed volume portions of general bodies) and
attempt to match mesh sizes across the multiple coincident edges.

Note:

To be identified and linked by any option in this section, edges must have coincident
endpoints.

Off
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No edges are paired in this manner.

Free Surface Edges Only

Only edges that are used by one surface will be considered. This is the default, however it will
not identify certain types of geometry, such as T-junctions, where one of the edges is an internal
edge of sheet solid or general body (i.e., surfaces which have been stitched or non-manifold
added together). On the other hand, it will identify T-junctions where all curves that meet at the
junction belong to individual surfaces.

Free Surface Edges and Other Edges

Similar to Free Surface Edges Only, but also considers internal edges of any sheet solid or
general body.

All Edges

Simply checks all geometric edges. This method will have the slowest performance, but also
considers edges of regular (non-sheet) solids, which allows it to identify junctions between solids
and sheet solids.

Note:

If Include Edges on Same Solid is deactivated, which is the default, edges are never
checked for pairing with other edges of the same sheet solid, solid, or general body. For
instance, if there is a sheet solid that wraps around to form a closed cylinder, the edges
would never be linked unless this option is activated.

Edge Pairing Tolerance

This is the tolerance used to automatically pair coincident edges. Automatic uses the default
node merge tolerance, while Specified uses value provided by the user.

Note:

Femap determines the default node merge tolerance based on overall model size. The
number is 1/10000 of the model box diagonal (think of the model box being an invisible
box that completely encapsulates every entity in the model).

• Added a Detect Surface Poles option to Mapped approaches in the Surface Mesh Approach dialog
box. When activated, the location of surface poles will be detected and the selected points may be
reordered to create a higher-quality mesh. When deactivated, the points are always used as entered.

Materials

• Added option 607..MSC.Nastran Cohesive Material (MCOHE SOL400) to Other Types to support
the MCOHE entry for MSC Nastran SOL 400.

• Added option 608..MSC.Nastran Gasket Material (MATG SOL400, SOL 600) to Other Types to
support the MATG entry for MSC Nastran SOL 400 and SOL 600.

Materials
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Properties

• Added a Define Property Extensions icon button to the Define Property dialog boxes for a number of
different property types. When clicked, the Property Extensions dialog box is displayed, which allows
specification of solver-specific items for the current property type. The options available change
from property type-to-property type. The Filter icon button can be used to limit the tabs which are
displayed in the Property Extensions dialog box.

Options available for Integration Type are “0..Default”, “1..Gauss”, or “2..Newton-Coates”. Options
available for Output Type are “0..Default”, “1..Corner Nodes”, or “2..Gauss Points”. Options available
for Matrix Scheme are “0..Default”, “1..Secant-Type Matrix”, or “2..Tangent-Type Matrix”.

Property Extensions - Rod

MSC Nastran tab - These options are only used for SOL 400 and written to a PRODN1 entry. When
Large Strain is activated, an existing material may then be selected from the Material drop-down in the
Overrides section.

Property Extensions - Bar and Beam

MSC Nastran tab - These options are only used for SOL 400 and written to a PBARN1 entry for
a bar or a PBEMN1 entry for a beam. When Large Strain is activated, the options for Integration
Type are 0..Default, 1..Linear/Cubic, 2..Linear/Cubic Closed Section, 3..Linear/Cubic Open Section,
or 4..Linear-shear, while the options for Section are 0..Default, 1..Smeared Cross-Section, or
2..Numerically Integrated Cross Section. In addition, an existing material may then be selected from
the Material drop-down in the Overrides section.

Property Extensions - Membrane, Bending Only, and Plate

Autodesk Nastran tab - For plate properties, the General section can be used to specify which element
stress Component Direction will be used to determine element failure and maximum Compression
Allowable.

The Shell Type After Reversion drop-down specifies the type of element being created, 1..Tension
Only or 2..Shear Panel.

When set to 1..Tension Only the values defined for X Compression Factor and Y Compression Factor
are used to determine the stiffness when the element fails.

When set to 2..Shear Panel, Effectiveness Factor, F1, F2, F3, and F4 specify treatment of the effective
extensional area of the shear panel.

MSC Nastran tab - These options are only used for SOL 400 and written to a PSHLN1 entry. When Large
Strain is activated, two options, Integration Type and Behavior Type, are available for each element
topology.
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For a Membrane, Bending Only, or Plate property, available options for Integration Type and Behavior
Type for each Element Topology for Plates:

Element Topology Integration Type Behavior Type

Tria3 Elements 0..Default

1..Linear

5..Linear Discrete Kirchhoff

0..Default

2..Doubly-curved thin shell

3..Membrane three-dimensional

Tria6 Elements 0..Default

3..Quadratic

0..Default

3..Membrane three-dimensional

Quad4 Elements 0..Default

1..Linear

2..Linear Reduced Hourglass control

5..Linear Discrete Kirchhoff

0..Default

1..Doubly-curved thick shell

2..Doubly-curved thin shell

3..Membrane three-dimensional

Quad8 Elements 0..Default

3..Quadratic

4..Quadratic Reduced

0..Default

1..Doubly-curved thick shell

3..Membrane three-dimensional

In addition, an existing material may then be selected from the Membrane drop-down and/or the
Bending drop-down in the Material Overrides section.

Property Extensions - Plane Strain

MSC Nastran tab - These options are only used for SOL 400 and written to a PSHLN2 entry. When Large
Strain is enabled, two options, Integration Type and Behavior Type, are available for each element
topology.

Available options for Integration Type and Behavior Type for each Element Topology for Plane Strain:

Element Topology Integration Type Behavior Type

Tria3 Elements 0..Default

1..Linear

0..Default

1..Axisymmetric Solid

2..Incompressible Axisymmetric

4..Plane Strain

5..Incompressible Plane Strain

Tria6 Elements 0..Default

3..Quadratic

0..Default

1..Axisymmetric Solid

3..Plane Stress

Properties
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Element Topology Integration Type Behavior Type

4..Plane Strain

Quad4 Elements 0..Default

1..Linear

2..Linear Reduced Hourglass control

6..Linear with Twist

0..Default

1..Axisymmetric Solid

3..Plane Stress

4..Plane Strain

Quad8 Elements 0..Default

3..Quadratic

4..Quadratic Reduced

5..Quadratic with Twist

0..Default

1..Axisymmetric Solid

3..Plane Stress

4..Plane Strain

In addition, an existing material may then be selected from the Material drop-down as well as a Layer
Direction and/or Thickness in the Overrides section.

Property Extensions - Laminate

MSC Nastran tab - These options are only used for SOL 400 and are written to PHSLN1 entry. When
Large Strain is activated, two options, Integration Type and Behavior Type, are available for each
element topology.

Available options for Integration Type and Behavior Type for each Element Topology.

Element Topology Integration Type Behavior Type

Tria3 Elements 0..Default

1..Linear

5..Linear Discrete Kirchhoff

0..Default

2..Doubly-curved thin shell

3..Membrane three-dimensional

Tria6 Elements 0..Default

3..Quadratic

0..Default

3..Membrane three-dimensional

Quad4 Elements 0..Default

1..Linear

2..Linear Reduced Hourglass control

5..Linear Discrete Kirchhoff

0..Default

1..Doubly-curved thick shell

2..Doubly-curved thin shell

3..Membrane three-dimensional

Quad8 Elements 0..Default

3..Quadratic

4..Quadratic Reduced

0..Default

1..Doubly-curved thick shell

3..Membrane three-dimensional
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In addition, an existing material may then be selected from the Membrane drop-down and/or the
Bending drop-down in the Material Overrides section.

Property Extensions - Axisymmetric

MSC Nastran tab - These options are only used for SOL 400 and written to a PSHLN2 entry. When Large
Strain is activated, two options, Integration Type and Behavior Type, are available for each element
topology.

Available options for Integration Type and Behavior Type for each Element Topology for Plane Strain:.

Element Topology Integration Type Behavior Type

Tria3 Elements 0..Default

1..Linear

0..Default

1..Axisymmetric Solid

2..Incompressible Axisymmetric

4..Plane Strain

5..Incompressible Plane Strain

Tria6 Elements 0..Default

3..Quadratic

0..Default

1..Axisymmetric Solid

3..Plane Stress

4..Plane Strain

Quad4 Elements 0..Default

1..Linear

2..Linear Reduced Hourglass control

6..Linear with Twist

0..Default

1..Axisymmetric Solid

3..Plane Stress

4..Plane Strain

Quad8 Elements 0..Default

3..Quadratic

4..Quadratic Reduced

5..Quadratic with Twist

0..Default

1..Axisymmetric Solid

3..Plane Stress

4..Plane Strain

In addition, an existing material may then be selected from the Material drop-down as well as a Layer
Direction and/or Thickness in the Overrides section.

Property Extensions - Solid

MSC Nastran tab - These options are only used for SOL 400 and written to the PSLDN1 entry.

Available options for Integration Type and Behavior Type for each Element Topology for Plane Strain:.

Properties

Femap What's New, Femap 2301  10-15
© 2023 Siemens



Element Topology Integration Type Behavior Type

Tetra4 Elements 0..Default

1..Linear

0..Default

1..Solid

3..Incompressible Solid

Tetra10 Elements 0..Default

2..Linear Reduced Hourglass control

6..Quadratic

0..Default

1..Solid

Pyram5 Elements 0..Default

1..Linear

2..Linear Reduced Hourglass control

0..Default

1..Solid

Pyram13 Elements 0..Default

6..Quadratic

0..Default

1..Solid

Wedge6 Elements 0..Default

1..Linear

0..Default

1..Solid

Wedge15 Elements 0..Default

6..Quadratic

0..Default

1..Solid

Brick8 Elements 0..Default

1..Linear

2..Linear Reduced Hourglass control

3..Assumed Strain Enhanced Formulation Solid Shell

0..Default

1..Solid

2..Solid Shell

Brick20 Elements 0..Default

4..Quadratic Reduced

6..Quadratic

0..Default

1..Solid

In addition, an existing material may then be selected from the Material drop-down in the Overrides
section.

Property Extensions - Solid Laminate

MSC Nastran tab - The Brick8 Elements and Brick20 Elements sections contain an Integration Type
drop-down menus. Available options for Brick8 Elements are 0..Default, 1..Linear, and 2..Assumed
Strain Enhanced For-mulation Solid Shell, while available options for Brick20 Elements are 0..Default
and 3..Quadratic.

In addition, it is possible to specify a Layer Direction in the Overrides section. The value for Layer
Direction must be +/-1, +/-2, or +/-3 only. Default in +1. A positive value implies that the composite layer
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input is a fractional percent of the total element thickness in the ply direction and is recommended. A
negative value implies that the composite layer input is the actual thickness of that ply.

These options, along with the options in the Define Property dialog box are used to write the PCOMPLS
entry.

Property Extensions - Solid Cohesive

MSC Nastran tab - These options are only used for SOL 400 and write. The Cohesive Elements section
contains three drop-downs.

Loads and Constraints

• Added an Equation Coord Sys drop-down to the Create Loads dialog box for the Model → Load
→ Nodal; Model → Load → Nodal on Face; Model → Load → Elemental; and Model → Load
→ Elemental on Face commands. The Equation Coord Sys drop-down can be used to specify the
coordinate system in which equations are evaluated when defining nodal or elemental loads when
Method is set to Variable. By default, this option is set to the active coordinate system in the model,
not to match the Definition Coord Sys.

Connections (Regions, Properties, and Connectors)

• Added a Check for Connection to Internal Edges option to the Connect → Automatic command,
which is only available when Edge - Edge is activated in the Connection Types section of the
Auto Detection Options for Connections dialog box. When activated, it allows connections to be
automatically created between any combination of free edges an internal edges (i.e., non-free edges)
of surfaces (sheet solids), solids, and general bodies which are considered coincident based on the
value specified for Tolerance in the Detection Options section. If deactivated, which is the default,
no connections will be made between any edge and any internal edge.

• Added a Surfaces to the Output section for Connection Regions. Only available when Defined By is
set to Surfaces and is currently only used by MSC Nastran.

• Updated the Connection Region Options dialog box to have three tabs: Simcenter Nastran, MSC
Nastran, and ABAQUS. The options on the Simcenter Nastran and ABAQUS tabs were available in
previous versions of Femap, but all of the options on the MSC Nastran tab other than Friction Value
(FRIC) are new for 2021.1.

Body Surface Contact Flag (COPTB)

Flag to indicate how body surfaces may contact. Writes COPTB and corresponding value to BCBDPRP
entry. Please see MSC documentation for BCONPRG entry for more information.

Friction Value (FRIC) or Friction Table (FRIC - TABLE)

When Friction Value (FRIC) is selected, specifies a friction coefficient and writes FRIC and a real
number to BCBDPRP entry. When set to Friction Table (FRIC - TABLE), represents ID of an existing
function, which writes FRIC and an integer value to BCBDPRP.

Loads and Constraints
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In general, entering the friction coefficient for a contact body pair via a BCTABLE and BCONECT/
BCONPRP is strongly recommended. When a grid point contacts a rigid body, coefficient of friction
associated with the rigid body is used. When a grid point contacts a deformable body, average of the
coefficients for the two bodies is used.

Smoothing Control (IDSPL)

Controls geometric smoothing of boundary of deformable body option. Enter a value of 0 or leave
blank for discrete geometric representation. When a value above 0 is used, the surface of the body
is smoothed out with splines (2D) or Coons surfaces (3D) and discontinuity edges/corners are being
defined by using absolute values of this setting as the ID of the BLSEG entries. If a BLSEG with ID
that does not equal the absolute value of this setting does not exist, the whole body is smoothed
and there are no user-defined discontinuity corners (2D) or edges (3D). Furthermore, additional
discontinuity edges are being generated automatically if the difference in patch normals exceeds
the value of Discontinuity Threshold (SANGLE). Default = 0. Writes IDSPL and corresponding value
to BCBDPRP entry.

Midside Node Projection (MIDNOD)

Mid-side node projection flag. Only used when Smoothing Control IDSPL does not equal 0. When
set to a value above 0, the midside grid of quadratic elements are projected onto the selected
spline surfaces. This operation is performed before the contact process starts and it may change the
location of grids in contact bodies. It may operate in combination with the initial stress-free contact.
Writes MIDNOD and corresponding value to BCBDPRP entry.

Discontinuity Threshold (SANGLE)

Threshold for automatic discontinuity detection in degrees. Used for geometric smoothing option in
SOL 400 only. Default = 60.0. Not used when Smoothing Control (IDSPL) is greater than or equal to
0. Writes SANGLE and corresponding value to BCBDPRP entry.

Contact Check (ISTYP)

Check of contact conditions and is not necessary in segment-to-segment contact. Writes ISTYP and
either 0 (default) or 2 to BCBDPRP entry.

0..Check Each Body

Each deformable body is checked versus the other.

1..Optimized Contact

Double-sided contact with automatic optimization of contact constraint equations.

Rigid Options button

Opens the Rigid Region Options dialog box, which is used to specify values for the various fields of
the BCRIGID entry.

Motion Control

This section is used to specify the CGID and CONTROL fields on the first line of the BCRIGID
entry, along with the NLOAD field on the second line. Control Node (CGID) and Rotation
Control Node (NLOAD) are the IDs of existing node(s). Choose from one of the three options
for Control Type (CONTROL).
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Rotation Axis

This section is used to specify values for the DCOS1, DCOS2, and DCOS3 fields on the second
line of the BCRIGID entry. When set to X (DCOS1)/Y(DCOS2)/Z(DCOS3), writes a specified value
as a real number to DCOS1, DCOS2 and/or DCOS3 fields, respectively. If set to Time Dependent
X/Time Dependant Y/Time Dependent Z, writes ID of existing function to DCOS1, DCOS2,
and/or DCOS3 fields as an integer.

Growth Factor

This section is used to specify values for the fields on the GROW line of the BCRIGID entry.
The values for Component 1 (GF1), Component 2 (GF2), and Component 3 (GF3) are written
to the GF1, GF2, and GF3 fields, respectively. The IDs of existing functions selected for Table
1 (TAB-GF1), Table 2 (TAB-GF2), and Table 3 (TAB-GF3) are written to the TAB-GF1, TAB-GF2,
and/or TAB-GF3 fields, respectively.

Angular Velocity

This section is used to specify values for the ANGVEL on the first line of the BCRIGID entry,
along with the values for the VELRB1, VELRB2, and VELRB3 fields on the second line of the
BCRIGID entry. When set to Angular Velocity Value (ANGVEL)/VX (VELRB1)/VY (VELRB2)/VZ
(VELRB3), writes a specified value as a real number to ANGVEL, VX (VELRB1), VY (VELRB2)
and/or VZ (VELRB3) fields, respectively. If set to Time Dependent Value/Time Dependant
VX/Time Dependent VY/Time Dependent VZ, writes ID of existing function to ANGVEL, VX
(VELRB1), VY (VELRB2), and/or VZ (VELRB3) fields as an integer.

Approach Velocity

This section is used to specify values for the fields on the APPROV line of the BCRIGID entry.
Angular Velocity (A) writes a value to the A field. Rotation Axis X (N1)/Rotation Axis Y (N2)/
Rotation Axis Z (N3) are written to the N1, N2, and N3 fields, respectively, while Velocity X
(V1)/Velocity Y (V2)/Velocity Z (V3) are written to the V1, V2, and V3 fields.

• Added Norm Scale Fac (SFNPNLT) and Tang Scale Fac (SFTPNLT) options to the Contact section of
the MSC Nastran Advanced Contact Options dialog box accessed by the Advanced Options button on
the MSC Nastran tab.

Norm Scale Fac (SFNPNLT)

Scale factor of augmented Lagrange penalty factor along contact normal direction. Value must be
above 0.0 (Default=1.0). Norm Scale Fac (SFNPNLT)*Lagrange Factor (PENALT) used
in analysis. If this field is left default, value of SFNPNLT entered for BCPARA, specified in Analysis
Set Manager, will be used. A non-blank value entered in SFNPNLT will override the value of
SFNPNLT in BCPARA. SOL 400 only.

Tang Scale Fac (SFTPNLT)

Scale factor of augmented Lagrange penalty factor along contact normal direction. Value must
be above 0.0 (Default=1.0). Tang Scale Fac (SFTPNLT)*Lagrange Factor (PENALT)
used in analysis. If this field is left default, value of SFTPNLT entered for BCPARA, specified in
Analysis Set Manager, will be used. A non-blank value entered in SFTPNLT will override the value
of SFTPNLT in BCPARA. Sol 400 only.

Connections (Regions, Properties, and Connectors)
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• Added a Cohesive Options button to the Glue Break section of the MSC Nastran Advanced Contact
Options dialog box accessed by the Advanced Options button on the MSC Nastran tab.

Displays the Contact Glued Contact Options dialog box, which can be used to specify parameters for
Cohesive (Flexible) Glued Contact. These options are written as parameters to a BCONPRG entry,
which is potentially used in conjunction with BCONPRP entry, with one or both entries referenced by a
BCONECT entry. Currently, these options are only for SOL 400.

Note:

Cohesive (Flexible) contact is only supported for surface-to-surface contact, thus all limitations
for sur-face-to-surface contact are also applicable to cohesive contact. In addition, the options
in the Glue Break section are not supported when using Cohesive contact.

Enable Cohesive Contact (FGCFLG)

Flag to activate Cohesive Glued Contact. Creates PGCFLG entry. When deactivated, which is default,
writes 0, which indicates no Cohesive Contact. When activated, writes 1, which activates Cohesive
Glued Contact.

Normal Stiffness (FGCNST)

Equivalent normal contact stiffness of connector for Cohesive Glued Contact. Creates FGCNST entry
and corresponding value.

Tangent Stiffness (FGCTST)

Equivalent tangential contact stiffness of connector for Cohesive Glued Contact. Creates FGCTST
entry and corresponding value.

Normal Stress Function (FGCNSTR)

ID of function defining contact normal stress versus relative displacement for Cohesive Glued
Contact. Creates FGCNSTR entry referencing ID of existing function.

Tangent Stress Function (FGCTSTR)

ID of function defining contact tangential stress versus relative displacement for Cohesive Glued
Contact. Creates FGCTSTR entry referencing ID of existing function.

Normal Stiffness Function (FGCNSTI)

ID of function defining contact normal stiffness versus relative displacement or temperature for
Cohesive Glued Contact. Creates FGCNSTI entry referencing ID of existing function.

Tangent Stiffness Function (FGCTSTI)

ID of function defining contact tangential stiffness versus relative displacement or temperature for
Cohesive Glued Contact. Creates FGCTSTI entry referencing ID of existing function.

Reference Node (FGCRCEN)

ID of node on which the resultant contact and moment are based.
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• Added an Interference Options button to MSC Nastran Advanced Contact Options dialog box
accessed by the Advanced Options button on the MSC Nastran tab.

The options in this section are only available when Type is set to 0..Contact and written as
parameters to a BCONPRG entry, which can potentially be used in conjunction with a BCONPRP entry,
with one or both entries referenced by a BCONECT entry. Currently, these options are only for SOL
400.

Method (OPINTRF)

The method for interference fit. Integer value greater than or equal to 0 (Default=0).

0..Small Interference Fit

Small interference fit (solved in one increment).

1..Varying with time and resolved in normal direction

Interference fit varies with time; resolved in normal direction.

2..Varying with time in a user specified direction

Interference fit varies with time in a user specified direction.

3..Varying with time using a scale factor

Interference fit varies with time using scale factor.

4..Automatic fit varying with time and node location

Automatic interference fit varies with time and node location.

Variation Table (TBINTRF)

ID of function used for interference fit. Creates TBINTRF entry referencing ID of existing function.
Usage of the function depends on the setting for Method (OPINTRF):

0..Small Interference Fit

Not used.

1..Varying with time and resolved in normal direction

Variation of interference closure with respect to time.

2..Varying with time in a user specified direction

Variation of magnitude of translation vector with respect to time.

3..Varying with time using a scale factor

Variation of magnitude of scale factor with respect to time.

4..Automatic fit varying with time and node location

Variation of magnitude of penetration vector projected node position on the master segment
with respect to time.

Connections (Regions, Properties, and Connectors)
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Region (CBINTRF)

Specifies if the Slave region or Master region of each connector referencing a particular connection
property should be used for interference fit. Creates CBINTRF entry and writes 0 (“0..Slave” selected,
default) or 1 (“1..Master” selected). Usage depends on the setting for Method (OPINTRF):

0..Small Interference Fit and 1..Varying with time and resolved in normal direction

Not used.

2..Varying with time in a user specified direction

Use translation vector of each Slave or Master region.

3..Varying with time using a scale factor

Use scale factors of each Slave or Master region.

4..Automatic fit varying with time and node location

Determines penetrations of each Slave or Master region.

Fit CSys (CDINTRF)

ID of coordinate system used by Interference Vec X (VXINTRF), Interference Vec Y (VYINTRF), and
Interference Vec Z (VZINTRF) for interference fit. Creates CDINTRF entry referencing ID of existing
coordinate system. Usage depends on the setting for Method (OPINTRF):

0..Small Interference Fit, 1..Varying with time and resolved in normal direction, and
4..Automatic fit varying with time and node location

Not used.

2..Varying with time in a user specified direction

Coordinate system for direction cosines of translation vector.

3..Varying with time using a scale factor

Coordinate system for scale factor vector.

Pen Search Tolerance (PTINTRF)

Penetration search tolerance for interference fit. Only used when Method (OPINTRF) is set to
4..Automatic fit varying with time and node location. The value must be greater than or equal to
0 (Default = error tolerance*100).

Interference Vec X (VXINTRF), Interference Vec Y (VYINTRF), and Interference Vec Z (VZINTRF)

X, Y, and Z components of vector for interference fit (Default = 0.0). Usage depends on the setting
for Method (OPINTRF):

0..Small Interference Fit, 1..Varying with time and resolved in normal direction, and
4..Automatic fit varying with time and node location

Not used.

2..Varying with time in a user specified direction

10. What’s New - Version 2021.1

10-22  Femap What's New, Femap 2301
© 2023 Siemens



Direction cosines for the translation vector.

3..Varying with time using a scale factor

Scale factor vector.

Scaling Center X (XCINTRF), Scaling Center Y (YCINTRF), and Scaling Center Z (ZCINTRF)

X, Y, and Z components interference fit center of scaling. Only used when Method (OPINTRF) is set
to 3..Varying with time using a scale factor. Coordinates must be specified in global rectangular
coordinate system (Default = 0.0).

Initial Configuration (OPINGP)

Initial gap or overlap option. Choose from 0..None or 1..Initial Gap or Overlap. Writes OPINGP with
corresponding value of 0 (0..None) or 1 (1..Initial Gap or Overlap).

Search Tolerance (TOLINGP)

Search tolerance of initial gap. Only used when Initial Configuration (OPINGP) is set to 1..Initial
Gap or Overlap. Writes TOLINGP and corresponding value (Default = average edge length of all
contact segments).

Adjusted Region (CDINGP)

Specifies if Slave region or Master region of each connector referencing a particu-lar connection
property should be adjusted. Only used when Initial Configuration (OPINGP) is set to 1..Initial Gap
or Overlap. Creates CDINGP entry, writes 0 (0..Slave selected, default) or 1 (1..Master selected).

Overlap Magnitude (MGINP)

Gap or overlap magnitude. Only used when Initial Configuration (OPINGP) is set to 1..Initial Gap
or Overlap. When value is greater than 0.0, signifies a gap. When value less than 0.0, signifies an
overlap. When value = 0.0, which is the default, initial gap distance is preserved.

Listing

Added an Evaluate Group to ensure Entity Selection is valid option to the List → Groups command.
This option is on by default, but only used when the List Entities in Group option is enabled. Simply
performs the Group → Operations → Evaluate command on all selected groups before listing the
entities in each group.

Views

• Added support for RBE1 elements when using Best Available or Performance Graphics.

Output and Post-Processing

• Added a Linear and Parabolic Types option to the Contour Options dialog box, which controls if
averaging of results occurs across boundaries between linear and parabolic solid elements.

Listing
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Geometry Interfaces

The following Femap interfaces have been updated to support newer geometry formats:

Femap Interface Latest Supported Version

Parasolid 33.0

NX version 1926 (2020)

Solid Edge 2021

For details, see Section 9, “Geometry Interfaces” in the Femap User Guide.

Analysis Program Interfaces

Several of the analysis program interfaces have been improved. These changes include:

• Femap Neutral File Interface

• MSC Nastran Interface

• Simcenter Nastran Interface

• Nastran Interfaces (Simcenter and MSC/MD)

• ABAQUS Interface

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

Femap Neutral File Interface

• Updated Neutral Read and Write for v2021.1 changes.

MSC Nastran Interface

SOL 400 Overview

• Added support for Analysis Type 30..Implicit Nonlinear, which is used to setup analysis jobs using
SOL 400. To support SOL 400, new dialog boxes have been created in the Analysis Set Manager
to enter options for Non-linear Behavior (Nonlinear Behavior Options), Automatic Contact Parameters
(Automatic Contact Generation), and Control Parameters (NASTRAN Implicit Nonlinear Analysis). In
addition, new options were added to Contact Parameters (MSC Nastran Contact Solver Parameters).
Finally, two new entity types, Analysis Step (Analysis Step dialog box) and Global Step (Global Analysis
Steps dialog box), have been created to perform analysis chaining within a particular subcase.
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Nonlinear Behavior

The Nonlinear Behavior Options dialog box is used to specify values for specific fields on the NLMOPTS
entry:

When on, Enable NLMOPTS writes specified options to NLMOPTS entry. When off, writes nothing.

Nonlinear Properties

The items in this section are written to the SPROPMAP line of the NLMOPTS entry. These options
control auto-mated inclusion of nonlinear property options. See MSC Nastran Quick Reference Guide
for more information.

Mapping (PROPMAP)

Value written to PROPMAP field depends on selected option.

-1..No mapping considered

Writes a value of -1, which means no mapping is considered.

0..Full integration elements when necessary

Writes 0, which means map to full integration elements associated with nonlinear property
extension entries when necessary.

1..Reduced integration elements when necessary

Writes 1, which means map to reduced integration elements associated with nonlinear
property extension entries when necessary.

MSC Nastran Interface
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2..Full integration elements when possible

Writes 2, which means map to full integration elements associated with nonlinear property
extension entries when possible.

3..Reduced integration elements when possible

Writes 3, which means map to reduced integration elements associated with nonlinear
property extension entries when possible.

Behavior (PROPBEH)

Text written to PROPBEH field depends on selected option. 0..1D writes 1D, 1..3D writes 3D,
2..PLST writes PLST, 3..PSTR” writes PSTR, and 4..AXI writes AXI.

Print Flag (IPRINT)

Print flag for generated property. Value written to IPRINT field depends on selected option.

0..Default

Writes value of 0.

1..Print

Writes 1.

2.Punch

Writes 2.

3..Print and Punch

Writes 3.

Layer Direction (DIRECT)

Layer Direction Flag. Value written to DIRECT field depends on specified value. Must be an
integer value of 1, 2, or 3. Default is 1.

Thickness (THICKOP)

Out of plane thickness for 2D solids. Value written to THICKOP field depends on specified value,
which must be greater than or equal to 0.0. Default is 1.0.

Composite Options

The first two items in this section are written to the INLAM line of the NLMOPTS entry, while the
third is written to the SHEAR line.

Output (VCOORD)

Selects coordinate system for interlaminar stress output. Text written to VCOORD field depends
on selected option.

0..Use original CSys

Writes nothing, meaning use original coordinate system for interlaminar stress output.
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1..Use Ply CSys of bottom layer

Writes BOTT, meaning use ply coordinate system of bottom layer of the interlaminate for
interlaminar stress output.

2..Use Ply CSys of above layer

Writes TOP, meaning use ply coordinate system of top layer of the interlami-nate for
interlaminar stress output.

X-axis Projection (CPROJ)

Activates projection system for projecting X-axis of CORDM onto layer plane. When on, writes
ON to CPROJ field, which indicates projection scheme activated. When off, writes nothing or
OFF.

Parabolic Shear Distribution (TSHEAR)

When on, writes TSHEAR to VALS field to indicate parabolic shear distribution is used for certain
element types. When off, THEAR line is not written.

Strain Formulations

The first item in this section is written to the LRGSTRN line of the NLMOPTS entry, while the second
is written to the ASSM line.

Large Strain (LRGSTRN)

pecifies Large Strain Formulation. Value written to VALLE field on LRGSTRAN line depends on
selected option.

-1..No Large Strain Formulation

Writes -1.

0..Mean Normal Return

Writes 0.

1..Hypoelasticity and additive plasticity with mean normal return

Writes 1.

2..Hyperelasticity and multiplicative plasticity with radial return

Writes 2.

Assumed Strain (ASSM)

Assumed strain option. Text written to VALA field on ASSM line depends on selected option.

0..Default

ASSM line not written and assumed strain is calculated automatically for certain element
types under certain conditions.

1..Use assumed strain formulation

MSC Nastran Interface
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Writes ASSUMED, which means assumed strain is calculated manually for certain element
types under certain conditions.

2..Do not use assumed strain formulation

Writes OFF, which means assumed strain is never calculated.

Element Deactivation

The items in this section are written to the DEACTEL line of the NLMOPTS entry.

Rules (VALD1)

Select default deactivation rules for elements in each physics pass in the analysis. Value written
to VALD1 field depends on selected option.

-1..Default deactivation rules are always ignored

Writes -1, which is default for single physics analysis.

0..Default deactivation rules are always applied

Writes 0, which is default in coupled analysis.

1..Default deactivation rules are applied in a mechanical pass only

Writes 1.

2..Default deactivation rules are applied in a thermal pass only

Writes 2.

Diag. Output (VALD2)

Select diagnostic output behavior for active and deactivated elements. Value written to VALD2
field depends on selected option.

0..Summary of deactivated elements

Writes 0, meaning a summary of all deactivated elements is printed. If no elements get
deactivated output is skipped.

1..Detailed list of deactivated elements

Writes 1, meaning a detailed list of all deactivated elements is printed. If no elements get
deactivated output is skipped.

2..Summary of deactivated and remaining elements

Writes 2, meaning a summary of all deactivated and all remaining active elements is
printed.

3..Detailed list of deactivated and remaining elements

Writes 3, meaning a detailed list of all deactivated and all remaining active elements is
printed.

Creep
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The items in this section are written to the CREEP line of the NLMOPTS entry.

Enable Creep Formulations (CREEP)

When on, the CREEP line is written with either values for VALC1 and VALC2 or values for VALC3
and VALC4. This line indicates the formulation to use for creep analysis.

Note:

Creep data should be entered using the MATVP entry, not the CREEP bulk data entry.

Implicit Creep

When selected, writes the selected option to a combination of the VALC3 and VALC4 fields. In
all cases, a value of a value of 1 is written to VALC3. The value of VALC4 depends on selected
option, where 0..Elastic Tangent writes a value of 0, 1..Secant Tangent writes a 1, or 2..Radial
Return writes a 2.

Explicit Creep

When selected, writes the selected option to a combination of the VALC1 and VALC2 fields. In
all cases, a value of a value of 0 is written to VALC2. The value of VALC1 depends on selected
option, where 0..Maxwell Model Creep writes a value of 0 or 1..Explicit Viscoplastic Creep
writes a 1.

Automatic Contact Parameters

The Automatic Contact Generation dialog box is used to specify values for specific fields on the BCAUTOP
entry, which are used for Automatic contact generation (ACG).
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When enabled, Enable BCAUTOP writes specified options to BCAUTOP entry, When disabled, writes
nothing.

Primary Parameters

The items in this section are the most important parameters for build of contact bodies, match of
contact pairs.

Elements (ESET)

When selected, specifies the element IDs to only consider for automatic creation of contact
bodies. When a group is selected from the drop-down, a SET1 entry will be created in Case
Control containing element IDs, then ESET will be written and reference the ID of the SET1
entry. If the drop-down is set to 0..None, then a SET1 entry will not be written or referenced by
ESET, thus all elements in the model will be considered.

Elements as Seeds (SeedESet)

When selected, specifies the element IDs to consider as seeds for automatic creation of contact
bodies. When a group is selected from the drop-down, a SET1 entry will be created in Case
Control containing element IDs, then SeedESet will be written and reference the ID of the SET1
entry. If the drop-down is set to 0..None, then a SET1 entry will not be written or referenced by
SeedESet, thus all elements in the model will be considered as seed elements.

Nodes as Seeds (SeedGSet)

When selected, specifies node IDs to determine seed elements for automatic creation of contact
bodies. Only considers elements which are connected to the specified node IDs. When a group
is selected from the drop-down, a SET1 entry will be created in Case Control containing node
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IDs, then SeedNSet will be written and reference the ID of the SET1 entry. If the drop-down is
set to 0..None, then a SET1 entry will not be written or referenced by SeedNSet, thus all nodes
in model are considered to determine seed elements.

Properties (PropSet)

When selected, specifies the property IDs to use for automatic creation of contact bodies.
When a group is selected from the drop-down, a SET1 entry will be created in Case Control
containing property IDs, then PropSet will be written and reference the ID of the SET1 entry. If
the drop-down is set to 0..None, then a SET1 entry will not be written or referenced by PropSet,
thus all properties in model are considered.

Rigid Regions (RigidSet)

Specifies connection region IDs with Type set to Rigid to consider for automatic creation of
contact bodies. When a group is selected from the drop-down, a SET1 entry will be created in
Case Control containing connection regions IDs, then RigidSet will be written and reference the
ID of the SET1 entry. If the drop-down is set to 0..None, then a SET1 entry will not be written
or referenced by RigidSet, thus all connec-tion regions in model with Type set to Rigid are
considered.

Note:

To quickly create a new group or edit an existing group, click the New Group icon button
next to a drop-down, then use the Quick Group dialog box to create, then populate the
group with entities (New Group button, followed by Edit Group button) or simply edit
an existing group (select a group from list, click Edit Group button). In all cases, clicking
Edit Group will open a standard selection dialog box allowing selection of the type of
entity needed by a particular set. For instance, when using the icon but-ton next to the
Elements (ESET) drop-down, you will be prompted to select elements.

Type (CTYPE)

Type of contact. Text written to CTYPE field depends on selected option.

0..Touching

Writes TOUCH (default).

1..Permanent Glue

Writes PGLUE.

2..Step Glue

Writes SGLUE.

3..General Glue

Writes GGLUE.

Distance Tolerance (DISTANCE)

Distance tolerance of contact pair. If the distance between any two points which are belonging
to two different contact bodies is less than this value, these two contact bodies are recognized
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to be a contact pair. Default value of DISTANCE is 100 times value of contact tolerance (ERROR).
If using the default ERROR, the value for ERROR is the smallest of the following values:

• 1/20 of the smallest nonzero element dimension (plates or solids) in the contact body.

• 1/4 of the thinnest shell thickness in the contact body.

Auxiliary Parameters

The items in this section allow for selection of an existing connection property and/or connection
region from the appropriate drop-down to specify options on the BCAUTOP entry.

In addition, the Contact Solver Options button displays the MSC Nastran Contact Solver Parameters
dialog box. For more information, see Section 8.8.1.33, "Contact Parameters (MSC Nastran Only)" in
the Femap User Guide.

Secondary Parameters

The items in this section are helpful for user to provide more detail and further requirement for
contact model establishment and contact analysis with automatic contact generation.

Dimension (DIMENS)

Dimension of contact bodies to create. When set to 2D, writes DIMENS and 2D. When set to 3D
(default), writes DIMENS and 3D.

Consider Beam Contact (BEAMCNT)

Determines if beams should be included in contact definition. When enabled, writes BEAMCNT
and YES. When disabled, which is the default, writes nothing.

Detection at Beam Free End (BEAMCAP)

Mainly used for contact pair detection where contact occurs at free beam end. When enabled,
which is the default, writes nothing. When disabled, writes BEAMCAP and NO.

Consider Edge Contact (EDGECNT)

Determines if shell edge is included in contact definition. When enabled, writes EDGECNT and
YES, which means free and hard shell edges are included in the contact definition. When
disabled, which is the default, writes nothing and no shell edges are included in the contact
definition.

Ignore Shell Thickness (IGTHNK)

Indicates if shell element thickness should be ignored for contact detection. When enabled,
writes IGNTHK and YES to ignore shell thickness. When disabled, which is the default, writes
nothing and shell thickness is included in detection.

Initial Stress Free Contact (INISTF)

Indicates if initial stress free contact should is allowed. When enabled, writes INISTF and YES,
meaning initial stress free contact is implemented. When disabled, which is the default, writes
nothing, meaning general contact without implementation of initial stress free.

Self Contact (SelfCont)
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Indicates if self contact should be considered. When enabled, writes SelfCont and Yes. When
disabled, writes nothing.

Friction

The items in this section are used to specify the options for friction.

Type (FTYPE)

Type of friction. When set to 0..No Friction, which is the default, writes nothing. When set
to 6..Bilinear Coulomb Friction, writes FTYPE and BLCOUL (indicates value of 6). When set to
7..Bilinear Shear Friction, writes FTYPE and BLSHEAR (indicates value of 7).

Coefficient options

Used to specify value for friction. When set to Table Coefficient, writes FRIC along with an
integer value which corresponds to the ID of function currently selected in the drop-down.
When set to Value Coefficient, writes FRIC along with the value specified in the field.

NASTRAN Implicit Nonlinear Analysis

Opens the Nastran Implicit Nonlinear Analysis dialog box, which is used to specify control parameters for
the Master Case, any subcase, or any analysis step for implicit nonlinear analysis (SOL 400):

Writes specified options to NLSTEP Bulk Data entry, along with NLSTEP = ID entry to the appropriate
location in Case Control. If Skip NLSTEP is on, no options may be specified and nothing is written.
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Value for ID is written to the ID field of NLSTEP. If a Subcase or Step has the same ID as Master Case, a
different Subcase, and/or a different Step, it will be properly incremented during export, so each NLSTEP
has a unique ID.

Step
Parameters

The items in the section are written to specific fields on the first line of the NLSTEP
entry.

Total Time (TOTTIM)

Total time for the load case. Must be a real number with a positive value. Default is
1.0. Value is written to TOTTIM field.

Nonlinearity (CTRLDEF)

Used to control the default values used for options specified the General
Parameters section and the Mechanical Analysis Parameters dialog box, which
is accessed by clicking the Mechanical Parameters button.

Note:

Once an option has been selected, click the Defaults button in the
appropriate dialog box to update the default values. This will allow blank
values to be written to the input file for those options.

Writes selected option to CTRLDEF field.

0..Default

Writes nothing.

1..Linear

Writes QLINEAR, meaning defaults are set for quasi-linear analysis.

2..Mildly Nonlinear

Writes MILDLY, meaning defaults are set for mildly nonlinear analysis.

3..Severely Nonlinear

Writes SEVERELY, meaning defaults are set for severely nonlinear analysis.

General Parameters

The items in the section are written to specific fields on the GENERAL of the
NLSTEP entry.

Max Iterations / Increment (MAXITER)

Maximum number of iterations allowed for each increment. Default is 10.
Writes value to MAXITER field.

Min Iterations / Increment (MINITER)
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Minimum number of iterations needed for each increment. Must be a
value greater than 0. Default is 1, unless Nonlinearity (CTRLDEF) is set to
2..Severely Nonlinear, then default value is 2. Writes value to MINITER field.

Max Bisections for Step (MAXBIS)

Maximum number of bisections allowed in the current step. Value can be
positive or negative. Default is 10. If value is positive and solution does
not converge after the specified number of bisections, the best solution is
computed and the analysis is continued to the next time step. If value is
negative and solution does not converge after the absolute value of specified
number of bisections, analysis is terminated.

Include Creep (CREEP)

Flag to include creep in current load case. If disabled, which is the default,
nothing is written to the CREEP field, meaning creep will not be included, even
if creep is defined for a material. When on, a value of 1 is written to the CREEP
field. For nonlinear elements only..

Analysis Parameters

Depending on the setting for Increment Type, the different options are available
when clicking the Increment Parameters button.

When Increment Type is set to 0..Fixed, clicking the Increment Parameters
button displays the Fixed Time Stepping Parameters dialog box. See Fixed Time
Stepping Parameters in the Femap User Guide for more information.

When Increment Type is set to 1..Adaptive, clicking the Increment Parameters
button displays the Adaptive Load Stepping Parameters dialog box. See Adaptive
Load Stepping Parameters in the Femap User Guide for more information.

When Increment Type is set to 2..Arc-Length, clicking the Increment Parameters
button displays the Arc-Length Load Stepping Parameters dialog box. See Arc-
Length Load Stepping Parameters in the Femap User Guide for more information.

Note:

The arc-length increment type is not supported for contact analysis and
should not be used when Analysis Type if set to 3..Transient.

Clicking the Mechanical Parameters button displays the Mechanical Analysis
Parameters dialog box. See Mechanical Analysis Parameters in the Femap User
Guide for more information.

Fixed Time Stepping Parameters

The items in Fixed Time Stepping Parameters dialog box are written to the FIXED line of the NLSTEP
entry.
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Step Parameters

Number of Increments (NINC)

Number of increments for fixed time stepping. Value must be above 0. Default is 50. When
value other than 50 is entered, writes value to NINC field. The time step for each increment
is calcu-lated value specified for Total Time (TOTTIM)/value specified for Number of Increments
(NINC).

Output Interval (NO)

Interval for output. Every NO-th increment will be saved for output. Must be a value greater
than or equal to 0. Default is 1. When value other than 1 is entered, writes value to NO field.

Adaptive Load Stepping Parameters

The items in Adaptive Load Stepping Parameters dialog box are written to the various ADAPT lines of the
NLSTEP entry.
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Time Steps

Initial Fraction (DTINITF)

Initial time step defined as fraction of Total Time (TOTTIM). Default is 0.01. If this value is
greater than or equal to Max Fraction (DTMAXF), then the value is reset to that value.
If Nonlinearity (CTRLDEF) is set to 1..Linear, this value should be set equal to Total Time
(TOTTIM). When set to a value other than 0.01, writes specified value to DTINITF filed on first
ADAPT line.

Min Fraction (DTMINF)

Minimum time step defined as fraction of Total Time (TOTTIM). Default is 1.0E-5. When set to a
value other than 1.0E-5, writes specified value to DTMINF field on first ADAPT line.

Max Fraction (DTMAXF)

Maximum time step defined as fraction of Total Time (TOTTIM). Default is 0.5. When set to a
value other than 0.5, writes specified value to DTMAXF field on first ADAPT line.
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Note:

When Analysis Type is set to 3..Transient for the Master Case, Subcase, or Step, this
value should be set between 0.05 and 0.2.

Increase Factor (SFACT)

Factor for increasing time steps due to number of iterations. Default is 1.2. When set to a value
other than 1.2, writes specified value to SFACT field on first ADAPT line.

Auto Skip Factor (ADJUST)

Time step skip factor for automatic time step adjustment. Only used when Analysis Type is set
to 3..Transient for the Master Case, Subcase, or Step. Default is 0. When set to a value other
than 0, writes value to ADJUST field on third ADAPT line.

Dominant Period Resp. Steps (MSTEP)

Number of steps to obtain the dominant period response. Default is 10. When value other than
10 is specified, writes value to MSTEP field on third ADAPT line.

When set to an integer value from 10 to 200, activates frequency based adaptive time step
adjustment with bounds, using value specified for Adaptive Time Step Bound (RB), when
specified increment converges. It cannot be combined with iteration based adaptive time step
adjustment, controlled by Desired Iterations / Increment (NDESIR), thus the value for Desired
Iterations / Increment (NDESIR) is always ignored in this case.

When set to a value of -1, activates frequency based adaptive time step adjustment without
bounds, thus value specified for Adaptive Time Step Bound (RB) is ignored. It can be combined
with iteration based adaptive time step adjustment controlled by Desired Iterations / Increment
(NDESIR). If Desired Iterations / Increment (NDESIR) is set to 0, time step is only adjusted after
the increment converges.

Adaptive Time Step Bound (RB)

Define bounds for maintaining the same time step for the stepping function during the adaptive
process. Must be value from 0.1 to 1.0. Default is 0.6. When value other than 0.6 is specified,
writes value to RB field on third ADAPT line. See definition for Dominant Period Resp. Steps
(MSTEP) for more information about when this value is used.

Output Control

Output Flag (INTOUT) and Output Every Nth Step

Output flag and Interval value to use when options is set to 1..Equally Spaced Intervals. Writes
value for selected option to INTOUT field on first ADAPT line.

-1..Last Increment

Writes value of -1, meaning only the last increment of the step will be output.

0..Every Load Increment

Writes value of 0, meaning every computed load increment will be output.
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1..Equally Spaced Intervals

Writes, value specified for Output Every Nth Step, meaning output will be obtained at
equally spaced intervals, thus time step will be temporarily adjusted if necessary in order to
reach certain intervals.

Criteria button

Opens User Criteria Parameters dialog box:

If Enable User Criteria is enabled, the options in the Parameters and Time Step Changes sections
in the top half of the dialog box can be used to write values to fields on the second ADAPT line of
the NLSTEP entry.

Physical Criteria (IPHYS)

Determines if automatic physical criteria should be added and how analysis should proceed if a
user criterion is not satisfied. Writes value for selected option to IPHYS field. Default is 2..Add
Auto Physical Criteria; Stop When User Criteria Exceeded.

-2..No Auto Physical Criteria; Continue When User Criteria Exceeded

Writes value of -2, meaning do not add automatic physical criteria; continue when user
criteria are not satisfied.

-1..Add Auto Physical Criteria; Continue When User Criteria Exceeded

Writes value of -1, meaning add automatic physical criteria; continue when any user
criterion is not satisfied.

1..No Auto Physical Criteria; Stop When User Criteria Exceeded

Writes value of 1, meaning add automatic physical criteria; stop when any user criterion is
not satisfied.
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2..Add Auto Physical Criteria; Stop When User Criteria Exceeded

Writes value of 2, meaning do not add automatic physical criteria; stop when any user
criterion is not satisfied

Definition (LIMTAR)

Controls how user criteria are used. When set to 0..Criteria as Limits, which is default, writes
value of 0 to LIMTAR field. When set to 1..Criteria as Targets, writes value of 1 to LIMTAR field.

Note:

When used as limits, time step will be reduced if the criterion would be violated. When
used as targets, time step will be increased if the calculated results are less than what is
specified by the criteria.

Min. Ratio (RSMALL)

Smallest ratio between time step changes due to user criteria. Default is 0.1. When set to value
other than 0.1, writes value to RSMALL field.

Max Ratio (RBIG)

Largest ratio between time step changes due to user criteria. Default in 10.0. When set to value
other than 10.0, writes value to RBIG field.

The bottom half of the dialog box can be used to specify values for up to 10 different user-
defined criteria. These values are then written to a TABSCTL entry. The ID of the TABSCTL entry is
then referenced by the CRITTID field on the second “ADAPT” line of the NLSTEP entry.

The various columns are used for several reasons, including selection of user criteria to consider,
choose which entities should be considered for each user criteria, and specify limit values for
each criteria.

Status

When the box in the Status column is on, that User Criteria will be written to the TABSCTL entry
using the specified group information and ranges of limit target values.

Increment

This column contains names of the 10 potential user criteria. Selected user criteria are written
as text to a ICRITi field on the TABSCTL entry. Available options are Elem. Strain (writes ESI),
Elem. Plastic Strain (writes EPSI), Elem. Creep Strain (writes ECSI), Elem. Normalized Creep
Strain (writes ENCSI), Elem. Strain Energy (writes ESRI), Elem. Stress (writes ESTRI), Elem.
Normalized Stress (writes ENSTRI), Nodal Temperature (writes GTI), Nodal Displacement
(writes GDI), and Nodal Rotation (writes GRI).

Group

By default, set to 0..All, which means all nodes in the model will be considered for the 3 nodal
criteria or all elements will be considered for the 7 elemental criteria. If a group is selected,
only the nodes/elements in that group will be considered by writing a SET3 bulk data entry
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containing node/element IDs. Each SET3 entry is then referenced by an appropriate SET3_IDi
field on the TABSCTL entry.

Note:

To quickly create a new group or edit an existing group, click the New Group icon button
in the lower left of the dialog box, then use the Quick Group dialog box to create, then
populate the group with enti-ties (New Group button, followed by Edit Group button)
or simply edit an existing group (select a group from list, click Edit Group button). In all
cases, clicking Edit Group will open a standard selection dialog box allowing selection of
the type of entity needed by a particular user criteria.

Y1, M1, Y2, M2, Y3, M3, Y4, M4

For each user criterion, up to 4 ranges of target/limit values can be specified. This allows the use
of different limit/target values for different ranges of the corresponding total quality. Writes all
YT1_i, MT1_i, YT2_i, MT2_i, YT3_i, MT3_i, YT4_i, and MT4_i entries needed for each selected
user criteria.

Arc-Length Load Stepping Parameters

The items in the Arc-Length Load Stepping Parameters dialog box are written to the various ARCLN lines
of the NLSTEP entry.

Constraint Type

Used to select the arc-length method. Writes text for selected option to TYPE field. Default is
0..Crisfield.

0..Crisfield

Writes CRIS, which selects the Crisfield arc-length method.
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1..Riks

Writes RIKS, which selects the Riks arc-length method.

2..Modified Riks

Writes MRIKS, which selects the modified Riks arc-length method.

Initial Time Step Fraction (DTINITFA)

Initial time step defined as a fraction of the Total Time (TOTTIM) for the arc-length procedure.
Default is 0.01. If value other than 0.01 is specified, writes value to DTINITFA field.

Min ArcLen Adjust Ratio (MINALR)

Minimum allowable arc-length adjustment ratio between increments for the adaptive arc-length
method. Must be a value from 0.0 to 1.0. Default = 0.25. If value other than 0.25 is specified, writes
value to MINALR field.

Max ArcLen Adjust Ratio (MAXALR)

Maximum allowable arc-length adjustment ratio between increments for the adaptive arc-length
method. Must be greater than or equal to 1.0, Default = 4.0. If value other than 4.0 is specified,
writes value to MAXALR field.

Scale Factor (SCALEA)

User specified scaling factor. If any value other than 0.0 is specified, writes value to SCALEA field.

Desired Iterations (NDESIRA)

Desired number of iterations for convergence to be used for the adaptive arc-length adjustment.
Must be an integer value greater than 0, Default = 4. If value other than 4 is specified, writes value
to NDESIRA field.

Max Increments (NSMAXA)

Maximum number of increments in the current load case. Must be an integer value. Default is 1000.
If value other than 1000 is entered, writes value to NSMAXA field.

Mechanical Analysis Parameters

The items in the Mechanical Analysis Parameters dialog box are written to the various MECH lines of the
NLSTEP entry.
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When Enable MECH is on, writes specified options to MECH lines. When disabled, writes nothing.

Based on the setting for Nonlinearity (CTRLDEF) in the Nastran Implicit Nonlinear Analysis dialog box,
which is listed at the top, clicking the Defaults button populates the fields with the recommended
default values.

Stiffness Updates

Method (KMETHOD)

Method for controlling stiffness updates. When set to 0..Full Newton-Raphson, which is the
default, nothing is written. When set to 1..Quasi Newton-Raphson, writes ITER to KMETHOD
field.

Iteration Interval (KSTEP)

Only available when Method (KMETHOD) is set to 1..Quasi Newton-Raphson. Specifies
number of iterations before the stiffness update. Default is 10. Writes value other than 10
to KSTEP field.

Advanced

ON Vectors (MAXQN)

Only used by Method (KMETHOD) is set to 1..Quasi Newton-Raphson. Maximum number of
quasi-Newton correction vectors to be saved on the database. Must be an integer value. Default
is value for Max Iterations / Increment (MAXITER). Writes value to MAXQN field.

Max Line Searches (MAXLS)

Only used by Method (KMETHOD) is set to 1..Quasi Newton-Raphson. Maximum number of
line searches allowed for each iteration. Default is 4. Writes value other than 4 to MAXLS field.

Line Search Tol (LSTOL)
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Only used by Method (KMETHOD) is set to 1..Quasi Newton-Raphson. Line Search tolerance.
Must be value from 0.01 to 0.9. Default is 0.5. Writes value other than 0.5 to LSTOL field.

Fraction Limit (FSTRESS)

Fraction of effective stress used to limit the sub-increment size in material routines. Must be
value from 0.0 to 1.0. Default is 0.2. Writes value other than 0.2 to FSTRESS field.

Convergence Tolerances

Displacement, Load, Work, Vector, Length, Automatic Switching

Error tolerances for displacement, load, work, vector, and length. Depending on the options
enabled, writes the CONV entry with U (Displacement), P (Load), W (Work), V (Vector), L
(Length), and/or A (Automatic Switching) in any combination. Default for CONV for SOL 400 for
structural analysis is PV. Along with CONV, a corresponding entry and value will be written for
each tolerance. When on, Displacement writes EPSU, Load writes EPSP , and Work writes EPSW.
Default values depend on Nonlinearity (CTRLDEF) setting in the Nastran Implicit Nonlinear
Analysis dialog box

Checking (MRCONV)

Specifies if rotations and moments should be included in the convergence testing. Writes value
of selected option to MRCONV field. Default is 3..Forces and Displacements.

0..Forces, Moments, Displacements, and Rotations

Writes value of 0, meaning check forces, moments, dis-placements and rotations.

1..Forces, Moments, and Displacements

Writes value of 1, meaning check forces, moments, and displacements.

2..Forces, Displacements, and Rotations

Writes value of 2, meaning check forces, moments, and rotations.

3..Forces and Displacements

Writes value of 3, meaning check forces and displacements only.

MSC Nastran Contact Solver Parameters

The MSC Nastran Contact Solver Parameters dialog box contains a number of options which can be
specified when performing an analysis in MSC Nastran, which also includes surface-to-surface contact.
All of the items in this dialog box correspond to items (Params) which can be included on the BCPARA
entry.
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Enable Contact Parameters must be on for Femap to use any options in this dialog box:

BCPARA

The items in this section are written to the BCPARA entry. For more information, see the BCPARA
(Contact Parameters - SOLs 101 and 400) entry in the MSC Nastran Quick Reference Guide.

Contact Method (METHOD)

Contact Method. When set to 0..NODESURF, which is the default, writes nothing, indicating
node to segment contact. When set to 1..SEGTOSEG, writes METHOD and SEGTOSEG, indicating
segment-to-segment contact.

Touch Dist (ERROR)

Distance below which a node is considered touching a body. Default = 0.0 (nothing is written,
meaning automatic calculation). When value above 0.0 is specified, writes ERROR and value.

Cont Tolerance (BIAS)

Contact tolerance bias factor. Value must be between 0.0 and 1.0. Default value is 0.9. When
value is not 0.9, writes BIAS and value.

Max Slide Dist (SLDLMT)
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Maximum allowed sliding distance, beyond it the contact segments are redefined, for segment
to segment contact analysis with large deformation. Default is 0.0. If value other than 0.0 is
specified, writes SLDLMT and value.

Max Slip Dist (STKSLP)

Maximum allowable slip distance for sticking, beyond it there is no sticking, only sliding exists.
Only used when Contact Method (METHOD) is set to 1..SEGTOSEG. Default is 0.0. If value
other than 0.0 is specified, writes STKSLP and value.

All Glue (NGLUE)

Determines if the same glued behavior will be used for all subcases, which is the default, or only
the first load case (first subcase and first step). If off, which is the default, and all slave regions
for connectors (BCTABLE or BCONPRG entries) corresponding to the first load case (first subcase
and first step) contain a value for TYPE(IGLUE) above 0 on the Connection Property, permanent
glued contact with small rotation condition will be used for all slave connection regions in all
subcases. If instead, then value for TYPE(IGLUE) is below 0 on the Connection Property, then
permanent glued contact for large deformation and large rotation is activated. If enabled, writes
NGLUE and a value of 1, meaning permanent glued contact conditions will be used for all “slave
connection regions in only the first load case (first subcase and first step).

Error by Pair (ERRBAS)

Error computation option. When off, which is the default, error is computed globally for all
contact pairs (connectors). When on, writes ERRBAS and value of 1, meaning the error is
calculated for each contact pair (connector) individually.

Include 3D Beam (BEAMB)

Beam-Beam contact flag. When off, which is the default, nothing is written and there is no
beam-to-beam contact. When on, writes BEAMB with a value of 1 and beam-to-beam contact is
activated.

Ignore Tolerance Thickness (THKOFF)

Ignore thickness from the tolerance used when Search (ISEARCH) is set to 2..Auto on the
Connection Property when Contact Method (METHOD) is set to 0..NODESURF or from the
characteristic length calculated from the combination of the values for Aug Pen Dist (AUGDIST)
and Augment PenFactor (PENALT) in Contact Method (METHOD) is set to 1..SEGTOSEG. If off,
which is the default, writes nothing, meaning do not ignore thickness. If on, writes THKOFF and
value of 1, meaning remove thickness.

Augment Method (AUGMENT)

Augmentation method used in a segment-to-segment contact analysis. Writes AUGMENT and
value of selected option. 0..None is default.

0..None

Writes 0, meaning no augmentation.

1..Linear-Constant, Quadratic-Bilinear

Writes 1, meaning Augmentation based on a constant Lagrange multiplier field for linear
elements and on a (bi)linear Lagrange multiplier field for quadratic elements.
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2..Constant

Writes 2, meaning augmentation based on a constant Lagrange multiplier field.

3..Bilinear

Writes 3, meaning augmentation based on a (bi)linear Lagrange multiplier field.

Aug Pen Dist (AUGDIST)

Penetration distance beyond which an augmentation will be applied. Only used when Contact
Method (METHOD) is set to 1..SEGTOSEG. Must be a value above 0. Writes AUGDIST and value.
See MSC Nastran Quick Reference Guide for more information on proper usage.

Augment PenFactor (PENALT)

Augmented Lagrange penalty factor. Only used when Contact Method (METHOD) is set to
1..SEGTOSEG. Must be a value above 0.0. Writes PENALT and value. See MSC Nastran Quick
Reference Guide for more information on proper usage.

Stick Pen Fact (TPENALT)

Augmented Lagrange penalty factor for sticking part of friction. Only used when Contact
Method (METHOD) is set to 1..SEGTOSEG. Must be a value above 0.0. The default is value
specified for Augment PenFactor (PENALT)/1000. Writes TPENALT and value.

Normal Scale Factor (SFNPNLT)

Scale factor of augmented Lagrange penalty factor along contact normal direction. Only used
when Contact Method (METHOD) is set to 1..SEGTOSEG. Must be a value above 0.0 and
default is 1.0. Normal Scale Factor (SFNPNLT) value *Augment PenFactor (PENALT) value is
used in analysis. Writes SFNPNLT and value.

Tangent Scale Factor (SFTPNLT)

Scale factor of augmented Lagrange penalty factor along contact tangential direction. Only
used when Contact Method (METHOD) is set to 1..SEGTOSEG. Must be a value above 0.0 and
default is 1.0. Tangent Scale Factor (SFTPNLT) value *Augment PenFactor (PENALT) value is
used in analysis. Writes SFTPNLT and value.

Max DDU (DDULMT)

Maximum value of DDU in a Newton-Raphson cycle. Value must be greater than or equal to
zero. Default is 0.0, which means no limitation. If other value is enters, writes DDULMT and
value.

Sticking Augment (TAUGMNT)

Augmentation for the sticking part of friction when Contact Method (METHOD) is set to
1..SEGTOSEG. When off, which is the default, writes nothing and there is no augmentation.
When on, writes TAUGMENT and a value of 1, meaning use augmentation.

Infinitesimal Sliding (LINCNT)

Flag for Linear Contact (i.e., under infinitesimal assumption, small sliding with small
deformation and rotation). When off, which is the default, nothing is written, meaning general
contact. When on, writes LINCNT and value of 1, which activates linear contact so the contact
force is distributed based upon undeformed geometry.

MSC Nastran Interface

Femap What's New, Femap 2301  10-47
© 2023 Siemens



Friction

The items in this section are written to the BCPARA entry.

Friction (FTYPE)

Friction type. When set to 0..None, which is the default, writes nothing. When set to 6..Bilinear
Coulomb, writes FTYPE and a value of 6, meaning Bilinear Coulomb friction. When set to
7..Bilinear Shear, writes FTYPE and value of 7, meaning Bilinear Shear friction.

Bilin (RVCNST)

Slip threshold for the bilinear friction model. Must be greater than or equal to 0.0. Default is 0.0.
When set to a value other than 0.0, writes RVCNST and specified value.

Non Symmetric Matrix (SEGSYM)

Specifies if a symmetric or non-symmetric friction matrix will be used when Contact Method
(METHOD) is set to 1..SEGTOSEG. When off, which is the default, writes nothing, meaning
symmetric friction matrix. When on, writes SEGSYM and a value of 1, indicating a non-sym-
metric friction matrix will be used.

Cohesive Contact Options button

Displays the Cohesive Glued Contact Options dialog box, which contains options related to cohesive
glued contact.

The Enable Cohesive Contact (FGCFLG) option must be enabled to use any options in this dialog
box. When on, writes FGCFLG and a value of 1, meaning Cohesive (Flexible) Glued Contact has been
activated.

Normal Stiffness (FGCNST)

Equivalent normal contact stiffness of connector for Cohesive (Flexible) Glued Contact. Writes
FGCNST and entered value.

Tangent Stiffness (FGCTST)

Equivalent tangential contact stiffness of connector for Cohesive (Flexible) Glued Contact.
Writes FGCTST and entered value.

Normal Stress Function (FGCNSTR)

Select an existing function to define contact normal stress versus relative displacement for
Cohesive (Flexible) Glued Contact. When a function is selected, writes FGCNSTR and the ID of
the function.

Tangent Stress Function (FGCTSTR)

Select an existing function to define contact tangential stress versus relative displacement for
Cohesive (Flexible) Glued Contact. When a function is selected, writes FGCTSTR and the ID of
the function.

Normal Stress Function (FGCNST1)
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Select an existing function to define contact normal stiffness versus rela-tive displacement or
temperature for Cohesive (Flexible) Glued Contact. When a function is selected, writes FGCNST1
and the ID of the function.

Tangent Stress Function (FGCTST1)

Select an existing function to define contact tangential stiffness versus relative displacement or
temperature for Cohesive (Flexible) Glued Contact. When a function is selected, writes FGCTST1
and the ID of the function.

Reference Node (FGCRCEN)

ID of node on which the resultant contact and moment are based. Must be an existing node in
the model. When not set to 0, writes FGCRCEN and ID of node.

Separation Control

The items in this section are written to the BCPARA entry.

Sep Control (ICSEP)

Select an option from the drop-down to control separation. Only used when Contact Method
(METHOD) is set to 0..NODESURF. Default is 0..Nodal Force > Separation Force.

0..Nodal Force > Separation Force

The node separates and an iteration occurs if the force on the node is greater than the
separation force. Writes nothing.

1..Prevent Separation Until Next Increment

If a node which was in contact at the end of the previous increment has a force greater than
the separation force, the node does NOT separate in this increment, but separates at the
beginning of the next increment. Writes ICSEP and value of 1.

2..Prevent New Node Separation

If a new node comes into contact during this increment, it is not allowed to separate during
this increment, prevents chattering. Writes ICSEP and value of 2.

3..Both 1 and 2

Both 1 and 2 are in effect. Writes ICSEP and value of 3.

Separation (IBSEP)

Select an option from the drop-down to control if separation is based on stresses or forces.
Default is 0..Force Based.

0..Force Based

Separation based on forces. Writes nothing.

1..Absolute Stress Based

Separation based on absolute stresses (force/area). Writes IBSEP and value of 1.

2..Absolute Intg Pt Stress
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Separation based on absolute stress (extrapolating integration point stresses). Writes IBSEP
and value of 2.

3..Relative Nodal Stress

Relative nodal stress (force/area). Writes IBSEP and value of 3.

4..Relative Intg Pt Stress

Separation based on relative stress (extrapolating integration point stresses). Writes IBSEP
and value of 4.

Max Sep (MAXSEP)

Maximum number of separations allowed in each increment. After the specified number of
separations have occurred, if the standard convergence tolerance conditions are achieved, the
step will converge. Default value is 9999. When a value other than 9999 is entered, writes
MAXSEP and the value.

Sep Force/Stress (FNTOL)

Separation force (or stress if Separation (IBSEP) is set to an option other than 0..Force Based)
above which a node separates from a body. Automatically calculated when using a value of 0.0,
which writes nothing. When a value other than 0.0 is entered, writes FNTOL and value.

Skip Sep Check (NODSEP)

Skip separation check in contact for any grid already touched and separated. The value indicates
how times to skip within the current increment. Default is 5. When am integer value other than
5 is entered, writes NODSEP and value.

Simcenter Nastran Interface

DDAM

• Added read/write support for the SELMODE entry. This is specified using the Mode Selection section
in the NASTRAN DDAM Solution Options dialog box in the Analysis Set Manager.

• Added read support for MPC Forces, Element Strains, and Membrane-only Stresses for Beams, Shells,
and Laminates. These results are requested by PARAM,SHLMEM,YES.

A number of bugs were corrected.

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

Nastran Interfaces (Simcenter and MSC/MD)

• Added read/write support for MODSEL (Simcenter Nastran) and a subset of the functionality of
MODESE-LECT (MSC Nastran). This can be specified using the Response Mode Selection (a, b,
c THRU d) section in the NASTRAN Modal Analysis dialog box in the Analysis Set Manager
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when creating an Analysis Set with Analysis Type set to 3..Transient Dynamic/Time History or
4..Frequency/Harmonic Response.

A number of bugs were corrected.

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

ABAQUS Interface

• Added support to maintain the case of names during import of an input file.

• Added support to remove the leading characters of names during export, thus maintaining the names
of entities entered by the user.

A number of bugs were corrected.

For details, see Section 8, “Analysis Program Interfaces” in the Femap User Guide.

Tools

• Added Interference Factor/Proximity Factor options to the Tools → Check → Mesh Interference
command. In addition, consolidated the user interface to use a single dialog box instead of a series of
questions.

First, select the elements to be checked, then specify options using the Check Mesh Interference dialog
box.

When Check All Element Faces is selected in the Checking Options section, all faces on solid elements
are considered for interference checking. When Check Only Free Faces of Solid Elements is selected,
only the free faces of solid elements are considered.
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When Interference Factor is selected in the Checking Options section, an element has to overlap at
least one other element by more than the specified value for the elements to be considered interfering.
When Proximity Factor is selected, it acts in an opposite manner to Interference Factor, meaning if a
gap smaller than the specified value exists between and element and any other element, those elements
are considered interfering.

When Create Element Interference Group is on in the Group Creation section, a group of all elements
which interfere with at least one other element is automatically created. If disabled, the elements are
simply highlighted in the graphics window. If there no elements interfere, a group will not be created,
even if this option is enabled.

OLE/COM API

New and modified API Objects and Attributes

• Added AnalysisStep (feAnalysisStep) object to the API.

Added StepTitle, StepLabel, StepID, InternalStepID, StepAnalysisType, UseGlobalStep, GlobalStepID,
CaseID, SkipStandard, NasStepAlternateTextLocation, StartText, and EndText attributes to specify
options in the MSC Nastran SOL400 Analysis Step dialog box.

Added NasInlStepOptOn, NasInlStepOptSkipNLSTEP, NasInlStepOptID, NasInlStepOptTOTTIM,
NasInlSte-pOptCTRLDEF, NasInlStepOptMAXITER, NasInlStepOptMINITER, NasInlStepOptMAXBIS,
NasInlStepOpt-CREEP, NasInlStepOptLoadStepping, NasInlStepOptNINC, NasInlStepOptNO,
NasInlStepOptDTINITF, NasInlStepOptDTMINF, NasInlStepOptDTMAXF, NasInlStepOptNDESIR,
NasInlStepOptSFACT, NasInlSte-pOptINTOUT, NasInlStepOptNSMAX, NasInlStepOptIDAMP,
NasInlStepOptDAMP, NasInlStepOptEnableCri-teria, NasInlStepOptIPHYS, NasInlStepOptLIMTAR,
NasInlStepOptRSMALL, NasInlStepOptRBIG, NasInlStepOptIncrements, NasInlStepOptGroupIDs,
NasInlStepOptYT1_i, NasInlStepOptYT2_i, NasInlStepOp-tYT3_i, NasInlStepOptYT4_i,
NasInlStepOptMT1_i, NasInlStepOptMT2_i, NasInlStepOptMT3_i, NasInlSte-pOptMT4_i,
NasInlStepOptADJUST,NasInlStepOptMSTEP, NasInlStepOptRB, NasInlStepOptUTOL, NasInlStepOptTYPE,
NasInlStepOptDTINITFA, NasInlStepOptMINALR, NasInlStepOptMAXALR, NasInlSte-pOptSCALEA,
NasInlStepOptNDESIRA, NasInlStepOptNSMAXA, NasInlStepOptMECH, NasInlStepOpt-ConvU,
NasInlStepOptConvP, NasInlStepOptConvW, NasInlStepOptConvV, NasInlStepOptConvN,
NasInlStepOptConvA, NasInlStepOptEPSU, NasInlStepOptEPSP, NasInlStepOptEPSW, NasInlStepOptK-
METHOD, NasInlStepOptKSTEP, NasInlStepOptMRCONV, NasInlStepOptMAXQN, NasInlStepOptMAXLS,
NasInlStepOptLSTOL, and NasInlStepOptFSTRESS attributes to specify options in the various dialog boxes
for MSC Nastran SOL 400 Control Parameters in an Analysis Step.

Added NasModeOn, NasModeEigrSet, NasModeMethod, NasModeSolutionType, NasModeEstRoots,
NasMod-eDesiredRoots, NasModeNormOpt, NasModeNormNode, NasModeNormDOF,
NasModeMassForm, vNasMode-FreqRange, NasModesSkipEigr, vNasModeImagFreqRange,
NasModesComplexConverge, NasModesComplexRegionWidth, and NasModeDampOverall in the
NASTRAN Modal Analysis dialog box for an Analysis Step.

Added BCSet, vBCSet, ContactOption, and ContactSetType attributes to specify options in the Boundary
Condi-tions dialog box for an Analysis Step.
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Added Output, vOutput, Echo, Destination, Imaginary, CornerOutput, IntegrationOutput,
NasOmodesOn, NasO-modes, and NasCurvatureStrain attributes to specify options in the NASTRAN
Output Requests dialog box for an Analysis Step.

• Added GlobalStep (feGlobalStep) object to the API.

Added GlobalStepTitle, GlobalStepLabel, globalstepID, GlobalStepAnalysisType, SkipStandard,
NasGlobalAlter-nateTextLocation, StartText, and EndText attributes to specify options in the MSC
Nastran SOL400 Global Analysis Step dialog box.

Added NasInlStepOptOn, NasInlStepOptSkipNLSTEP, NasInlStepOptID, NasInlStepOptTOTTIM,
NasInlSte-pOptCTRLDEF, NasInlStepOptMAXITER, NasInlStepOptMINITER, NasInlStepOptMAXBIS,
NasInlStepOpt-CREEP, NasInlStepOptLoadStepping, NasInlStepOptNINC, NasInlStepOptNO,
NasInlStepOptDTINITF, NasInlStepOptDTMINF, NasInlStepOptDTMAXF, NasInlStepOptNDESIR,
NasInlStepOptSFACT, NasInlSte-pOptINTOUT, NasInlStepOptNSMAX, NasInlStepOptIDAMP,
NasInlStepOptDAMP, NasInlStepOptEnableCri-teria, NasInlStepOptIPHYS, NasInlStepOptLIMTAR,
NasInlStepOptRSMALL, NasInlStepOptRBIG, NasInlStepOptIncrements, NasInlStepOptGroupIDs,
NasInlStepOptYT1_i, NasInlStepOptYT2_i, NasInlStepOp-tYT3_i, NasInlStepOptYT4_i,
NasInlStepOptMT1_i, NasInlStepOptMT2_i, NasInlStepOptMT3_i, NasInlSte-pOptMT4_i,
NasInlStepOptADJUST,NasInlStepOptMSTEP, NasInlStepOptRB, NasInlStepOptUTOL, NasInlStepOptTYPE,
NasInlStepOptDTINITFA, NasInlStepOptMINALR, NasInlStepOptMAXALR, NasInlSte-pOptSCALEA,
NasInlStepOptNDESIRA, NasInlStepOptNSMAXA, NasInlStepOptMECH, NasInlStepOpt-ConvU,
NasInlStepOptConvP, NasInlStepOptConvW, NasInlStepOptConvV, NasInlStepOptConvN,
NasInlStepOptConvA, NasInlStepOptEPSU, NasInlStepOptEPSP, NasInlStepOptEPSW, NasInlStepOptK-
METHOD, NasInlStepOptKSTEP, NasInlStepOptMRCONV, NasInlStepOptMAXQN, NasInlStepOptMAXLS,
NasInlStepOptLSTOL, and NasInlStepOptFSTRESS attributes to specify options in the various dialog boxes
for MSC Nastran SOL 400 Control Parameters in a Global Step.

Added NasModeOn, NasModeEigrSet, NasModeMethod, NasModeSolutionType, NasModeEstRoots,
NasMod-eDesiredRoots, NasModeNormOpt, NasModeNormNode, NasModeNormDOF,
NasModeMassForm, vNasMode-FreqRange, NasModesSkipEigr, vNasModeImagFreqRange,
NasModesComplexConverge, NasModesComplexRegionWidth, and NasModeDampOverall in the
NASTRAN Modal Analysis dialog box for a Global Step.

Added BCSet, vBCSet, ContactOption, and ContactSetType attributes to specify options in the Boundary
Condi-tions dialog box for a Global Step.

Added Output, vOutput, Echo, Destination, Imaginary, CornerOutput, IntegrationOutput,
NasOmodesOn, NasO-modes, and NasCurvatureStrain attributes to specify options in the NASTRAN
Output Requests dialog box for a Global Step.

• Added PublishTool (fePublishTool) object to the API. In addition, added PublishTable, which can be
used by the PublishTable object to the API. PublishTool and PublishTable have no attributes, only
methods.

• Added NasInlStepOptOn, NasInlStepOptSkipNLSTEP, NasInlStepOptID, NasInlStepOptTOTTIM,
NasInlSte-pOptCTRLDEF, NasInlStepOptMAXITER, NasInlStepOptMINITER, NasInlStepOptMAXBIS,
NasInlSte-pOptCREEP, NasInlStepOptLoadStepping, NasInlStepOptNINC, NasInlStepOptNO,
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NasInlStepOptDTINITF, NasInlStepOptDTMINF, NasInlStepOptDTMAXF, NasInlStepOptNDESIR,
NasInlStepOptSFACT, NasInlSte-pOptINTOUT, NasInlStepOptNSMAX, NasInlStepOptIDAMP,
NasInlStepOptDAMP, NasInlStepOptEna-bleCriteria, NasInlStepOptIPHYS, NasInlStepOptLIMTAR,
NasInlStepOptRSMALL, NasInlStepOptRBIG, NasInlStepOptIncrements, NasInlStepOptGroupIDs,
NasInlStepOptYT1_i, NasInlStepOptYT2_i, NasInlSte-pOptYT3_i, NasInlStepOptYT4_i,
NasInlStepOptMT1_i, NasInlStepOptMT2_i, NasInlStepOptMT3_i, NasIn-lStepOptMT4_i,
NasInlStepOptADJUST,NasInlStepOptMSTEP, NasInlStepOptRB, NasInlStepOptUTOL,
NasInlStepOptTYPE, NasInlStepOptDTINITFA, NasInlStepOptMINALR, NasInlStepOptMAXALR, NasInl-
StepOptSCALEA, NasInlStepOptNDESIRA, NasInlStepOptNSMAXA, NasInlStepOptMECH, NasInlSte-
pOptConvU, NasInlStepOptConvP, NasInlStepOptConvW, NasInlStepOptConvV, NasInlStepOptConvN,
NasInlStepOptConvA, NasInlStepOptEPSU, NasInlStepOptEPSP, NasInlStepOptEPSW, NasInlStepOptK-
METHOD, NasInlStepOptKSTEP, NasInlStepOptMRCONV, NasInlStepOptMAXQN, NasInlStepOpt-MAXLS,
NasInlStepOptLSTOL, and NasInlStepOptFSTRESS attributes to specify options in the various dialog
boxes for MSC Nastran SOL 400 Control Parameters via an Analysis Case Object.

• Added a number of attributes to the Analysis Manager Object.

Added NasModeSelOn, NasModeSelInc, and NasModeSel attributes to specify options in the NASTRAN
Modal Analysis dialog box via an Analysis Manager Object.

Added NasDdamSelModeMethod and NasDdamSelModeVal attributes to specify options in the NASTRAN
DDAM Solution Options dialog box via an Analysis Manager Object.

Added NasNonlinBehaviorOn, NasNonlinBehaviorCreepExp, NasNonlinBehaviorEnable,
NasNonlinBehavior-CreepType, NasNonlinBehaviorCreepImp, NasNonlinBehaviorASSM,
NasNonlinBehaviorTSHEAR, NasNonlin-BehaviorLRGSTRN, NasNonlinBehaviorPROPMAP,
NasNonlinBehaviorPROPBEH, NasNonlinBehaviorDIRECT, NasNonlinBehaviorTHICKOP,
NasNonlinBehaviorIPRINT, NasNonlinBehavior-VALD1, NasNonlinBehaviorVALD2,
NasNonlinBehaviornINLAM, NasNonlinBehaviorCreepOn, NasNonlinBe-haviorCPROJ attributes to specify
options in the Nonlinear Behavior Options dialog box via an Analysis Manager Object.

Added NasAutoCtOn, NasAutoCtEnabled, NasAutoCtBodyVal, NasAutoCtCTYPE, NasAutoCtDISTANCE,
NasAutoCtESET, NasAutoCtSeedESet, NasAutoCtSeedGSet, NasAutoCtPropSet, NasAutoCtRigidSet,
NasAuto-CtBEAMCNT, NasAutoCtBEAMCAP, NasAutoCt2D, NasAutoCtEDGECNT, NasAutoCtFTYPE,
NasAutoCt-FRIC, NasAutoCtFRICTABLE, NasAutoCtFRICVal, NasAutoCtIGNTHK, NasAutoCtINISTF,
NasAutoCtSelfCont, NasAutoCtRegion, and NasAutoCtConProp attributes to specify options in the
Automatic Contact Generation dialog box via an Analysis Manager Object.

Added NasMscCtTHKOFF, NasMscCtLINCNT, NasMscCtSFNPNLT, NasMscCtSFTPNLT, NasMscCtFGCFLG,
NasMscCtFGCNST, NasMscCtFGCTST, NasMscCtFGCNSTR, NasMscCtFGCTSTR, NasMscCtFGCNST1,
NasMscCtFGCTST1, and NasMscCtFGCRCEN attributes to specify options in the MSC Nastran Contact
Solver Parameters dialog box via an Analysis Manager Object.

Added NasInlStepOptOn, NasInlStepOptSkipNLSTEP, NasInlStepOptID, NasInlStepOptTOTTIM,
NasInlSte-pOptCTRLDEF, NasInlStepOptMAXITER, NasInlStepOptMINITER, NasInlStepOptMAXBIS,
NasInlStepOpt-CREEP, NasInlStepOptLoadStepping, NasInlStepOptNINC, NasInlStepOptNO,
NasInlStepOptDTINITF, NasInlStepOptDTMINF, NasInlStepOptDTMAXF, NasInlStepOptNDESIR,
NasInlStepOptSFACT, NasInlSte-pOptINTOUT, NasInlStepOptNSMAX, NasInlStepOptIDAMP,
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NasInlStepOptDAMP, NasInlStepOptEnableCri-teria, NasInlStepOptIPHYS, NasInlStepOptLIMTAR,
NasInlStepOptRSMALL, NasInlStepOptRBIG, NasInlStepOptIncrements, NasInlStepOptGroupIDs,
NasInlStepOptYT1_i, NasInlStepOptYT2_i, NasInlStepOp-tYT3_i, NasInlStepOptYT4_i,
NasInlStepOptMT1_i, NasInlStepOptMT2_i, NasInlStepOptMT3_i, NasInlSte-pOptMT4_i,
NasInlStepOptADJUST,NasInlStepOptMSTEP, NasInlStepOptRB, NasInlStepOptUTOL, NasInlStepOptTYPE,
NasInlStepOptDTINITFA, NasInlStepOptMINALR, NasInlStepOptMAXALR, NasInlSte-pOptSCALEA,
NasInlStepOptNDESIRA, NasInlStepOptNSMAXA, NasInlStepOptMECH, NasInlStepOpt-ConvU,
NasInlStepOptConvP, NasInlStepOptConvW, NasInlStepOptConvV, NasInlStepOptConvN,
NasInlStepOptConvA, NasInlStepOptEPSU, NasInlStepOptEPSP, NasInlStepOptEPSW, NasInlStepOptK-
METHOD, NasInlStepOptKSTEP, NasInlStepOptMRCONV, NasInlStepOptMAXQN, NasInlStepOptMAXLS,
NasInlStepOptLSTOL, and NasInlStepOptFSTRESS attributes to specify options in the various dialog boxes
for MSC Nastran SOL 400 Control Parameters in the Master Case of an Analysis Set via Analysis Manager
Object.

• Added SurfaceContactFlag, FrictionType, FrictionValue, FrictionTable, SmoothingControl,
ContactCheck, MidNodeProjection, DiscontinuityValue, ControlNode, MotControlType,
RotControlNode, AngVelFlag, AngVelTable, AngVelValue, RotAxisFlag, RotAxisTable, RotAxisValue,
MotionFlag, MotionTable, Motion-Value, AppAngVelVal, AppRotAxisVal, AppVelVal, GrowthComp, and
GrowthTable attributes to the Con-nection Region Object.

• Added ContourElemBreakLinearParabolic attribute to the View Object.

New and Updated API Methods

• Added InitAnalysisStep, DeleteAnalysisStep, and ActiveContactEntities methods to the AnalysisStep
Object.

• Added InitGlobalStep, DeleteGlobalStep, and ActiveContactEntities methods to the GlobalStep Object.

• Added Clear, SetFormat, SetParagraphIndent, SetParagraphAlignment, SetParagraphSpacing,
AddStyle, AddParagraph, AddPicture, AddView, AddDataTable, AddFunctionTableEditor,
AddEntityEditor, AddMes-sages, AddChart, UserTable, PublishToClipboard, and PublishToFile methods
to the PublishTool Object. In addition, added AddColumn, AddColumnGroupTitle, AddRowNumbering,
SetRealFormat,SetTableStyle, SetRowTitle, SetCellStyle, SetCellReal, SetCellInteger, SetCellText,
SetMultiCellStyle, SetMultiCellReal, SetMultiCellInteger, SetMultiCellText, and Publish methods for
PublishTable.

• Added IsNotEmpty, HasOne, and HasMultiple methods to the Set Object.

• Added GetStep, PutStep, and DeleteStep for MSC Nastran SOL 400 to Analysis Case Object.

• Added RemoveDuplicates method to the Connection Region Object.

• Added IsFreeEdge and IsOnSolidRegion methods to the Curve Object.
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The following functions have been added or updated:

• feAppLoadColorPalette

• feAppLoadContourPalette

• feGroupCondense

• feMeshSizeCurve2

• feMeshSizePropagate

• feSurfaceMidAuto4

• feCheckElemInterference2

New and updated Global Variables

• Added Pref_NewPick to set the New Picking preference on the Graphics tab of File, Preferences.

• Added Pref_Filter_Analysis to set the Enable Analysis Filtering option on the Interfaces tab of
File, Prefer-ences. In addition, added Pref_Filter_SC_Nastran_Linear, Pref_Filter_SC_Nastran_MSNL,
Pref_Fil-ter_SC_Nastran_MSNLK, Pref_Filter_SC_Nastran_ADVNL, Pref_Filter_SC_Nastran_ADVNLE,
Pref_Filter_MSC_Nastran, Pref_Filter_Autodesk_Nastran, Pref_Filter_ABAQUS, Pref_Filter_ANSYS,
Pref_-Filter_DYNA, Pref_Filter_SINDA, and Pref_Filter_MARC to control the individual options in the
Select Solv-ers to Filter dialog box.

• Added Info_MeshSizePropagation_On to enable the Propagate Sizing
option in the dialog boxes for various Mesh Sizing commands.
In addition, added Info_MeshSizePropagation_SelMode, Info_MeshSizePropaga-
tion_SlavedMapped, Info_MeshSizePropagation_EdgeOption, Info_MeshSizePropagation_SameSolid,
Info_MeshSizePropagation_UseTolerance, and Info_MeshSizePropagation_Tolerance to control the
options in the Mesh Sizing Propagation Options dialog box.

• Added Pref_API_UseAlternateFileDialog and Pref_API_HonorWorkingDirectory to control specify
options needed for improved access for Teamcenter Simulation (TC Sim).

Preferences

Graphics

• Added New Picking to the Graphics Options section.

When on, which is the default, New Picking uses new picking introduced in version 2021.1 which takes
advantage of Open MP to improve performance when selecting a large number of entities from the
graphics window, especially when using area picking (Box, Circle, Polygon, or Freehand) and/or Front
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Pick. Unless there is a problem picking entities, New Picking should remain on. Fast Picking uses older
picking methods, but for the time being should also remain on. Eventually, New Picking will become
the only available option and these preferences will be removed.

• Updated OpenMP in the Advanced/Debug Options section. To be activated by default. In addition,
now set a default value of 4 for Number of Threads.

If any issues are encountered when using this option, please deactivate this option, and then contact
Customer Support to describe the issue.

This option, which is on by default, activates OpenMP functionality (i.e. multi-threading). Once
activated, click the Options... button to set Number of Threads, which should not exceed the number
of cores available on the machine running Femap. The default for Number of Threads is 4.

This functionality has been implemented to improve performance for a limited number of commands
and operations including:

___ Picking done when the New Picking option is activated.
___ When using the View → Advanced Post → Dynamic IsoSurface and View → Advanced Post

→ Cynamic Cutting Plane commands.
___ Placing a contour plot on certain types of entities when post-processing

Interfaces

• Added an Enable Analysis Filtering option and a Select Analysis Filters icon button, which accesses
the Select Solvers to Filter dialog box.

When activated, this option is used in conjunction with the solvers selected using the Select Analysis
Filters icon button to limit solver-specific options found in various locations throughout Femap,
including dialog boxes and dockable panes.

Preferences
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Solvers which can be filtered are MSC Nastran, Autodesk Nastran, LS-DYNA, ABAQUS, ANSYS, SINDA,
and MARC. For Simcenter Nastran, certain analysis types can be filtered, including Linear (Contact
options including glued contact for most solution sequences), Multistep Structural (SOL 401), Multistep
Kinematic (SOL 402), Advanced Nonlinear (SOL 601), and/or Explicit (SOL 701).

The All Off button can be used to quickly select all options, while All Off can quickly deselects all
options.
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